macOS High Sierra 10.13 Works/Does Not Work Thread

Discussion in 'macOS High Sierra (10.13)' started by bradhs, Jun 5, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. GeorgieJ macrumors newbie

    Joined:
    Nov 16, 2017
    #701
    I was using InDesign CS4. It worked perfectly all the way up to yesterday morning using Sierra. I upgraded to High Sierra midmorning and it no longer works. My problem is that the folks I worked for for 18 years (I retired in 2012) come back to me every so often to update the publications I did for them. At the moment I am updating a 200 page book. It is, in fact, off at the proofreaders. Once it comes back to me I need to make whatever corrections they ask for and then update the index. I obviously can't do a blasted thing now and am in total panic mode. I called Adobe last night and the Adobe rep suggested I downloaded CS6. He said I should be able to download, use it as a trial, and pay for it as an upgrade. He said it might work since it's something like the last version before the subscription. From this forum, it looks like CS6 will work. I couldn't download it, though; it said I needed to download Adobe Support Supervisor, which is no longer available. Today Adobe told me of course I'm not allowed to do that. Anybody have any solutions? I finally broke down and started to cry. I need to open that job or I am so screwed. And no, since i'm basically retired I do not want a monthly subscription.
     
  2. Mac Hammer Fan macrumors 6502a

    Mac Hammer Fan

    Joined:
    Jul 13, 2004
    Location:
    Belgium
    #702
    I hope you have a bootable clone of your previous system Sierra. I suggest you to erase High Sierra and clone your backup with Carbon Copy Cloner.
     
  3. GeorgieJ macrumors newbie

    Joined:
    Nov 16, 2017
    #703
    The Apple support guy wanted me to do that while he had me on the phone last night. While I might be really good at working in InDesign and doing artwork, I am totally stupid when it comes to computers themselves. No, no bootable copy of Sierra that I know of. He wanted me to run to WalMart and buy a cheap hard drive so he could use it for loading Sierra onto and then another harddrive to back up my computer and then whatever steps for getting the computer back to Sierra, etc. and so on. But I'm not that close to a WalMart. And the idea of it also kind of freaked me out. Now if my daughter was still living with the guy who worked for Apple then he could have come here in person and fixed it while I agonized in the kitchen and cooked dinner ... but nope. Do you think it's easier -- and possibly better -- to revert to Sierra than it is to somehow get InDesign CS6?
     
  4. Mac Hammer Fan macrumors 6502a

    Mac Hammer Fan

    Joined:
    Jul 13, 2004
    Location:
    Belgium
    #704
    Unfortunately the problem is I don't know whether the installers of CS4 or CS6 will work in Sierra. I have updated CS6 in the past from Mountain Lion to the higher systems. Perhaps someone else can confirm whether the installers still work? If this is the case, if I were you I would backup my files, erase HS, do a clean install of Sierra and reinstall CS4. Fingers crossed.
     
  5. GeorgieJ macrumors newbie

    Joined:
    Nov 16, 2017
    #705
    Earlier on in this thread I saw someone wrote that CS6 worked as long as Java Legacy was installed. I think it's Java Legacy se6. I forget the exact file name. But I downloaded that last night while I had the Apple support person on the phone, so I have that. So, according to whoever posted that earlier in this discussion, that version of InDesign should work. But the Adobe folks won't let me download it. I tried anyhow, but ... got a message right at the end saying I needed Adobe Support Advisor. Which is no longer available on the Adobe site. I'm not sure the download would work anyhow, but I thought it worth a try. They are the most unhelpful.
     
  6. Mikovich macrumors newbie

    Mikovich

    Joined:
    Nov 17, 2017
    #706
    Found this post via a google search. After having upgraded to High Sierra I have now noticed that Hyperdock no longer works. It works for a minute or so after booting up the machine, and then all features stop to function. Going into settings and stopping and restarting the app makes it work again.

    Your list states that version 1.7 works. It does not. :( I miss it already.

    I hate it how this happens every time Apple updates their OS.
     
  7. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #707
    an OS update, by definition, is a change in the OS. it's revised code, it's inevitable that it will break some apps. so, we update, then deal with the consequences, or... we stay where we are. you can't have it both ways (new OS, perfect compatibility with older apps).

    meanwhile, if the claim i that 1.7 works, perhaps try uninstalling the app? then installing the latest? (just a thought, i don't use hyperdock).
     
  8. Mikovich macrumors newbie

    Mikovich

    Joined:
    Nov 17, 2017
    #708
    Yes, Im not a complete noob. I know what an OS update is. Its just interesting how common it is, for Mac OsX updates to break apps and add bugs that weren't there before.

    Of course I tried uninstalling and installing the latest version - no difference whatsoever. The app is broken in High Sierra and seems to be abandoned by the guy who made it. Shame. I'll have to look for an alternative.
     
  9. Sciuriware macrumors 6502

    Sciuriware

    Joined:
    Jan 4, 2014
    Location:
    Gelderland
    #709
    Just an idea: try to re-install abandoned applications in a Virtual system, like VirtualBox or such.
    Of course THAT application should run OK! Well, VirtualBox 5.1.12 does (Running WindowsXp for now).
    ;JOOP!
     
  10. Mikovich macrumors newbie

    Mikovich

    Joined:
    Nov 17, 2017
    #710
    Thank you for the suggestion ;-) Unfortunately I don't see how it will resolve my problem with Hyperdock. I already have Parallels and Windows 10 installed... Never use it :p
     
  11. Sciuriware macrumors 6502

    Sciuriware

    Joined:
    Jan 4, 2014
    Location:
    Gelderland
    #711
    The same here. Until now I found alternatives all the time. Lots of SUCCESS!
    ;JOOP!
     
  12. Mikovich macrumors newbie

    Mikovich

    Joined:
    Nov 17, 2017
    #712
    The lord works in mysterious ways. i thought I uninstalled old version correctly. After updating CleanMyMac, I removed old version. now the newest version works after all. Praise Jebus.
     
  13. Sciuriware macrumors 6502

    Sciuriware

    Joined:
    Jan 4, 2014
    Location:
    Gelderland
    #713
    Congrats; then again: you're not alone: Time Machine no longer ignores my exclude lists after some reboots. How on ....
    ;JOOP!
     
  14. ashleykaryl macrumors regular

    ashleykaryl

    Joined:
    Jul 22, 2011
    Location:
    UK
    #714
    It seems to be working OK for me with 10.13.1. I did a clean install, so perhaps that is why I saw no problems.
     
  15. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #715
    seriously, did not mean to be rude. but if you're not a noob, then you should understand why it's common for osx to break some apps, and add some bugs... it's (partially) new code, and that is the nature of such things. it's always been like this, with each new mac OS version. either way, am glad you got this sorted out!
     
  16. docmartinhk macrumors newbie

    docmartinhk

    Joined:
    Nov 19, 2017
    #716
    I found this w Photoshop Elements
    Just tried a file with Affinity Photo, and worked just fine
     
  17. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #717
    Well I have purchased some actions using NIK Collection but there is a fix for this until DXO fixes and updates the plugins.

    So the idea is that whenever you open SIlver Efex Pro, Analogue Efex Pro or Color Efex Pro you need to make sure that the effects are applied to the same layer not to a separate one.

    To do that you have an option in the Menu of each Google NIK Plugin - what happens after clicking OK.
    The select apply to the current layer.
     
  18. SimonG50 macrumors newbie

    SimonG50

    Joined:
    Apr 12, 2017
    Location:
    Japan
    #718
    Dragon Naturally Speaking

    Dragon Professional Individual for Mac
    only working version is 6.0.8. This is from Dragon website and personal testing (my previous version 6.0.0 crashes instantly).

    Note: many users know how unstable this programme has been on Mac for years. Glad to report 6.0.8 seems incredibly stable.
     
  19. Bart Kela, Nov 26, 2017
    Last edited: Nov 26, 2017

    Bart Kela Suspended

    Bart Kela

    Joined:
    Oct 12, 2016
    Location:
    Searching...
    #719
    Actually, this is mostly the third-party developer's fault.

    Apple updates macOS on a fairly predictable schedule. They unveil the next macOS (and iOS and tvOS and watchOS) at WWDC in June. Then there is a beta period that lasts several months where developers (and brave consumers) have access to the beta.

    It is during the beta period where third-party developers should be diligently working to ensure their software is compatible with the future OS.

    The Hyperdock developers failed in maintaining that continuity. Worse, they apparently failed to communicate to users to avoid upgrading to the new OS because they weren't ready.

    The end user bears some responsibility here as well. If you rely on certain third-party applications to work, it is YOUR RESPONSIBILITY to find out if they will work on the new operating system.

    If the Hyperdock application is abandonware, well again it's the onus of the user to find a functional replacement.

    Expecting Apple to maintain backward compatibility with abandonware smacks of entitlement.
     
  20. Riwam macrumors 6502a

    Riwam

    Joined:
    Jan 7, 2014
    Location:
    Basel, Switzerland
    #720
    Did you find a solution in the meantime?
    I do not want to suggest things that are not supposed to be legal but through torrents it is possible to get CS6 if Adobe is not willing to help a customer who wants to do things right.:rolleyes:
     
  21. jethrogillgren macrumors newbie

    jethrogillgren

    Joined:
    Dec 2, 2017
    #721
    Hi, I Have no Edit button so can't change the wiki... maybe as it's a new account?

    Unity 5.6.4 (f1) is marked as Working on High Sierra 10.13 but it is not fully for me.
    It works on a simple project with no Graphics card work, but anything that does use the graphic card will randomly Crash Unity or the whole OS. It also seems to lag very slow in complex projects.


    Can someone update this for other users?
    "Crashes or freezes Unity, or OS in some situations"
     
  22. rraven macrumors newbie

    rraven

    Joined:
    Aug 31, 2017
    Location:
    Pacific Northwest
    #722
    I'm seeing this as well, along with warnings about files having been changed by another program (they weren't) followed by all files buffers opening onto empty files (they're not). I wonder if people are seeing/not seeing this is based on using/not using APFS.

    TextWrangler has been sunset by Bare Bones and they explicitly say that it isn't compatible with High Sierra:

    http://www.barebones.com/support/new-os.html

    I've been meaning (for too long) to move to BBEdit anyway. This is a pretty compelling incentive.
     
  23. sibcc, Dec 12, 2017
    Last edited: Dec 12, 2017

    sibcc macrumors member

    sibcc

    Joined:
    Oct 5, 2015
    Location:
    La Jolla CA
    #723
    That's because Apple is not nearly as good as they once were at adequately testing their OS before release. That Apple broke MS Office a few years back is an example of Apple's dereliction. When you release something that breaks, arguably, the most prevalent productivity application, then you're not doing something right. I place blame on the yearly cycle. An OS is not a piece of art, but rather, a mere tool that ought maintain reasonable compatibility with its application base.
     
  24. Sciuriware macrumors 6502

    Sciuriware

    Joined:
    Jan 4, 2014
    Location:
    Gelderland
    #724
    Of course macOS et all is still thoroughly tested .... by US!
    ;JOOP!
     
  25. 8megabits macrumors newbie

    Joined:
    Mar 15, 2015
    #725
    Did you ever get Safari Stand favicons to work in High Sierra?
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page