Major bug in iCloud Mail ??

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by CmdrLaForge, Feb 8, 2016.

Tags:
  1. CmdrLaForge macrumors 68040

    CmdrLaForge

    Joined:
    Feb 26, 2003
    Location:
    around the world
    #1
    Cheers,

    I have an Apple icloud ID that's basically my first name. Example: jordie@me.com : Now I get mails that are not mine that start with the same first name but add e.g a last name, example: jordie.laforge@me.com

    I have seen an increase lately.

    How could that be? Is Apple using only the first 8 letters or something ? I think this is a major glitch. I am also worried if others get my emails...

    What you think?

    LaForge
     
  2. lascott macrumors member

    Joined:
    Oct 28, 2007
    Location:
    Baltimore
    #2

    Maybe it ignores everything after the . but still shows it as being the TO address.

    I get a ton of emails where people forgot to add the numbers after their username.. including many of their social security numbers/income/employment info.. it's amazing how careless people are :) I've even called one of them and asked why they keep using my email, and all they could say was "i forgot to give the numbers at the end of my username".

    So now I just cancel their orders, pizza deliveries.. one day they will get their email address correct. It's so bad I've stopped using gmail/icloud and use my domain now.
     
  3. CmdrLaForge thread starter macrumors 68040

    CmdrLaForge

    Joined:
    Feb 26, 2003
    Location:
    around the world
    #3
    Thanks. This could be it. I usually just delete those emails even so some are just to funny. I get a lot from obviously elder people.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    I just tried emailing myname.gibberish@me.com and it bounced. It seems that iCloud doesn't ignore what's after the . so that doesn't seem to be the issue.
     
  5. CmdrLaForge thread starter macrumors 68040

    CmdrLaForge

    Joined:
    Feb 26, 2003
    Location:
    around the world
    #5
    I assume it must be like a glitch. Because there are not a lot. Actually after I posted this thread I check again and I could only find 1 or 2 with this exact issue. The others are just a different name in the header then mine. Also the address I am seeing is difficult to understand on my ipad
     

Share This Page