No internet via Wifi on iPhone6 since IOS 10.2

Discussion in 'iOS 10' started by Dinky2, Jan 13, 2017.

  1. Dinky2 macrumors newbie

    Joined:
    Nov 21, 2010
    #1
    Since the installation of IOS 10.2On my iPhone6 I am having problems connecting to the internet via Wifi. The Wifi connection itself works fine, but there is no internet behind it. Resetting Wifi or resetting the iPhone will in some cases "solve" the problem, but only for a short while.
    I have read many issues with connecting to Wifi since IOS 10.2, but that is not my problem. I have issued a bug report to Apple, but they haven't reacted in any way so far.

    We also own an iPhone6s, which does not seem to have the problem, nor does the problem exist on our iPads running IOS9. So the internet connection itself is OK, since we can use it from all devices, including Ethernet attached ones.

    Does any of you have a suggestion (except completely re-install the phone) ?
     
  2. LoveToMacRumors macrumors 68000

    LoveToMacRumors

    Joined:
    Feb 15, 2015
    Location:
    Canada
  3. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #3
    Reboot your router. (even though other devices seem to be ok)
     
  4. graley macrumors regular

    Joined:
    May 25, 2010
    Location:
    Australia
    #4
    Same here with 6s. Other devices ok. But i need to restart router often. Pain
     
  5. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #5
    Sometimes on 6s I seem to have the "stuck" connection as well whereby mail never updates and spinner keeps going, or other apps seem to not be connected and spinner goes but wifi is connected. I can go to control center and quickly toggle wifi off/on and it gets it back functioning. Not sure if its an extended sleep period or what but definitely something going on with wifi since iOS 10.
     

Share This Page