Noise from processor when scrolling

HylianKnight

macrumors 6502
Original poster
Jul 18, 2017
303
303
2013 mbpr

So I was scrolling through iCloud photos today on safari using my rMBP when I noticed a relatively quiet, albeit noticeable clicking like sound coming from what I believe is the area where the processor is located (near the esc key). I searched online but found no real answer.

I did some testing using gfxxardstatus to switch between the integrated and discrete graphics. The noise only occurs when utilizing the intel integrated graphics. When using the discrete gfx card there is no noise. So, my question is, is this normal or not? If no, what steps would you recommend? Does your mbpr make this noise when scrolling a page with heavy media content?
 
Last edited:

HylianKnight

macrumors 6502
Original poster
Jul 18, 2017
303
303
Rear center, I know where the heat pipes go over so I’m not sure why I said esc key. The noise is most definitely coming from either the processor or potentially a fan.

My thinking is that when running the intel integrated graphics, the processor is stressed more. This leads to either the processor or a fan as the source of the noise. Since it occurs when scrolling or “processor intensive” tasks, my money is on the processor. I will manually put my fans at high rpm and slowly lower the rpm tomorrow to see if it could be a bearing, but I have my doubts about that.

Also, amazingly fast reply, much appreciated (;
 
Last edited:

Niklas_nick

macrumors regular
Dec 12, 2016
152
206
I have the same issue on my 2014 rMBP sometimes when the computer has been running for some time and not been restarted for some time. It only happens while scrolling. A shutdown and restart usually solves it for me, but I'm still wondering what makes the sound. Maybe from the fan?
I would describe the sound like a HDD working fast or scrolling really fast on an old iPods click wheel.
 

duffyanneal

macrumors 6502a
Feb 5, 2008
658
101
ATL
Sounds like coil whine. It varies depending on the load on the CPU/system. Not sure if this was common in your vintage machine. I know that it is fairly common on non-Mac systems, and I had a Macbook Pro a few generations back that had horrible coil whine. The fix at the time was to open Photo Booth. Not exactly an elegant solution.
 

naho

macrumors newbie
Oct 11, 2018
1
0
My guess is the AC power transformer. See if the sound goes away when unplugged.
I had same issue and in my case it is as you suggested AC power transformer.
Noise disappears when unplugged.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.