iPhone Predictive text error "I" to "A [?]"

eking511

macrumors newbie
Original poster
Oct 30, 2017
2
5
I have an iPhone 7, running 11.0.3

Whenever the keyboard opens up the first recommended word for predictive text is "A [?]" except the bracketed ? is what shows up when you don't have a new emoji and someone sends it to you. I have tried a hard reboot, resetting the keyboard, turning off predictive text/ autocorrect, and have checked to make sure that is isn't in the text replacement menu. When I type the letter "I" it autocorrects to A [?]. I don't know what else to do at this point. I reset all settings and it still isn't resolved. I attached an image for reference. Does anyone have any idea what is going on?

IMG_1171.jpg
 

havok24

macrumors newbie
Jun 7, 2012
2
3
I'm having the same issue on my iPhone 8. A workaround is to just turn off predictive text, but it's certainly annoying. It shows up in all apps (and even sends the weird character on mail and gchat). It seems to be tied to your iCloud account, because i see those weird characters on my iMac, although i cannot actually type in that character from the iMac.

If you restore and don't sign in to iCloud, the issue goes away, but that's obviously unsustainable. I've been on the phone with AppleCare for a long while at this point...
[doublepost=1509411183][/doublepost]I should mention that i know 2 other people who are having this issue.
 

kuronya

macrumors newbie
Oct 30, 2017
8
1
I am also having this same issue, though on occasion it actually shows up on my MBP too. I have a friend who is also experiencing this.
 
  • Like
Reactions: Kuuursten19

stephen_timberlake

macrumors newbie
Oct 30, 2017
1
2
Hello MacRumors!

Yesterday I and a few of my friends started experiencing a bug when typing in the letter "i". The suggestion for "i" changes the letter to "A [?]" or "! [?]". I even noticed that, in the emojis keyboard, it shows under my frequently used tab the letter "i".

It's very frustrating! Here are two screenshots of the bug from my iPhone 8 plus running iOS 11.0.3 :
fullsizeoutput_4a83.jpeg IMG_5342.jpg
 

stephen1108

macrumors 65816
Sep 30, 2007
1,068
160
Hey guys, so this just started happening yesterday and IDK what's causing it (I didn't do any changes to my settings).

Whenever I type the letter "I" on my iOS device, it displays fine, but when I send a message off with it, it will either display as an "A � " or the actual "I" I meant to type.

For example, here's a case of it happening on my iPhone in Telegram earlier, I've noticed if the recipient is using an iOS or Apple device they'll receive it fine, but Android devices are unaffected:



Then on MacOS High Sierra:


It only happened in one instance here, but the funny thing is on my phone's end it looks fine (on my MacBook in Messages is where it looks crazy).

If I copy and paste that character combo, it just turns into an "I".

Does anyone have any insight on this? The only thing I can think of is I'm using iOS 11.1 Beta 5 on my iPhone, but this just started yesterday and it's not a problem with messages sent from my iPad or MacBook. I also can't find anything online about it with the search criteria I'm using.
[doublepost=1509432900][/doublepost]Resetting my keyboard dictionary does nothing, but I noticed this happening:



Why is my letter "I" auto correcting to this weird thing? I even set "I" to "I" as a text replacement in Text Shortcuts, and still nothing.
[doublepost=1509433187][/doublepost]https://forums.macrumors.com/threads/predictive-text-error-i-to-a.2082250/
https://forums.macrumors.com/threads/letter-i-bug.2082329/

Oh I just scrolled down and saw more people are dealing with this too... This needs to be on the front page.
[doublepost=1509433475][/doublepost]https://www.reddit.com/r/iphone/comments/79qgrp/whats_wrong_with_my_i_screenshots_inside/
https://www.reddit.com/r/apple/comments/79t2hw/can_someone_please_tell_me_what_the_heck_is_going/
https://www.reddit.com/r/apple/comments/79tjya/keyboard_and_the_letter_i_on_the_iphone/

I also found people complaining about the same thing on Reddit too, this is a serious bug. It impacts daily things like sending a simple text message to someone.
 
Last edited:

stephen1108

macrumors 65816
Sep 30, 2007
1,068
160
My personal fix since I can't deal without auto correct, is to use Gboard on my iPhone and iPad.

This bug is really a PITA and doesn't make any sense.
 
Last edited:
  • Like
Reactions: Rhonindk

eking511

macrumors newbie
Original poster
Oct 30, 2017
2
5
Yeah, mirroring some of those above, I have just switched to using gboard for now as well.
 

stephen1108

macrumors 65816
Sep 30, 2007
1,068
160
Same thing started happening to my boyfriend too yesterday, I'm just finding out though.

Who do we have to bring this to the attention to so it gets front page news?
 

theheadguy

macrumors 65816
Apr 26, 2005
1,123
1,322
california
Yup. It's happening to me, too. What a pain in the ...

Edit: FWIW, I just called Apple Support and after considerable hold time, they told me they are aware of the issue and are already working on it. They don't yet have their internal support web pages updated to reflect this known issue, but it is indeed on their radar as they continue to "work on it".
 
Last edited:

superspud

macrumors regular
Dec 6, 2007
235
0
happening for me as well on my 7+

incredibly annoying.

just updated to 11.1 and it didnt fix anything.
 

ee99ee

macrumors 6502
Mar 9, 2006
269
3
Yesterday my friend who also uses iOS 11.1 mentioned that every time he types 'I' it becomes some weird 'A ?' with a box around the question mark overlaid on the 'X' for the autocorrect popup bubble.

I thought he was crazy.

Then, today, out of nowhere... it started happening to me!!



What the hell is this???
 
  • Like
Reactions: jayewatts

Kb522

macrumors member
Mar 15, 2011
51
3
This is happening to me as well and several others I know. I posted on Apple Forums last night, but I did not get any responses. It's very strange!

Anyway, the auto correct is happening in other apps on my phone now as well. It started before I updated to 11.1, so I did the update, did a hard reset on my phone and even rest the Keyboard Dictionary, but it is still happening.
 
Last edited by a moderator:
  • Like
Reactions: Slsanford

ncsmith4

macrumors 6502
Jul 15, 2007
331
4
Sometime in the past couple days, my suggestions above the keyboard have included an “A” with a question mark with a box around it. I have no idea what this is. Anyone else getting this??? It’s very frustrating.

UPDATE: Seems to occur only when typing "I." If I type just an "I" it will autocorrect to "A with question mark in a box" as seen in the pics.
 

Attachments

Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.