iPhone Predictive text error "I" to "A [?]"

Discussion in 'iOS 11' started by eking511, Oct 30, 2017.

  1. TDOB macrumors newbie

    Joined:
    Oct 9, 2017
    Location:
    Leawood, KS
    #26
    Same as above with what everyone is experiencing. I spend a few hours on the phone with support last night and continued to get escalated to higher levels. I submitted 'crash reports' screenshots, etc. to the senior engineering advisor. I do know that resetting the keyboard does not fix it. If you sign out of your Apple ID and restart your phone, it will disappear, but once you log back in with your Apple ID it shows up again.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #27
    Could it be connected to some iCloud setting? Perhaps (in some weird way) Keychain or Safari or something else of that nature?
     
  3. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #28
    So it seems like it's a server side/iCloud issue, since it's impacting 11.0.3, 11.1 and 11.2?
     
  4. Prelate74 macrumors member

    Joined:
    Jun 15, 2010
    Location:
    Royal Oak, Michigan
    #29
    Yes this same thing is happening to me. I am wondering if this will be the case with my iPhone X that's coming?
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
  6. superspud macrumors regular

    Joined:
    Dec 6, 2007
    #31
    lets not let this disappear, there has to be a fix somewhere out there...

    I just realized that it does the same A [?] thing while typing emails as well, so thats cool.....
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #32
    Have you tried disabiling some iCloud settings to see if that might help?

    Also, there's a potential workaround for the moment that can help:

     
  8. superspud macrumors regular

    Joined:
    Dec 6, 2007
    #33
    neither appear to do anything for me :/



    edit - maybe it took a minute or two to take, because now its working. Thanks!

    edit again - the one that worked for me is the "work around" where you add the keyboard shortcut
     
  9. Jma1053 macrumors newbie

    Joined:
    Nov 1, 2017
    #34
    This has been driving me insane since yesterday, and apple support was no help. However, I did manage to fix it on my phone!! (Hoping it doesn’t come back). What I did was:

    I have my phone set to backup to iCloud, but not photos. I made sure my photos were backed up to my Mac, then disconnected from Mac, and then went into my iPhone’s iCloud to confirm it had been backing up recently. Then, yes I know this is scary, but I did an iPhone reset of “erase all content and settings” (this WILL erase everything if you do not have it backed up!!) after resetting, when prompted, sign in with iCloud and choose to restore from a backup. HOWEVER, choose a backup pre weird symbol thing, i.e. it was two days ago for me, so I chose oct 30th backup. Once it finished restoring, keyboard was back to normal! Let’s hope it stays....
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #35
    Certainly a workaround, but perhaps not the most practical one for many I would think. Might be simpler to try a workaround like creating a keyboard text replacement shortcut.
     
  11. Gregjburgess macrumors newbie

    Gregjburgess

    Joined:
    Nov 2, 2017
    #36
    This is really annoying.
    I can’t seem to find a fix anywhere.
    iOS 11.1 hasn’t fixed it at all.
    --- Post Merged, Nov 2, 2017 ---
    I did the same thing, but didn’t choose a restore from far enough back.

    It’s takes forever for everything to redownload. It’s such a pain to do it all over again.
     
  12. CoriG macrumors 6502

    Joined:
    Jun 7, 2011
    #37
    Is anyone getting a weird symbol when they type a capital I on their phone? This just started happening this morning.
     
  13. CoriG macrumors 6502

    Joined:
    Jun 7, 2011
    #39
    I️ (this is what I️ am getting when I️ type I️)
    --- Post Merged, Nov 2, 2017 ---
    It is showing up different on my iphone.. IMG_A34CE2D10102-1.jpeg
     
  14. applesince1991 macrumors newbie

    applesince1991

    Joined:
    Nov 2, 2017
    #40
    This has been happening to me, suddenly, today. I tried a software update and a reset with no luck. I do not have predictive text on, so I ended up turning off autocorrect to fix, which is so annoying as autocorrect is super necessary. Also, though, autocorrect has been super weird out of nowhere as well—recently changing "talk" to "y'all" (a word I never have used)
     

    Attached Files:

  15. TMG357 macrumors newbie

    TMG357

    Joined:
    Nov 2, 2017
    #41
    This is happening to me too. "I" is turning into A [?] ever since I completed the latest update. It shows up like this in text and FB messenger. When will this be resolved?
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #42
    As mentioned in the quoted post below, it seems like creating and using a keyboard text replacement shortcut for this is the best workaround for the moment (short of perhaps disabling auto-correct and predictive features, or doing something even more impactful like singing out of iCloud or resetting settings if not even reinstalling).
     
  17. bribri99 macrumors regular

    Joined:
    Sep 3, 2014
    #43
    Same issue here. The weird thing is if someone write "I" from their iphone to my imessage on my computer, it looks all wrong though my iphone looks fine
     
  18. mwojno macrumors newbie

    mwojno

    Joined:
    Nov 2, 2017
    #44
    Settings > General > Keyboard > Text Replacement

    Shortcut: copy and paste the weird symbolizing (A ? with box around it).

    Phrase: Type an i or I.

    This is a work around to swap every occurrence of that weird symbolizing error and replace it with the correct unicode for I. This is strange that it is happening with no one updating even. Hopefully apple can push a solution shortly. Gotta love software sometimes...
    --- Post Merged, Nov 2, 2017 ---
    Settings > General > Keyboard > Text Replacement

    Shortcut: copy and paste the weird symbolizing (A ? with box around it).

    Phrase: Type an i or I.

    This is a work around to swap every occurrence of that weird symbolizing error and replace it with the correct unicode for I. This is strange that it is happening with no one updating even. Hopefully apple can push a solution shortly. Gotta love software sometimes...
     
  19. kojo0513 macrumors member

    Joined:
    Apr 29, 2014
    #45
    Came in to ask the same thing.


    I️
    I️
    I️


    Still doing it. :(
     
  20. atlchamp macrumors 65816

    Joined:
    Jun 19, 2012
    Location:
    ATL
    #46
    Mine is doing it on 11.2 beta 1 as well on iPhone 8
     
  21. venusfly- macrumors newbie

    venusfly-

    Joined:
    Nov 2, 2017
    Location:
    Philly → LA
    #47
    This just started happening for me yesterday! However, it's only happening in some apps that I use, like instagram. Not in iMessage. It'll suggest an autocorrect to change it to those characters, but I just click the 'X' to get rid of it, and then it'll send normally...So weird.

    However, one person's i's are coming up that way for me on my Mac's iMessage, but the same messages are coming up normal i's on my phone?...Absolute madness! Apple is not the same as it used to be.
     
  22. EM2013 macrumors 65816

    EM2013

    Joined:
    Sep 2, 2013
    #48
    Weird how so many are experiencing this, I’m not having this issue though *knocks on wood*

    How does Apple have the silliest of bugs!
     
  23. Robert1797 macrumors newbie

    Joined:
    Nov 3, 2017
    #49
    Apple's support staff is recommending customers affected by this bug use text replacement as a temporary workaround.

    To do this, go to Settings > General > Keyboard > Text Replacement. Type in an uppercase "I" for the phrase, and a lowercase "i" as the replacement.
     
  24. troubleshoot macrumors newbie

    troubleshoot

    Joined:
    Nov 3, 2017
    #50
    Just spoke to AppleCare and we fixed it by turning off autocorrect
     

Share This Page