iPhone Predictive text error "I" to "A [?]"

Discussion in 'iOS 11' started by eking511, Oct 30, 2017.

  1. blulegend macrumors regular

    Joined:
    Apr 15, 2008
    #51
    It started happening to me with 11.1. It happens to my wife and a couple friends but not with my brother who didn’t update to 11.1. Initially thought it was with 11.1 but reading here it doesn’t seem so. Was hard to search for this issue.
     
  2. Billburns macrumors 6502

    Billburns

    Joined:
    Mar 27, 2017
    Location:
    Usa
    #52
    Mine randomly happened last night but was fine all week... annoying as fufge
     
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #53
    The text replacement shortcut workaround sounds like a better way to go about it (unless one doesn't really care about autocorrect in general).
     
  4. nheilweil macrumors 6502a

    nheilweil

    Joined:
    Jul 10, 2008
    Location:
    Redmond, WA
    #54
    Same issue here on the 11.2 Beta. Sigh. I opened a bug.
     
  5. CoriG macrumors 6502

    Joined:
    Jun 7, 2011
    #55
    Did you turn autocorrect back on?
     
  6. FSUSeminole007 macrumors newbie

    Joined:
    Sep 17, 2014
    #56
    Is anyone else seeing this character appear when attempting to type the letter "I" in iMessage? Anyone know of a solve?

    [​IMG]
     
  7. bradhs macrumors member

    Joined:
    Jun 5, 2010
  8. SwissReymond macrumors newbie

    SwissReymond

    Joined:
    Nov 3, 2017
    #58
    I ran into this same problem and I just created a shortcut to have shortcut "i" turn into phrase "i". This seems to have fixed the problem. Settings - General - Keyboard - Text Replacement - and then create a new shortcut using the "+" in the top right corner.
     
  9. matty.p macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Portland, OR
    #59
    Tried this. Seems to reduce the problem but not fix it entirely unfortunately.
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #60
    The other things to try currently would be to disable autocorrect (and/or predictive).
     
  11. planelydesigned macrumors newbie

    Joined:
    Sep 24, 2014
    #61
    Didn't have this on my iPhone 6s, but since getting an X this has popped up. Super annoying because you don't even realize till after the fact.
     
  12. randy98mtu macrumors 65816

    randy98mtu

    Joined:
    Mar 4, 2009
    #62
    My wife’s phone and her associates are both doing this too. And my wife’s status bar is totally jacked in messages. Very irritating. Wish there was a real fix.
     
  13. kuronya macrumors newbie

    Joined:
    Oct 30, 2017
    #63
  14. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #64
    What's weak/odd about it? Seems to signify they are aware of the issue, working on a fix, and have a workaround the is listed that should alleviate some of the pain with the issue in the meantime.
     
  15. kuronya macrumors newbie

    Joined:
    Oct 30, 2017
    #65
    Following the steps does not fix the issue consistently for me, only turning off autocorrect does. It seems odd to me that was no mention of that nor of the fact that the issue also occurs on Macs connected to the same Apple ID
     
  16. Maya0024 macrumors newbie

    Joined:
    Nov 4, 2017
    #66
    I was going through the same thing and found a fix. If you go to Settings > General > Keyboard > Text Replacement - and then press the “+” in the top right hand corner you can just enter “I “ as the phrase and “I “ again as the shortcut. This works for me so far!

    Hope it helps
     
  17. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #67
    Basically what Apple recommends: https://support.apple.com/en-us/HT208240
     
  18. kimmeemore macrumors newbie

    kimmeemore

    Joined:
    Nov 4, 2017
    #68
    YUP!!! This has been happening to me too! Whenever I type "I" on my iPhone it turns into the A with a "?"

    If I go to view my previously written texts on my computer, all of the I's look like boxes.

     
  19. Maya0024 macrumors newbie

    Joined:
    Nov 4, 2017
    #69
    I was going through the same thing and found a fix. If you go to Settings > General > Keyboard > Text Replacement - and then press the “+” in the top right hand corner you can just enter “I “ as the phrase and “I “ again as the shortcut. This works for me so far!

    Hope it helps
     
  20. Nordiclum1 macrumors newbie

    Nordiclum1

    Joined:
    Nov 4, 2017
    #70
    when I️ type I’m leaving boxes and ! Behind. I’m not using emojis and have turned off the emoji keyboard all together. Seems to happen when I️ try to type the letter I️ help.
     

    Attached Files:

  21. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #71
    It’s a glitch with IOS 11.1. Try turning off predictive text and see if it goes away. Some have the glitch and some do not.
     
  22. Nordiclum1 macrumors newbie

    Nordiclum1

    Joined:
    Nov 4, 2017
    #72
    Nope still doing it. Just with the I️ though.
    --- Post Merged, Nov 4, 2017 ---
    It also does not happen when I️ text. Just when I️ use things like face book and web forums snap chat thinks like that.
     
  23. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #73
    My SE was doing it. I now have an X and don’t have the problem. I purposely set up the X as a new device in hopes I wouldn’t have issues.

    Maybe set the phone up as new. I’m not sure if anyone knows a real solution.
     
  24. Nordiclum1 macrumors newbie

    Nordiclum1

    Joined:
    Nov 4, 2017
    #74
    This is not a new device though. Lol it just started happening out of the blue. It’s a 7.

     
  25. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #75
    Yeah my SE was the same way. When I updated to 11.1. I never was able to fix it on the SE.
     

Share This Page