Redsn0w waiting on reboot....

Discussion in 'Jailbreaks and iOS Hacks' started by CVito, Jun 21, 2009.

  1. CVito macrumors newbie

    Nov 24, 2008
    I am in the process of JB, my device has gone black and redsn0w says "waiting on reboot" it has been a good 5 minutes and this normal??
  2. onionman macrumors newbie

    Jun 21, 2009
    I am also having this problem, I eventually cancelled the jailbreak after 15 minutes or so and now the phone will not be recognized by the computer or turn on. I am trying restore mode now. Any idea's?
  3. DaMan05 macrumors member

    Nov 10, 2008
    I still haven't gotten this to work!

    I've tried both 0.7.1 and 0.7.2 to jailbreak and unlock my iPhone 2G on Vista 32bit

    ran in compatibility mode for XP SP2 and ran as administrator
    did this is normal and safe mode

    tried restarting my computer
    tried multiple USB ports

    what else can try?! a manual reboot when it says waiting for reboot?
  4. wildmilne macrumors regular

    Jan 19, 2008
    Are you trying to upgrade or did you do a full restore? Mine didnt work until i did a full restore. Still seemed a little flaky...keep holding that home button for a while on the last step. Seemed to work better in windows than mac.
  5. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
    I had this problem, which I posted about on here.

    The way to fix it is:

    - Do a clean restore to 3.0 via DFU mode and iTunes

    - Run the RedSn0w process before doing anything else to the phone, then you should not get the "waiting for reboot" problem

    - After it's all done, you can restore from your backup to get contacts etc back again
  6. DaMan05 macrumors member

    Nov 10, 2008
    I was restoring... nothing worked.

    I used my brother's XP machine.
  7. d_saum macrumors 6502


    Jun 14, 2005
    Make sure you have the correct .ispw file. I accidentally had used a 3G file instead of 2G. As soon as I switched to the correct file, it worked like a champ. ;)
  8. CVito thread starter macrumors newbie

    Nov 24, 2008
    I made the same mistake except opposite (I had 2G when I needed 3G). As soon as I had the right .ipsw file it worked just fine.
  9. d_saum macrumors 6502


    Jun 14, 2005
    Cool.. glad I could help! :D
  10. k2dragon macrumors member

    Apr 25, 2009
    I am having the same problem. I am using a mac. My IPSW is iPhone1,2_3.0_7A341_Restore
    Its stuck on "waiting for reboot". I just replaced it with Apple warranty. I dont think it was ever activated through at&t
  11. rashiki macrumors newbie

    Jul 7, 2009
    Yes. The "Waiting for reboot" screen was killing me too. I have a 2g iPhone. Running redsn0w 0.8 on my Power PC iBook. I got stuck at "waiting for reboot", but it did say, at first, that it was jailbreaking. But then it would get suck at "waiting for reboot". What I FINALLY found out was all I need to do was just unplug the cable from the phone and then plug it back in. Right after that, the phone screen turned white and everything continued as it should!

    Hope this helps!
  12. csmitty macrumors regular

    Sep 15, 2007
    Wow, I was getting so frustrated, that cured it it seems. Downloading jailbreak data now. Thanks.
  13. LennyX macrumors newbie

    Dec 29, 2007
  14. GenericVillain macrumors newbie

    Jul 11, 2009
  15. SwiftBullet macrumors newbie

    Jun 20, 2009
    You sir, are a genius.
  16. sean9 macrumors newbie

    Jul 20, 2009
    unplug cable, plug back in

    This solution worked for me too. After waiting for about 5 minutes, I started checking forums and found this one on the redsn0w "waiting on reboot" message. I just unplugged the cable at that point, and the iphone screen flashed for a second. After a moment I plugged the cable back in and I got the screen downloading jailbraking data or something like that.

  17. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    The unplug didn't work for my 3GS. I tried over 10 times till I gave up and did it with purplerain. Way faster and easier to use. Hope the Dev team puts out simpler programs to jailbreak in the future.
    No need to hold down home, power or release after 30 seconds etc.....
  18. Requiems macrumors newbie

    Jun 9, 2009
    Thanks a lot, I don't know how long I would have spent trying to figure that out.

    The unplug, re-plug trick worked perfectly.
  19. NateDMB macrumors regular


    Jan 25, 2008
    Also, make sure you have the right firmware file. With my 3GS i had the 1,2 file but needed the 2,2 file supplied by redsn0w for it to work correctly.
  20. benwoodward macrumors newbie

    Aug 1, 2009

    If you are trying to unlock firmware 3.0.1 and getting stuck on 'waiting to reboot'.

    Then use redsn0w 0.7.2 and point it at firmware 3.0

    That worked for me.

  21. FSUSem1noles macrumors 68000


    Feb 23, 2006
    Ft. Lauderdale
    Confirmed solution on "Waiting to Reboot"

    Unplug the cable from phone and plug it right back in, jailbreak continues.

    +1 to above poster who posted it!
  22. MaCnation macrumors newbie

    Jul 10, 2009
    BEAUTIFUL! The unplug tricked worked beautifully. Im using redsnow 0.8, firmware 3.0(7A341) with 3.0.1 update.

    Thankyou to the genius that figured this out. I love you bro!
  23. jenzo macrumors member

    Nov 23, 2008
    another solution for dummies like me :)

    make sure your using the 3gs firmware and redsn0w version 8.0.

    i was going nuts with the same issue and i was not only using the wrong firmware ( 3.0 for 3g ) but i had version 7.2 which wont recognize 3GS firmware.

    after i got both of those squared away, no more waiting for reboot freezes

    hope this helps!

  24. cubedweller macrumors 6502

    Nov 25, 2007
    ...unplugging/replugging cable works.

    well, after I got the "waiting for reboot" I ended up doing a DFU restore in iTunes to 3.0.1.. i then restored from backup and finally reran redsn0w 0.8 again, and got the same "waiting for reboot" hang... i unplugged/replugged the cable and the jailbreak went fine.

    iphone 3g, 3.0.1, redsn0w 0.8.
  25. metoo6000 macrumors regular

    Sep 18, 2007
    London, UK

Share This Page