Restore SSD with macOS High Sierra

Discussion in 'Mac Basics and Help' started by UltraLEL, Sep 11, 2018.

  1. UltraLEL macrumors newbie

    Joined:
    Sep 19, 2016
    #1
    Hi guys.

    I have Mac Mini with installed SSD and it worked well since one and half year.

    Recently i got some trouble with it. For some reason(i don't know why),my High Sierra crashed(freezed) two times, third time reboot didn't help and seems to be OS has come to broken state :(.

    Unfortunately i'm not a huge user on OS X(macOS) and i didn't tried to enter on Recovery Mode. I got impression that something is wrong with my SSD(like died controller or something other) or much worst variant with motherboard.

    So the first(and wrong) solution that arrived to my mind was disassemble Mac Mini and swap with another SSD to double check if all is fine(what i have made finally). And seems to be that all is fine and SSD is not dead btw, old data is remains there.

    Then i assembled back(my old problematic SSD) and started to restore with Recovery Mode(with no luck).

    Command+R( all other methods) didn't helped me, like 90% scenarios was that after booting my Mac Mini i got black screen with no reaction to different hotkeys for Recover Mode(Sometimes it was like 10-20 minutes with black screen and then appears logo with rotating earth, subsequently error something similar to "-2003F").

    So ok, internet recovery didn't help. Seems to be that BootLoader is dead.

    What i have made next : swapped with another clean SSD(where i have successfully installed new macOS High Sierra).
    Then i connected my OLD SSD with broken macOS High Sierra via Sata-to-USB and voila(!).
    I was able to see all my data (any folder/any place). So i started immediately getting the whole user folder(documents/library/apps and etc) and it was second huge mistake from my side.

    In fact, there is a lot of data and OS started to doing "preparing" of copying it to my new SSD.
    I waited approximately 10-15 minutes and it still was on "preparing" status. I Decided to "cancel" it, because seems to be that something went wrong.

    But it didn't worked, it's was like no reaction on it and i have extracted connected SSD(with broken macOS) via USB from Mac Mini.(like wrong disconnect any USB flash without ejecting properly)

    As i said before, i'm not a advanced user of macOS and i agree that this action was too stupid, because now when i connect my SSD(with broken macOS),i can see the initial folders, but if i try to enter/copy/make something that is related to read/write finder becomes freezed(Not Responding),to restore it i need to extract(Disconnect) broken SSD...

    I know that i got chance to restore it painless, when i connected first time via Usb-to-SATA adapter, i should run FirstAid from disk utility to restore OS, but know it's too late, because it can't help now.(it shows errors that can't unmount disk drive)

    TL;DR
    I need urgently to restore my macOS to extract all data from google chrome(bookmarks + passwords + other stuff) and the rest of downloaded/created that is alive on disk drive.

    I still can see the whole information about disk drive via terminal command, but as i said before if i'm trying to get/explore something, finder becomes freezed(not responding).
    Now something is broken with bootloader and table partition(?).

    Other programs cant read information properly from disk(they freezes also).

    This is what shown on Disk Utility
    MacProblem 1.png

    and this additional information about disk drive
    MacProblem2.jpg

    Also what i tried its to connect my broken SSD via USB-to-SATA and enter to recover mode to re-install new HighSerra...the result is the same, it can't be choosen as hard drive for installing(in fact it detects, but you can't do anything there).

    If choose as startup, also freezes up :(
    MacProblem3.jpg

    So guys..what can i do in my case? Any suggestions would be appreciated !

    PS Apologize for my English skills.
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    There is no need to disassemble the Mini if you have a second drive.

    Just connect it "externally" using USB3 and boot that way.
     
  3. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #3
    Can you navigate down the user account level on the external drive? If yes, you can extract the info you need and copy if over the current boot drive.

    UPDATE: I see you cannot browse the external. That makes things hard, especially with APFS, as so few tools are updated to support it.

    What did First Aid report? It is common that First Aid fails to unmount some external drives. You can unmount from the First Aid menu (not unplug it, just unmount it) and then run First Aid.
     
  4. UltraLEL, Sep 13, 2018
    Last edited: Sep 13, 2018

    UltraLEL thread starter macrumors newbie

    Joined:
    Sep 19, 2016
    #4
    Adapter Usb-To-Sata i got later,when OS already died..
    --- Post Merged, Sep 13, 2018 ---
    Yes.
    First time when i have connected 'broken' macOS SSD, i got a chance to browse it properly(any folder/any directory).

    But now in fact i can connect and only initial folders that are available,if i will jump somewhere there than my finder will die as Not Responding.

    First Aid reported something like this : "couldn't unmount disk for repair" (i will drop screenshot later).

    What means "unmount and run First Aid",what the difference? Can you explain please!

    BTW,are you sure that via FirstAid you can easily unmount disk drive? Maybe it available from bash command,like this ->

    PS I hope it will not format/erase the SSD :(.
     
  5. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #5
    You should have an Unmount button:

    [​IMG]

    Wait for it to unmount, then use First Aid:

    [​IMG]

    I see the automatic unmounting that should happen when trying to run First Aid will often fail, like the warning you got.

    Sometimes unmounting manually first works, and then you can run First Aid.

    Some external drives take as much as 30 seconds to unmount...perhaps the automated attempt gives up too soon.
     
  6. UltraLEL, Sep 14, 2018 at 1:30 AM
    Last edited: Sep 14, 2018 at 7:30 AM

    UltraLEL thread starter macrumors newbie

    Joined:
    Sep 19, 2016
    #6
    Thanks for fast reply.

    I already tried and zero reaction.

    Now it's much more worse. When i connect my SSD(honestly i didn't made anything that was like "breaking changes"), i remember that last thing what i have tried it was booting MacOS with connected via Usb-To-Sata adapter and trying to re-install/startup with broken version MacOS(external SSD,the stuff is pretty much described on initial post). Anyway, i didn't manage it, because SSD with broken OS was 'uneditable' and i didn't made anything.

    What i'm getting now :( it's that :
    1) When connect SSD with broken MacOS (via adapter),it shows nothing
    upload_2018-9-14_10-58-8.png

    2) What shows Disk Utility now
    upload_2018-9-14_11-4-52.png

    3) When i tap to "Unmount", there is zero reaction on this button. Just nothing happens now :(

    4)When i pressing on info button(left corner),it just shows this
    upload_2018-9-14_11-8-1.png
    (its like a infinite loading, it can't show now any information that i was able to see :( )

    5)First Aid as other guys(zero reaction), like no effect(but's not freezing)
    upload_2018-9-14_11-29-54.png

    6) what shows DiskUtil in terminal(seems to be it can be unmounted by bash command(?) ) :
    PS All is bad now :( ?
     
  7. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #7
    There is one other possibility.

    I have seen quite a few USB external docks and drives that were unstable on some Macs. Can't say why, but I would guess it is a compatiblity between some USB chipsets, and the Mac USB chipset.

    I have, for example, a drive dock that has USB and FireWire. From USB, many newer macs will neither boot or or allow a solid, reliable connection (Finder freezes, drives randomly unmount).

    The same dock, using the same drive is rock solid when connected to FW, or to Thunderbolt with a FW to TB adapter.

    Pretty clear it is a USB issue.

    Unfortunately, hard to know if your SATA to USB is the issue. It could be...
     
  8. HeadphoneAddict macrumors 6502a

    HeadphoneAddict

    Joined:
    Sep 16, 2007
    #8
    This is why I keep two bootable clones of my hard drive and three time machines, one offsite and 2 on the network...
     
  9. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #9

    Backups are indispensable!

    Still would be good to figure out if there is:
    1. hardware issue with SSD
    2. corrupt OS or directory
    3. damaged/corrupt files
    4. hardware issue with Mini
    5. USB/external bridge issue
     
  10. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #10

Share This Page