rMBP Constant USB connect/disconnect - Help?

Discussion in 'MacBook Pro' started by ohms12, Apr 19, 2018.

  1. ohms12 macrumors 6502

    ohms12

    Joined:
    Jun 21, 2012
    Location:
    Scotland
    #1
    Looking for some help!

    I've got a mid 2015 rMBP (2.5Ghz i7), running OSX 10.13.4. I've been having this strange issue where whatever device I plug into the laptop's USB port, it repeatedly connects and disconnects (every half second or so). I've tried with an iPad Air 2, iPhone X (both using different, official, Apple cables). I've yet to try more devices - but I need both (need to do an update & reset one device) to work!

    • I've reset the Privacy location settings
    • I've tried both USB ports
    • I've reset the PRAM & SMC
    • I've ran in safe boot
    • I've setup a new Admin account and ran them from there
    • I've run Disk Utility/First Aid (doing it via the cmd+R method at startup)
    • I'm currently charging both devices to 100% to see if it helps..
    • I'm running the most current software on all devices
    • I've also ran a hardware test (press D on startup)
    I think that covers everything I've tried, for now. No dice, though. Does anyone else have any ideas?! :)
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Question:
    WHEN did this behavior begin?

    Right after you upgraded to 10.13.4?
    Or... earlier than that?
     
  3. ohms12 thread starter macrumors 6502

    ohms12

    Joined:
    Jun 21, 2012
    Location:
    Scotland
    #3
    Honestly, not entirely sure. I haven't plugged anything into the mac in maybe a month or so! I guess it's possible..
     
  4. jerryk macrumors 601

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #4
    Is it both USB ports? I believe there are separate controllers for the left and right side ports.
     

Share This Page