RX 560 graphics card on Mac Pro 4,1/5,1 PCIe Lane Width x8?

CosmicScale

macrumors newbie
Original poster
Dec 10, 2017
8
1
London, UK
I’ve installed a RX 560 on my Mac Pro. Currently it’s the only graphics card in the system and in slot 1. I’ve noticed that System Report says it’s running with a PCIe Lane Width of x8. The card I took out was a GT 120 and that ran at x16. In fact if I put the GT 120 into slot 2 it still runs a x16 with the RX 560 still runs at x8. I see the same when running Windows 10 via bootcamp. The only other card in the system is a Blackmagic Intensity Pro in slot 4. Should I be seeing x16 on the new card? If so is there anything I can do to make that happen? I’m not sure if I’m getting the full performance out of the card at the moment.

MSI Radeon RX 560 Aero ITX 4G OC
Mac Pro 4,1 flashed to 5,1
High Sierra 10.13
 

CosmicScale

macrumors newbie
Original poster
Dec 10, 2017
8
1
London, UK
I’ve installed a RX 560 on my Mac Pro. Currently it’s the only graphics card in the system and in slot 1. I’ve noticed that System Report says it’s running with a PCIe Lane Width of x8. The card I took out was a GT 120 and that ran at x16. In fact if I put the GT 120 into slot 2 it still runs a x16 with the RX 560 still runs at x8. I see the same when running Windows 10 via bootcamp. The only other card in the system is a Blackmagic Intensity Pro in slot 4. Should I be seeing x16 on the new card? If so is there anything I can do to make that happen? I’m not sure if I’m getting the full performance out of the card at the moment.

MSI Radeon RX 560 Aero ITX 4G OC
Mac Pro 4,1 flashed to 5,1
High Sierra 10.13
Okay, on Windows, GPU-Z reports the following:

GT 120 PCIe x16 2.0 so 8000MB/s
RX 560 PCIe x8 3.0 so 7880MB/s

I guess that explains that then...
 

William_si

macrumors regular
Apr 4, 2016
188
54
Croatia
The 560 DIE itself has only x8 and your Windows reading is so wrong - your Mac has no PCIe 3.0 at all.

x8 2.0 is plenty for any GPU, and espscially for this low end.

You can look at the PCIe connector to see it really only has x8 wired; check eg. my 560 attached pic (see how the wiring ends half within the slot to go up entirely).
 

Attachments

Last edited:
  • Like
Reactions: owbp

h9826790

macrumors G5
Apr 3, 2014
14,400
6,951
Hong Kong
To my knowledge all 460 and 560 are x8, reference or not.
I think I’ve seen some non reference card has golden pins on the whole x16 connector. But not very sure.

Anyway, AFAIK, even PCIe 2.0 X4 is enough for RX560. And as you said, the GPU DIE itself should only support up to x8. Even those x16 card exist, should be just for marketing purpose. No real benefit.
 

andrew nz

macrumors member
Feb 11, 2017
83
8
Christchurch new zealand
hello all.

to change the theme slightly and ask your advice.

I am looking for an upgrade for my Mac Pro 1.1, yes the dinosaur of macpros and extend its usability for another couple of years.

I have installed a radeon R9 280/7970 which works well.

I would like to play warcraft and the conundrum is that 10.11.x is the unofficial minimum mac os, but my R9 is not supported although it is metal api capable.

I am tempted to try the RX 560 wind force with the dual fans, not the aero card, and with the extra power cable except my max OS will be 10.11.x.
Yes I have hacked the Mac Pro to run up to 10.11.6 el capitan and if you are interested there is an entire thread on that theme on this forum.
 

h9826790

macrumors G5
Apr 3, 2014
14,400
6,951
Hong Kong
hello all.

to change the theme slightly and ask your advice.

I am looking for an upgrade for my Mac Pro 1.1, yes the dinosaur of macpros and extend its usability for another couple of years.

I have installed a radeon R9 280/7970 which works well.

I would like to play warcraft and the conundrum is that 10.11.x is the unofficial minimum mac os, but my R9 is not supported although it is metal api capable.

I am tempted to try the RX 560 wind force with the dual fans, not the aero card, and with the extra power cable except my max OS will be 10.11.x.
Yes I have hacked the Mac Pro to run up to 10.11.6 el capitan and if you are interested there is an entire thread on that theme on this forum.
I don't think RX560 can work in 10.11.x
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.