Safari 9: Can't disable private browsing

Discussion in 'Mac Apps and Mac App Store' started by EdwardKris, Mar 3, 2016.

  1. EdwardKris macrumors newbie


    Mar 3, 2016
    Hi there! I really need some help. I wanted to remove private browsing on my Safari 9, and I have found a lot of posts, websites and threads on how to remove private browsing, and mainly, this is what I found:

    1. Go to applications folder in Finder
    2. right click (with a mighty mouse or 2 button mouse, or Control+click for one button mice) on safari and choose "Show Package Contents"
    3. Go to Contents, then Resources, then English.lproj folder (or a respective folder for whatever language you have maybe)
    4. Double click on MainMenu.nib to open it in interface builder
    5. look at the window with the safari menu, click on Safari to expand it, then click on the Private Browsing menu item.
    6. hit the delete key and it disappears!
    7. hit command+s to save, close interface builder if you want, and relaunch safari.

    So, I followed the steps up to the 4th, whereas I noticed that MainMenu.nib doesn't exist in my English.lproj. So, with that, I couldn't do anything. I tried opening the other MainMenu.nib s for French, German, etc, but all were just pictures and didn't have ACTUAL contents. I really need help with this. I was gonna uninstall Safari, but as I use El Capitan I couldn't, which I then noticed that on El Capitan you can't delete Safari. I really hope this is possible for Safari 9. Please do help me.

    [SIDE NOTE] The most reason why I want to disable private browsing is because of any form of explicit results that is unsuitable for certain ages. So what came across my mind is enabling SafeSearch for Private Browsing, but since when you close a private window all the cookies are removed, the SafeSearch option doesn't save (in which I wanted it to). Based on this thread by Google:!topic/websearch/mJ-BUVoLA08
    It indicates that I can use SafeSearch on private windows if I enable third-party cookies. I couldn't figure out how to do so, so if you can't solve the first question, please do help me with this one if you can.

    Any help is appreciated.
    Thanks in advance,
    - Edward

    MacBook, OS X El Capitan (10.11)
  2. His4ever macrumors newbie

    Jul 15, 2016

    Did you every get an answer for this? I would dearly love to learn how to do this. I came to the same roadblock as you with the fix, the MainMenu.nib file. Thanks
  3. EdwardKris thread starter macrumors newbie


    Mar 3, 2016
    Nope, so far none.
    I had simply created a thread on the official Apple support community forum, and have received a few replies that may help you out, but they have done little help for me:

    Best of luck,
  4. His4ever macrumors newbie

    Jul 15, 2016
    I had someone from one of the Apple forums who provided a solution that was acceptable for me. It is NOT permanent, but certainly disabled the feature for iOS products namely iPhone and iPad. If you go into Settings/General turn on (toggle) the Restrictions. In order to activate this feature you have to set up a PIN, but that way you know it can't be deactivated without your permission. Once in the Restrictions Menu set up some of the parental control features, eg. Websites to "Limit Adult Content". Once this is completed go back to Safari and select the multiple windows to ensure the Private Browsing feature is in fact gone. Hopefully it's truly disabled for you. I was not able to do this so well on an iMac. I made a separate profile that the children may log onto that does have the parental controls activated. It will not allow you set restrictions on the Sys Admin profile. Best wishes.

Share This Page