Safari omnibox suggestions reappearing on 'enter'

Discussion in 'macOS' started by jamesraward, Mar 29, 2016.

  1. jamesraward macrumors regular

    jamesraward

    Joined:
    May 18, 2009
    #1
    Hello,

    I've an irritating problem that I've found others experiencing on t'interweb (but given the hard-to-describe nature I'm unable to find these threads again) that I'm hoping someone might be able to shed light on.

    When I do a search in safari (latest on El Capitan - all updates) the suggestions appear whilst you're typing:
    Screen Shot 2016-03-29 at 23.07.20.png

    When you press enter, the suggestions box goes away, as you'd expect. However when the google page loads, it's back, and you have to click on the page to dismiss it before you can click on any links etc:
    Screen Shot 2016-03-29 at 23.07.24.png

    It's incredibly annoying, and I've tried to find a solution out there but I a) can't describe the issue in a way that brings me any information and b) have messed around with settings to no avail.

    Really hoping someone is able to help!!
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    That does not repeat for me. Some things to try: create a new user and see if the problem repeats. Remove safari plugins/extensions. Adblock is the only extension I have right now.
     
  3. jamesraward thread starter macrumors regular

    jamesraward

    Joined:
    May 18, 2009
    #3
    Well, an interesting result; I set up another profile (this computer only has my own) and this didn't happen on that clean (non admin) profile.

    Switched back to mine, and the issue wasn't there on mine either - curious.

    Thanks for the tip though, seems to have done the trick (for the time being!)
     
  4. jamesraward thread starter macrumors regular

    jamesraward

    Joined:
    May 18, 2009
    #4
    It's back - and I've no idea how to get rid of it. I really don't want to have to recreate my profile.
     
  5. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #5
    Delete all cookies?

    Clear browser history?

    Logout of any and all google accounts?
     
  6. iSebmo macrumors newbie

    iSebmo

    Joined:
    May 3, 2017
    Location:
    France, Sud-Ouest
    #6
    same problem with a clean install... annoying
     

Share This Page