SD card reader won't mount until restart

Discussion in 'Mac mini' started by jprovost, Jan 2, 2017.

  1. jprovost macrumors newbie

    Joined:
    Sep 29, 2007
    Location:
    Toronto
    #1
    The SD card reader on my mid-2011 Mac Mini (Macmini5,1) has been acting up.

    SD cards inserted won't mount until I restart (leaving them inserted). If I eject the card, remove it from the slot and re-insert the same card, it won't mount until I reboot again.

    Things I've tried:
    • checked slot for dust/debris/damage
    • tried different cards, reformatting cards, etc.
    • resetting SMC and PRAM
    • tried on a guest user account (gives same behaviour)
    System profiler gives me the Vendor ID 0x14e4 and Device ID 0x16bc, I think that makes it a Broadcom BCM57785. I looked for drivers from Broadcom but only found stuff from the Hackintosh world and I'm hesitant to dabble with it.

    The problem has persisted for a while. I could live with it or get a USB card reader, but the reader works perfectly once I restart and get a card mounted. It seems like a simple software problem.

    Any suggestions?
     
  2. jprovost thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    Location:
    Toronto
    #2
    Update: SD Cards appear in System Information when inserted, but not Disk Utility, Finder, Photos.app, etc. Screen Shot 2017-01-03 at 6.55.36 PM.png
     

    Attached Files:

  3. Kaida macrumors regular

    Kaida

    Joined:
    May 28, 2016
    Location:
    Singapore
    #3
    I did have some problem with the card being read only but it was due to the write protected switch being stuck at the slot.

    I would think the only thing left to do now to determine if it is a software problem would be to install different OS X/macOS on it.
     
  4. jprovost thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    Location:
    Toronto
    #4
    Yup, checked that.

    Just reinstalled El Capitan (10.11.6) and no luck. Might try Sierra...
     
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    There's a good chance this is a dirty hardware issue and the card isn't being read properly. You say you "checked" for dust and debris but you might want to invest a small amount in a "memory card slot cleaner".
     
  6. bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #6
    If you boot in safe mode, with the SD card mount ok?
     
  7. for this, Jan 4, 2017
    Last edited: Jan 4, 2017

    for this macrumors regular

    Joined:
    Nov 18, 2014
    #7
    You can try that but I don't think Sierra will help. If software was the issue, your problem would be solved by now.

    Has the slot ever worked for you before? I mean my mini's SD slot has a quirk. If I push a card in too hard, it won't mount. I have to pull it out and put it back in more gently for it to mount.

    PS. Just to be clear. Now, I'm using 10.11.6 with a late 2012 mini. The SD slot still works. I've never had a problem with it in 10.8, 10.9, 10.10, and 10.11 except the quirk I mentioned above. Haven't tried Sierra yet.
     
  8. jprovost thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    Location:
    Toronto
    #8
    I'll try this. I suppose if there's a switch that detects when a card is inserted, separate from however the Mini is detecting if one is present at startup, it's possible that this is a hardware issue afterall.

    Problem persists. Card mounts if it was inserted before booting, doesn't if inserted after.

    I think you're right about it being a hardware issue. The card reader used to work perfectly. I've tried pushing in the card fast, slow, angled, gently, not so gently, etc. with no luck.

    I'll try more thorough cleaning and report back.
     
  9. bernuli, Jan 9, 2017
    Last edited: Jan 9, 2017

    bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #9
    I don't think it is a cleaning issue.

    According to your System Profiler, it looks like the hardware is reading the card. However the OS is not or is unable to mount it for some reason.

    How are these cards formatted?

    Have you tried a new SD card, and formatting on the mini using OS X Extended (Journaled), GUID Partition Map?

    Are you using VMware, Parallels or other Virtualization software?

    Also, to gain more insight, before inserting another SD card, get 2 terminal windows going. Run the following commands in each window.

    sudo tail -f /var/log/system.log grep kernel

    sudo iostat -n 11 -d 11

    When you insert the card and it does not mount, do you get a new diskX column?

    Any errors showing up in system.log?

    Do USB Memory sticks suffer the same problem?
     
  10. jprovost thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    Location:
    Toronto
    #10
    It looks like System Profiler doesn't show the card like it did before. That screenshot might have been a fluke.

    Just tried reformatting a card to OS X Extended (Journaled), GUID. Problem persists.

    I'm not using any virtualization software.

    If I'm interpreting the system.log output right, it's not logging any errors or anything that seems pertinent.

    iostat continues to only show my two internal drives when the SD Card is inserted, no new column.

    USB memory sticks do not suffer the same problem.
     
  11. bernuli, Jan 9, 2017
    Last edited: Jan 10, 2017

    bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #11
    Well then I am back to thinking it is a hardware issue then.

    I recently bought a couple of these: https://eshop.macsales.com/item/Sabrent/HBMACR/ Sabrent USB hub with card reader. Seems handy, though I have not tried it out yet. Good to have for future troubleshooting anyway.

    EDIT:

    Actually, I am not real happy with the performance of the Sabrent. It spikes CPU usage and temperature under heavy file transfer and is not quite as fast as my Lexar LRW025URBNA.

    So I recommend either:

    https://www.bhphotovideo.com/c/product/867611-REG/Lexar_lrw025urbna_Multi_Card_25_in_1_USB_3_0.html

    or

    https://eshop.macsales.com/item/Lexar/LRW400CRBNA/
     
  12. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #12
    It might be that particular card.

    I know it's not the ideal suggestion, but...
    ... get a USB card reader. Can be found for $10-15, and usually work much better...
     
  13. bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #13
    If it were me I would install a clean version of OS X onto an external USB drive and boot from that and see if the card reader works better.

    I have the same model Mac Mini running 10.11.6 and I was unable to reproduce your problem.
     
  14. Kanunu macrumors 6502

    Joined:
    Apr 18, 2009
    Location:
    Hawaii
    #14
    I can't offer you a solution, but I can comment that my 2010 iMac had similar symptoms all the way back to when it had Snow Leopard installed. Even if ejected properly, the card would never mount if reinstalled. After a reboot, the card mounted and read fine. I can't reproduce the problem now as I no longer have the machine but the symptoms were essentially the same of for the OP.
     

Share This Page