Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Apple_Robert

Contributor
Sep 21, 2012
24,572
29,763
In the middle of several books.
Interesting. I have yet to get the popup on my iPhone 5 asking to enable it. Did you enable it on a previous beta or on the GM?

Yes, I enabled it in iOS 8 Beta 5. I set my phone up as new with the GM, though. Once everything was set up with giving permission to all 3 devices, everything worked as before. The only thing that has changed with the GM for me, is the ability to send and receive calls on my MBP and iPad Air, whereas I wasn't able to do that prior to the GM.
 
Comment

macfanfromCHI

macrumors newbie
Original poster
Jul 25, 2014
14
0
Yes, I enabled it in iOS 8 Beta 5. I set my phone up as new with the GM, though. Once everything was set up with giving permission to all 3 devices, everything worked as before. The only thing that has changed with the GM for me, is the ability to send and receive calls on my MBP and iPad Air, whereas I wasn't able to do that prior to the GM.

Thanks for responding. If GM is my first iOS 8 beta on my iPhone and I have yet to receive a popup asking me to enable it, is there anything you would recommend doing?
 
Comment

c0LdFire

macrumors regular
Jul 10, 2013
218
134
I'm seeing the exact opposite - SMS relay / calling handoff both worked fine in DP7 / Beta 5, but I can't get either to work now that I've installed the GM. It never even prompted me for permission.
 
Comment

Brammy

macrumors 68000
Sep 17, 2008
1,704
680
Is there anything I need to do to get SMS on my iPad on GM?
 
Comment

Apple_Robert

Contributor
Sep 21, 2012
24,572
29,763
In the middle of several books.
What about for SMS?

Once I installed iOS 8 GM and logged into Yosemite, I was asked by Yosemite (for each device) if i wanted to forward SMS relaying, amongst the other usual trusted keychain question(s).

I couldn't remember my iCloud Security code, so I had to reset it in Mavericks during the final set up process for the devices and then I booted into Yosemite, where I was immediately asked the aforementioned questions. If some of you gents haven't had the popup message for SMS relay approval, I am at a loss as to what to suggest further. Hopefully, someone else will have a better answer.
 
Comment

idiiamots

macrumors member
Feb 15, 2010
87
71
Seattle, WA
What's the minimum version of Apple computer required for SMS relay? I have a 2010 Macbook Air (Yosemite DP7) and iPhone 5 (iOS 8 GM). Both are set up for iCloud keychain and no prompts to set up relay. Wonder if BT4LE is required.
 
Comment

c0LdFire

macrumors regular
Jul 10, 2013
218
134
got the popup.. i can receive but cannot send.

I got this far eventually, too. I ended up factory resetting my phone and NOT restoring from an iCloud backup. Annoying, but it did the trick. It was about time for me to clean house and get rid of old apps anyway, I suppose.
 
Comment

lvanness7690

macrumors member
Jul 8, 2014
49
6
I haven't received a pop up on my phone asking to enable sms relay or on my computer or iPad. Was working for me on Beta 5 and Yosemite DP 7. Nothing though since I've upgraded to GM. Handoff and Continuity are working fine. Can receive texts but when I try to send and SMS it says user not registered with imessage. Please help
 
Comment

garettap

macrumors newbie
Jun 2, 2014
29
9
I fiddled with things for a while including logging in and out of iCloud on desktop and phone and restarting both devices. But then I thought, well let me send an SMS from my phone. So I did. At that point, the SMS relay approval stuff came up and then my Mac was all good to go.

So make sure you try sending an SMS to stimulate the process!
 
Comment

vfortier

macrumors member
Dec 16, 2005
46
7
I fiddled with things for a while including logging in and out of iCloud on desktop and phone and restarting both devices. But then I thought, well let me send an SMS from my phone. So I did. At that point, the SMS relay approval stuff came up and then my Mac was all good to go.

So make sure you try sending an SMS to stimulate the process!

I second that, I tried everything but only got the popup when I sent an SMS...
 
Comment

Enjoylife1788

macrumors 6502a
Aug 22, 2011
800
109
I got a pop up once. However i disabled it as i dont want to use it right now. How do i turn it back on when i feel like using it?
 
Comment

hpogosyan

macrumors newbie
Aug 13, 2014
2
0
Hey Guys!

I finally got it figured out! After changing two airport cards on my mac and resetting my iPhone and iPad, I finally found the problem to the SMS relay bug where you can receive SMS on your iOS8/yosemite devices but cannot send SMS except from your iPhone.

You need to enable receiving iMessages on your iPhone using your iCloud login.

Settings -> Messages -> Send & Receive -> You can be reached by iMessage at: "username@icloud.com" needs to be selected.

As soon as I selected this I was able to text using my iPad Mini Retina.
 
Comment

stridemat

Moderator
Staff member
Apr 2, 2008
11,292
759
UK
Hey Guys!

I finally got it figured out! After changing two airport cards on my mac and resetting my iPhone and iPad, I finally found the problem to the SMS relay bug where you can receive SMS on your iOS8/yosemite devices but cannot send SMS except from your iPhone.

You need to enable receiving iMessages on your iPhone using your iCloud login.

Settings -> Messages -> Send & Receive -> You can be reached by iMessage at: "username@icloud.com" needs to be selected.

As soon as I selected this I was able to text using my iPad Mini Retina.

I have done that and power cycled both the iPhone and the iPad and it still isn't working. Any one else any ideas?
 
Comment

saudor

macrumors 6502a
Jul 18, 2011
934
848
Hey Guys!

I finally got it figured out! After changing two airport cards on my mac and resetting my iPhone and iPad, I finally found the problem to the SMS relay bug where you can receive SMS on your iOS8/yosemite devices but cannot send SMS except from your iPhone.

You need to enable receiving iMessages on your iPhone using your iCloud login.

Settings -> Messages -> Send & Receive -> You can be reached by iMessage at: "username@icloud.com" needs to be selected.

As soon as I selected this I was able to text using my iPad Mini Retina.
This worked!
 
Comment

Chris Grande

macrumors regular
Jun 17, 2003
239
107
Hey Guys!

I finally got it figured out! After changing two airport cards on my mac and resetting my iPhone and iPad, I finally found the problem to the SMS relay bug where you can receive SMS on your iOS8/yosemite devices but cannot send SMS except from your iPhone.

You need to enable receiving iMessages on your iPhone using your iCloud login.

Settings -> Messages -> Send & Receive -> You can be reached by iMessage at: "username@icloud.com" needs to be selected.

As soon as I selected this I was able to text using my iPad Mini Retina.

This worked for me as well but I had to enable it on both. This is a strange requirement... I wonder if it's a bug. I only usually ever have my phone number enabled.
 
Comment

clukas

macrumors 6502a
May 3, 2010
986
392
Hey Guys!

I finally got it figured out! After changing two airport cards on my mac and resetting my iPhone and iPad, I finally found the problem to the SMS relay bug where you can receive SMS on your iOS8/yosemite devices but cannot send SMS except from your iPhone.

You need to enable receiving iMessages on your iPhone using your iCloud login.

Settings -> Messages -> Send & Receive -> You can be reached by iMessage at: "username@icloud.com" needs to be selected.

As soon as I selected this I was able to text using my iPad Mini Retina.

Im having problems with SMS relay swell. I can make phone calls from my iPad, however the SMS relay is not working for some reason. Hope its just a glitch.
 
Comment

oMc

macrumors 6502a
Oct 17, 2010
522
370
Finland & France
Phone calls are working for me, however I cannot send SMS from my Mac: the Massages.app on the Mac is trying to send the SMS but it's not working.

I don't even had the "SMS relay" authorization pop-up on my iPhone and I don't know how to get it...
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.