Still Running OS X Yosemite? Beware, iTunes 12.8.1 Breaks Safari

Discussion in 'Mac Blog Discussion' started by MacRumors, Dec 14, 2018.

  1. sornek macrumors newbie

    Joined:
    Dec 16, 2018
    #126
    good fix but . .
    it broke my ability to sync devices to iTunes & Photo.
    How do I restore that?
    Reinstall the file & look for another fix?
     
  2. DeboraE macrumors newbie

    Joined:
    Dec 16, 2018
    #127
    I’m running High Sierra. Since dec 15th my Safari keeps crashing. When I open it, it keeps closing itself. So the issue is slitely different, but the problem is the same, and it happend at the same time. So I found the mobiledevice in finder and tried to delecte it, but I’m unable to do so. I don’t have the option to rename it, replace it or throw it away. Can any of you help me out please?
     
  3. YosemiteOldie macrumors newbie

    Joined:
    Dec 16, 2018
    #128
    This worked for me running OSX Yosemite 10.10.5 - thank you!

    I have a Q though. If I update to El Capitan (my 2011 mac is apparently incompatible with Mojave) do I need to manually add this MobileDevice.framework file back to the system library or will it automatically run updates and replace? Should I save this file somewhere rather than permanetly delete it?


    Update - How to Fix

    Some users have been able to fix Safari by opening the Finder app, clicking on Go > Go to Folder... in the top menu bar, typing in /System/Library/PrivateFrameworks/ and dragging MobileDevice.framework to the Trash.

    Article Link: Still Running OS X Yosemite? Beware, iTunes 12.8.1 Breaks Safari[/QUOTE]
     
  4. nvmls macrumors 6502a

    nvmls

    Joined:
    Mar 31, 2011
    #129
    Safari's been broken long ago, even on Mojave, apple doesn't care.
     
  5. n604rv macrumors newbie

    Joined:
    Dec 16, 2018
    Location:
    Morris, IL
    #130
    so I tried this and Safari now works but I can't get the trash to delete it.
     
  6. sornek macrumors newbie

    Joined:
    Dec 16, 2018
    #131
    mine deleted fine (now I want it back - ios devices won't sync w/iTunes, iPhoto now. Might be better to just rename & keep it)

    holding option key while choosing empty trash from finder menu
    --- Post Merged, Dec 16, 2018 ---
    Why surprised?
    Many like me happily using a computer that's incapable of updating beyond Yosemite. Unhappy that I didn't wait longer to update iTunes. Often the issues that effect the older os aren't reported till too late. This is one.
    Now, after fixing the Safari "glitch", I find another issue to be annoyed with - no iPhone/iPad sync.
    Pfft.

    waiting now for another "update" I guess.
     
  7. FNH15 macrumors 6502

    Joined:
    Apr 19, 2011
    #132
    Your iOS devices won't sync because the incompatible file was responsible for managing the Mac-> iOS syncing interface. Also, you may not be aware of this, but any Mac capable of running 10.10 is capable of running 10.11, and many still are capable of officially running 10.13.
     
  8. sornek macrumors newbie

    Joined:
    Dec 16, 2018
    #133
    yes, I understand the sync problem, & I can just reinstall the file.

    As for going to 10.11, I recall attempting and failing a couple of years ago with this '08 MacPro, when I updated my wife's iMac successfully. The installer refused & I remember some site reporting issues with this machine. I may give it another go. Thanks.
     
  9. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #134
    iTunes 12.6.3 here using high Sierra. Guess I will stick to this combo for another couple of years then.
     
  10. KJL3000, Dec 17, 2018
    Last edited: Dec 17, 2018

    KJL3000 macrumors 6502

    KJL3000

    Joined:
    Oct 13, 2010
    #135
    UPDATE
    Apple just released a new itunes update (same version 12.8.1, new build) that fixes safari. No need to delete frameworks anymore.
     
  11. GoodWheaties macrumors 6502a

    GoodWheaties

    Joined:
    Jul 8, 2015
    #136
    Like others have said, anything that supported Yosemite is supported by El Capitan. Or even better than that, it is super easy to even get High Sierra running on most unsupported Macs. I have HS running on a 2009 MacBook Pro and a 2008 MacBook. Actually quite easy using dosdude1’s instructions. Google him.
     
  12. griz macrumors 6502a

    Joined:
    Dec 18, 2003
    Location:
    New London, NH
    #137
    For everyone who sees 12.8.1 in their software update and is reluctant to update. Check your existing version. If it is 12.8.1 then go ahead and install the new 12.8.1. It does resolve the issue.

    Scott
     
  13. TGU macrumors newbie

    TGU

    Joined:
    Dec 16, 2018
    #138
    Worked also forme.
     
  14. NJShaker macrumors newbie

    Joined:
    Dec 17, 2018
    #139
    The only side effect I see is having issues connecting my phone, iTunes does not recognize it. Otherwise, no further issues that I can see so far. I will live with this for now as I plan to upgrade to Mojave over the next few days.
     
  15. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #140
    Apple released a fixed version of iTunes 12.8.1. Just update from Software Update and it'll allow you to connect your phone again.
     
  16. Kaiser Keith macrumors newbie

    Joined:
    Dec 17, 2018
    #141
    My Safari still not working after latest update, it says as below, can anyone help me please?

    Dyld Error Message:
    Library not loaded: /System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/SafariShared
    Referenced from: /System/Library/StagedFrameworks/Safari/Safari.framework/Versions/A/Safari
    Reason: no suitable image found. Did find:
    /System/Library/StagedFrameworks/Safari/SafariShared.framework/Versions/A/SafariShared: code signature invalid for '/System/Library/StagedFrameworks/Safari/SafariShared.framework/Versions/A/SafariShared'
     
  17. ximdotro macrumors newbie

    ximdotro

    Joined:
    Jun 21, 2015
    Location:
    London
    #142
    Finder - Go to folder - /System/Library/PrivateFrameworks/

    PS: but first check the App Store for updates, this morning apple released an update for iTunnes
     
  18. dyoung1011 macrumors newbie

    Joined:
    Dec 16, 2018
    #143
    Same here. I can only run Yosemite. I don't need the latest and greatest, this 2008 macbook runs fine, other than this current glitch. why should I throw it away and spend a bunch of money on something new that is full of new problems. It is B.S. they don't support their products!!!
    --- Post Merged, Dec 18, 2018 ---
    Thank god i don't have an iPhone!
     
  19. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #144
    All computers which can run Yosemite can run El Capitan.
     
  20. flygbuss, Dec 18, 2018
    Last edited: Dec 18, 2018

    flygbuss macrumors 6502

    flygbuss

    Joined:
    Jul 22, 2018
    Location:
    Stockholm, Sweden
    #145
    Good luck finding a non apple computer that still runs reliable after 10! years..
    Get macOS 10.11.6 and you'll get security updates from this fall.

    Things are not as bad as you say.
     

Share This Page