Unable to add mail accounts to Internet Accounts

Discussion in 'OS X El Capitan (10.11)' started by CadenZ15, Feb 23, 2016.

  1. CadenZ15 macrumors member

    CadenZ15

    Joined:
    Jun 9, 2008
    #1
    I ran into an issue with my KeyChain recently, and after wiping it out to start fresh I've been unable to add Internet accounts to my accounts in System Preferences.

    When I enter my password for a given account it trys to authenticate with the spinning loading animation, then goes all grey and doesn't do anything after that.

    Has anyone had a similar issue or have any suggestions?

    Thanks!

    P.S. There should be an image attached of the loading screen once it has frozen.
     

    Attached Files:

  2. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #2
    Not sure what issue you had with Keychain, but completely deleting it probably wasn't very smart. In any case, it's too late to worry about that now... have you tried re-entering your login, iCloud passwords in System Prefs? Have you tried entering the new Internet account info directly in Mail/Messages, etc.?
     
  3. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Yes. Your Keychain statement is worrying. What did you do, exactly?

    What happens if you try adding an Internet Account in a new user account?

    I'm thinking you may need to "Reinstall OS X from Recovery", but answer and try the above first.
     
  4. CadenZ15 thread starter macrumors member

    CadenZ15

    Joined:
    Jun 9, 2008
    #4
    Yes to both, same outcome. I'm on the Public Betas for El Cap, and the KeyChain started to act up after one of the updates. I wasn't able to get it repaired (it would repeatedly lock me out of the UI asking for passwords for various programs). Anyway, I deleted the login KeyChain after everything else, and that's where I am now.
     

Share This Page