Why do my wife missed calls show up on my phone?

Discussion in 'iPhone' started by newdeal, Sep 23, 2015.

  1. newdeal macrumors 68020

    Joined:
    Oct 21, 2009
    #1
    Its very irritating, my wife and I both have iPhones, we are both on the same apple ID. When she gets a call my phone doesn't ring but when she misses that call my phone shows a missed call icon on the phone app and when I go to the phone app its pretty clearly someone who wasn't calling my phone. Any way to fix this so it stops?
     
  2. jtrue28 macrumors 6502

    jtrue28

    Joined:
    Apr 10, 2015
    Location:
    Lexington, KY
    #2
    Why are you on the same Apple ID? I would imagine that is the reason.
     
  3. mblogsd macrumors member

    Joined:
    Aug 14, 2013
    Location:
    Here
    #3
    Her phone is probably setup to be able to receive calls on other devices and your iPhone is one of them since you're using the same Apple ID. You could simply turn that off, but the better solution is to use separate Apple ID's.
     
  4. theshoehorn macrumors 6502

    Joined:
    Jul 6, 2010
    #4
    Are you on iOS 9? I've noticed this too, between my personal and work iPhones. It's not the "calls on other devices" thing, because even when I make an outbound cellular call, that call will show up on my other phone's recent list... Must be a new feature in iOS9...
     
  5. Bigads macrumors regular

    Bigads

    Joined:
    Jun 17, 2012
    Location:
    Here
    #5
    Seeing the same thing here.
    I am running 9.1 beta 2 and the wife is on 9.0.1 and I am seeing cellular calls she makes/relieves and visa versa. We don't have cellular calls on other devices switched on.
    I understand some people suggest not using the same iCloud/Apple details but we have for a number of years prior to this and this is the first time we have had this issue.
     
  6. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #6
    It may be showing up via continuity. Wild shot in the dark. Even though you don't have cellular on other devices turned on it may be reflecting the received and missed call list via continuity.
     
  7. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #8
    Did you find a solution to this?
     
  8. Bigads macrumors regular

    Bigads

    Joined:
    Jun 17, 2012
    Location:
    Here
    #9
    Not yet.
     
  9. Tsuchiya macrumors 68020

    Tsuchiya

    Joined:
    Jun 7, 2008
    #10
    Isn't this just an issue caused by sharing Apple IDs?

    If so, the solution would be simply to create your own independent Apple IDs (or a second one for the individual sharing) then enable Family Sharing if you would still like to share content you purchase.
     
  10. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #11
    Well I can vouch for the OP that previously users sharing Apple ID's didn't experience this. I'm not personally affected therefore cannot troubleshoot this myself. But I've heard of people complaining a lot and out of the blue indicating a recent change.
     
  11. nostresshere macrumors 68030

    Joined:
    Dec 30, 2010
    #12
    see post #3
     
  12. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #13
    After thinking about it your probably correct.

    BOTH people sharing an Apple ID need to go to settings, phone, calls on other devices, and deselect the other persons phone.
     
  13. CXsjr macrumors regular

    CXsjr

    Joined:
    Dec 6, 2007
    Location:
    Scotland, UK
    #14
    I'll add my name to the list of those experiencing this; but not just in iOS9. I can't say for sure but probably since 8.2 or 8.3 (but no issue with text messages).

    I've checked everything, literally. Each iPhone is only set to receive calls for that phone, and 'calls on other devices' is switched off on both devices.

    Being in a 'same sex' marriage, we share probably 80+% of the same contacts so sharing an Apple ID works perfectly for this. Also, just stupid things like syncing a shopping list via the "app for that" so that whichever of us goes to the supermarket has a synced list of things we need.

    Thankfully, we trust each other way more than enough that this won't be an issue but nevertheless it's something you 'should' be able to configure; after all, recent calls on my phone won't be relevant as 'recent calls' to my better half.

    If anyone finds a solution ....
     
  14. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #15
    Check FaceTime and see that only your number is on your phone and only his number on his phone within FaceTime settings.

    If that doesn't fix it then I think it's a legitimate bug.
     
  15. CXsjr macrumors regular

    CXsjr

    Joined:
    Dec 6, 2007
    Location:
    Scotland, UK
    #16
    I checked that too but sadly the issue persists.

    It's pretty stupid as my work provide iPhones as company phones (to those unlucky enough to need one) and folks can use their own iCloud accounts to set up. However, you might not want your own recent calls and your work recent calls to show up on both your devices ....
     
  16. Bigads macrumors regular

    Bigads

    Joined:
    Jun 17, 2012
    Location:
    Here
    #17
    I think I have found a solution.

    Turned off iCloud Drive on my wife's phone and had no call logs appear since. Will report back if anything changes but this appears to have done the trick.

    Found under: settings/iCloud and then the iCloud Drive toggled to off.
     
  17. haruhiko macrumors 68040

    haruhiko

    Joined:
    Sep 29, 2009
  18. Jtludwig macrumors 6502

    Joined:
    Mar 24, 2012
    #19
    Yeah but that causes problems of its own, such as the automatic syncing of photos with ICloud Photo Library and my iMac.
     
  19. Bigads macrumors regular

    Bigads

    Joined:
    Jun 17, 2012
    Location:
    Here
    #20
    I have read many threads on here and the official apple forums and many people keep saying 'don't share/use the same iCloud account.
    Myself and my wife have shared an iCloud account since we had iPhone 4 (ios5?) without issues. This appearance of 'shared' calls has only appeared since upgrading to ios9.
    FaceTime, iMessage etc all allow you to choose which numbers/emails will accept from that specific device and that works perfectly.
    From what I have found, it appears the option to have iCloud Drive switched on both phones is the aspect causing issues.
    I have turned it off on my wife's phone and we have had no 'phantom' calls on our lists since.
     
  20. CXsjr macrumors regular

    CXsjr

    Joined:
    Dec 6, 2007
    Location:
    Scotland, UK
    #21
    Your opinion, to which you're entitled, but there are those of us who find it's beneficial to use the same account i.e. shared contacts, work & personal iPhones etc.

    We're looking for a way to go back to the way it worked before, not sweeping, unsubstantiated dictature ....
     
  21. hutrebug macrumors regular

    Joined:
    Jun 24, 2015
    #22
    Bad, bad mistake. ;)
     
  22. newdeal thread starter macrumors 68020

    Joined:
    Oct 21, 2009
    #23
    I like sharing an iCloud account I just don't like seeing all her recent calls clutter my recent call list and getting notifications on my phone that I missed calls that weren't to my phone number. I have disabled the calls on other devices long ago on my phone but I will check hers
     
  23. Bigads macrumors regular

    Bigads

    Joined:
    Jun 17, 2012
    Location:
    Here
    #24
    Switching iCloud Drive off on my wife's phone has seemingly remedied the situation.
    No erroneous call logs today.
     
  24. lordhamster macrumors 6502

    Joined:
    Jan 23, 2008
    #25
    Same thing happened to me. I did NOT turn off cloud drive to fix it.

    What you need to do is go into General settings, then turn off both "Handoff" related features. Problem solved.
     

Share This Page