Why is my YouTube video blurry?

Discussion in 'Digital Video' started by spellflower, Mar 18, 2018.

  1. spellflower macrumors regular

    Joined:
    Jun 7, 2005
    #1
    I shot this video with the highest quality settings on an iPhone 7 with up-to-date OS and edited it in iMovie 10.1.8. It looks great in iMovie, and when exported as an mp4 with highest resolution. But when I upload it to YouTube, it's fuzzy. I tried uploading directly from iMovie and uploading the mp4, but there's no difference. I checked my YouTube playback settings, and they're at maximum quality, and the problem happens across browsers and in the YouTube iOS app too.

    Can anyone suggest something I can do to fix this?

    Thanks!

     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    It looks perfect to me. Pinsharp, no problems at all.
     
  3. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #4
    Thanks. I'm not sure what's going on, because friends are also telling me it looks fine, but it was definitely blurry when I posted originally. I think maybe I exported at 720 by accident, but I redid it at 1080 and it's fine now.
     
  4. joema2 macrumors 68000

    joema2

    Joined:
    Sep 3, 2013
    #5
    The Youtube encoding may not have finished. You upload one version and on the server it encodes various resolution versions and also using different codecs. Each of these takes various amounts of time to complete. Even if you are certain your playback setting was 1080p, that could be an H264 version not Youtube's preferred VP9 version.

    The “Stats for nerd” tool on Youtube will show you what codec it's using. If it happens again, check that immediately then if it improves check it again and see if the codec changed.
     

Share This Page