lozpop

macrumors 6502
Original poster
Mar 6, 2006
487
0
I have never had problems with WiFi and my iPad.

Ironically, since I've installed the 4.2 Golden Master, WiFi is clearly having problems.
My iPad sees the WiFi network and connects to it properly, but internet works once and doesn't work twice.

I tried to restore the network settings, change the assigned IP, reboot, but nothing works.

Anyone else with this problem?
PS - Something else very weird. The iPad is connecting to the 3G network, but it doesn't surf properly. Sometimes it works, sometimes not.

Definitely a bug with the general networking here, I think.

Anyone else?
 

petvas

macrumors 601
Jul 20, 2006
4,940
1,048
Munich, Germany
I have been using my iPad for the last 8 hours connected to the Internet vie WiFi and I had zero problems. Of course I am running 4.2
I did an update from 3.2.2.
Is that maybe sth specific to the 3G model?
 
Comment

saberahul

macrumors 68040
Nov 6, 2008
3,636
103
USA
It was an issue in beta 1. It seems to be resolved now. Not sure how to fix. Tr a restore.
 
Comment

lozpop

macrumors 6502
Original poster
Mar 6, 2006
487
0
It was an issue in beta 1. It seems to be resolved now. Not sure how to fix. Tr a restore.

Thanks for the info, I've never run beta 1. Anyway I'm curious because other users in the forum are experiencing the same thing.
 
Comment

CrAkD

macrumors 68040
Feb 15, 2010
3,178
255
Boston, MA
I have a bit of a wifi issue. Sometimes Internet slows to a stand still and I have to disable and reenable wifi to fix it. Dunno if it's my crappy verizon fios router tho.
 
Comment

lozpop

macrumors 6502
Original poster
Mar 6, 2006
487
0
I restored the network settings for the fifth time, and now I have no problem.
I will write if it is temporary as before.
 
Comment

PhoneI

macrumors 68000
Mar 7, 2008
1,589
542
Strange, I am having major WiFi problems since I upgraded to the GM. Cant get it to stay connected for more than a few minutes. No problems before.

By the way, I have a Fios router.
 
Comment

Don Kosak

macrumors 6502a
Mar 12, 2010
860
4
Hilo, Hawaii
Hmm, no problems so far. The Apps I'm testing both heavily use the internet connection.

I'm connecting via an Airport Extreme.

I haven't heard of WiFi problems since the early betas. Did you upgrade directly from iOS 3.2 directly, or from one of the earlier betas?
 
Comment

lbeck

macrumors 6502
Dec 5, 2009
381
0
Count me as having wifi issues. It just stops working, then starts after I turn wifi on and off
 
Comment

gforce216

macrumors 6502a
Jun 17, 2009
587
181
I had some wifi problems with the GM coming after I updated from beta 3. I decided to do a full restore and I now have no wifi problems at all. Maybe that will help to resolve your issue.
 
Comment

phyrexia

macrumors 6502a
Sep 3, 2010
611
1
I didn't mess with any of the betas, but installed the GM early this morning via a Restore. Then restored from a previous backup. No wifi issues so far.
 
Comment

PR.

macrumors regular
Oct 3, 2005
124
16
Bedford, UK
I'm having wireless issues to. When it stops working I can turn wifi off and back on to fix it. I did try resetting network settings but after the restart it still wasn't working until I did the wifi off and on.

Going to be annoying... :(
 
Comment

Chundles

macrumors G5
Jul 4, 2005
12,003
456
I had the exact same issue but haven't seen it since turning off MobileMe bookmark syncing. It wasn't present in earlier betas so I think it's something to do with MobileMe. There was mention of a change in login so Apple may be fiddling with the server prior to general release.
 
Comment

ryanmcv

macrumors 6502a
Aug 12, 2007
768
458
Phoenix, AZ
I was having the same issue earlier today and had to turn wifi off and then back on to restore the connection. I reset my network settings and it hasn't happened since. Fingers crossed...
 
Comment

Eampiart

macrumors newbie
Jun 17, 2008
3
0
I had the same problem. I upgraded from 3.2.1 and had WiFi signal, but after about 30 secs, no internet. I resetted the network settings twice and now it works. This was about an hour ago, so I think it's finally good :)
 
Comment

lozpop

macrumors 6502
Original poster
Mar 6, 2006
487
0
I had the same problem. I upgraded from 3.2.1 and had WiFi signal, but after about 30 secs, no internet. I resetted the network settings twice and now it works. This was about an hour ago, so I think it's finally good :)

Exactly.

Guys, it seems that the only solution, for now, is to reset the network settings multiple times. I did it five times and now internet works from yesterday.

Anyway, considering the number of users that's experiencing this issue, this is clearly a bug. -- and this would be the Gold Master?
 
Comment

MSL

macrumors member
Sep 6, 2008
37
0
Brighton, UK
Resetting the Network settings has the following effect:

Works momentarily, then cuts out.

This is not a good release.
 
Comment

Chundles

macrumors G5
Jul 4, 2005
12,003
456
Has anyone else turned off MobileMe bookmark syncing if you use it? Solved the problem right away, haven't had any issues since.
 
Comment

PR.

macrumors regular
Oct 3, 2005
124
16
Bedford, UK
Has anyone else turned off MobileMe bookmark syncing if you use it? Solved the problem right away, haven't had any issues since.

I don't use MobileMe.

When I get home tonight, if it happens again I'll try resetting the network settings a few times.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.