WPA2 Enterprise connecting issues - not auto-joining and incorrect password message

Discussion in 'iOS 11' started by matthewfromclfs, May 29, 2018.

  1. matthewfromclfs macrumors newbie

    Joined:
    May 29, 2018
    #1
    Hi All,

    We're changing our school's WiFi set-up which will require our iPads (5th Gen running iOS 11.3.1) to be set up so that they connect to our WiFi network using WPA 2 Enterprise, using a generic login for all the iPads.

    I have changed the WiFi payload in Apple Configurator 2 to reflect these changes, using PEAP as our EAP type and loaded and trusted the relevant certificates, as well as inputted the generic login credentials.

    The issues are two fold; firstly the iPads no longer auto-join onto this new WiFi network despite auto-join being ticked on the profile.

    Secondly, when you do try and join manually, it comes up with an 'Incorrect Password' error message. It does this several times before then deciding everything's okay and then joins the network.

    The other problem with this is that when the iPads roam around the school (we're a big site), it tends to loose the network so having to rejoin manually can be time consuming with the incorrect password message.


    Any ideas/help on this one? Appreciate any feedback.
     
  2. Heiser macrumors newbie

    Joined:
    Dec 31, 2017
    #2
    We have recently made this move to WPA2 Enterprise as well. I am seeing the same issues you describe. Luckily our iPads don't move around much, but I see it consistently on my iPhone that leaves the building several times a day. It's to the point where I have to verify I am on WiFi when I get to my desk. I can no longer assume it will connect on it's own.

    I wish I had some helpful information. I just wanted to put it out there that you aren't the only one seeing this issue.
     
  3. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #3
    Are there any certificates that are required for the network? My particular environment requires that, and if those aren't on the system, the auto-join profile won't work. I also add the root certificates as well to ensure there are no trust issues with the wifi certificate.
    In my environment I have TTLS and PEAP enabled with "inner authentication" set to MSCHAPv2.
     
  4. matthewfromclfs thread starter macrumors newbie

    Joined:
    May 29, 2018
    #4
    After more research, we believe the issue may be more down to our Access Points (HP MSM460) as we tried the iPads in our boarding house, which has newer and different Access Points, and they all worked perfectly. So it seems that the HP Access Points don't really like iOS devices as this issue affects individual iOS devices as well as those with managed profiles on them. Android and Window devices seem fine, although do sometimes drop connection when roaming and do not always auto-join, but never come up with the invalid password error that iOS devices seem to.

    chrfr - I'm pretty sure I tried that exact profile set-up and still encountered the same problems but I'll double-check tomorrow. I have also included two certificates in our profile for the network (which I exported from Keychain Access as trusted certificates from the MacMini that we use to manage the iPads).

    Hopefully we'll have some more answers now that we're looking at the Access Points too.
     

Share This Page