Youtube causing massive battery drain and heat from iPhone

Discussion in 'iPhone' started by Pascal325, Nov 5, 2017.

  1. Pascal325 Suspended

    Joined:
    Oct 24, 2017
    #1
    Seems lately, after iOS 11 update at least, the Youtube app is killing my phones battery and causing it to get very HOT. It has never done this before. I saw on Reddit many other people are showing the same issues. I have the 8 plus, but people have the X, and the 7's are having it too.

    Wonder if there is a way to fix or report the issue?
     
  2. myscrnnm macrumors 65816

    myscrnnm

    Joined:
    Sep 16, 2014
    Location:
    Seattle, WA
    #2
    Are you on 11.0 or 11.1? I have not experienced this on my X upgraded to 11.1.
     
  3. pat500000, Nov 5, 2017
    Last edited: Nov 5, 2017

    pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #3
    You said YouTube app? That’s youtube problem. I use youtube via safari.
     
  4. Cubsfan16 macrumors member

    Joined:
    Sep 29, 2014
    #4
    My iPhone X is getting very hot while watching YouTube. Never had an issue before this.
     
  5. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #5
    If you’re uncomfortable with this, just exhcange it or return it.
     
  6. Sorig macrumors member

    Joined:
    Nov 2, 2017
    #6
    Yup it's true. I got rid of the youtube app and now watch youtube on chrome. It's a shame the video quality on web browsers is not as sharp compared to the youtube app though.
     
  7. Pascal325 thread starter Suspended

    Joined:
    Oct 24, 2017
    #7
    11.1 now. But it did it on 11.03 I believe was the version.
    --- Post Merged, Nov 5, 2017 ---
    And what does this have to do with a youtube app issue or ios issue? LOL.
     
  8. jimmy_uk macrumors regular

    jimmy_uk

    Joined:
    Oct 19, 2015
    Location:
    UK
    #8
    Gets warm for me also on ios 11.1.

    Also when watching a video and scrolling through the comments they judder. The frame rate is really poor.

    Guessing in needs another update?
     
  9. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #9
    It appears that you would think it’s a hardware problem rather than the software. Or don’t use the app.
     
  10. Pascal325 thread starter Suspended

    Joined:
    Oct 24, 2017
    #10
    Please tell me what made you think I said it was a hardware issue?! Because NO WHERE did I say it was. I said an APP or iOS issue. How about stop posting until you actually post something constructive.

     
  11. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #11
    As i said....get rid of your app? How’s that for constructive?
     
  12. myscrnnm macrumors 65816

    myscrnnm

    Joined:
    Sep 16, 2014
    Location:
    Seattle, WA
    #12
    Just an update with my experience: I'm running 11.1 on my iPhone X with the most up-to-date version of the YouTube app. I've been watching videos for half an hour straight (first 20 minutes on LTE, last 10 on Wi-Fi) and the phone is no warmer than it would be when inactive (to the touch) and it's used about 7% battery from nearly a full charge.
     
  13. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #13
    So it’s been okay?
     
  14. myscrnnm macrumors 65816

    myscrnnm

    Joined:
    Sep 16, 2014
    Location:
    Seattle, WA
    #14
    Yes, I have not had any problems so far. Performance is comparable to my iPhone 6 Plus.
     
  15. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #15
    Must be the op’s problem then.
     
  16. saltd macrumors 6502a

    saltd

    Joined:
    Aug 1, 2010
    #16
    Glad I’m not the only one to have noticed this! No way I’m ditching the app, as I pay for the Red service. I’m sure they’ll sort it out, if they haven’t already.
     
  17. daffie macrumors regular

    daffie

    Joined:
    Dec 31, 2010
    Location:
    Holland
    #17
    Youtube update available.

    After installing the issue is solved. No heating issues, connection stable, smooth scrolling, and normal battery usage (2% for 15 minutes playback 1440p).
     
  18. nemnis macrumors newbie

    nemnis

    Joined:
    Oct 27, 2017
  19. Pascal325 thread starter Suspended

    Joined:
    Oct 24, 2017
    #19
    Of course after I uninstalled it. LOL! I will give it another try. Thanks for reporting!
     
  20. Galacticos macrumors 6502a

    Galacticos

    Joined:
    Apr 5, 2016
    #20
    I just installed it and had the problem worse if anything. 20 min video got very hot and drained 16% battery..

    Otherwise I’ve had very good battery
     
  21. deuxani macrumors 6502

    deuxani

    Joined:
    Sep 2, 2010
    #21
    I have the same issue on both my 7 Plus and X, but it doesn't happen with every video or every time. Sometimes it works like normal and sometimes the phone heats up and drains like crazy. It's definitely a YouTube app issue and I hope Google will fix it soon.
     
  22. mporcheron macrumors member

    mporcheron

    Joined:
    Nov 13, 2011
    Location:
    Nottingham, UK
    #22
    My 6S burns up one or two YouTube videos in. Definitely a recent problem with the app.
     
  23. Pascal325 thread starter Suspended

    Joined:
    Oct 24, 2017
    #23
    Seems mine is good to go now after Youtube was updated. Yay!
     
  24. daffie macrumors regular

    daffie

    Joined:
    Dec 31, 2010
    Location:
    Holland
    #24
    Yes after latest update my iphone doesn't heat up any more when playback youtube vids. Battery usage is 6% per 15 minutes (1080p / 1440p). I guess that's about normal?
     
  25. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #25
    YouTube always pushes the temps on my phone, its not really a hardware issue.

    As others stated, either live with it, update the app or do what many of us do, just view the videos in safari.
     

Share This Page