Bootchamp - what are the other alternatives

superparati

macrumors regular
Original poster
Apr 11, 2016
130
24
London
Hi,

With my Nvidia GT 120 unrecognised it is time to find an alternative solution.
If with El Capitan I was able to boot easily under Windows with the help of Bootchamp, today the same software doesn't work anymore under Sierra.

The command line bless is not supported due to SIP as far as I know which is the main reason why bootchamp is now obsolete.
Therefore numbers of subjects talking about how to replace the command line bless, some people use the command systemsetup
  • sudo systemsetup -liststartupdisks
  • sudo systemsetup -setstartupdisk /Volumes/[your boot volume]
  • sudo systemsetup -getstartupdisk (this command will show you the name of your startup disk).
However, this command doesn't replace completely bless and I head that actually after deactivating the SIP we could use it - which is interesting.

Also today something popup in my mind. After reading some information about the command bless.
My bootcamp partition is running under bootcamp's volume but when I select this partition from system preference startup disk hit the button reboot the computer will display a windows error message - blue screen.

If I press ALT, the only way to boot under windows is to select the partition EFI boot.

So by mixing the information from the command line bless I discover why when I select the Windows startup disk from preference system my computer doesn't boot.
The following command line shows me two boot disks:
  • sudo systemsetup -liststartupdisks
  1. /System/Library/CoreServices (macOS)
  2. /Volume/BOOTCAMP/WINDOWS (Windows)

The boot volume "/Volume/BOOTCAMP/WINDOWS" is not the right one.

I decided to actually try this command line:
  • sudo bless -mount /Volumes/BOOTCAMP -setBoot
  • sudo reboot
And bingo my computer did reboot under windows.

For those who are looking for a solution this one could be a quick fix.

Sources:

 
  • Like
Reactions: ActionableMango

kunia

macrumors regular
Oct 30, 2010
166
12
I had to disable SIP to use my Kore 2 controller, and bootchamp works like before.
 

vkd

macrumors 6502a
Sep 10, 2012
915
313
You could try using Apple's Bootcamp as an alternative to your Bootchamp
 
  • Like
Reactions: PhiLLoW

Ph.D.

macrumors 6502a
Jul 8, 2014
548
465
You could try using Apple's Bootcamp as an alternative to your Bootchamp
I've seen "Bootchamp" before, and wondered if my memory ("Boot Camp") was faulty.

Totally off topic, but just slightly related, it's "champing at the bit," not "chomping."
And it's "couldn't care less," not "could."
And it's "bated breath," not "baited."
And it's "Mac," not "MAC." :)

(Update: I see "bootchamp" is an actual 3rd party utility, not a malapropism.)
 
Last edited:

JoSch

macrumors 6502
Feb 22, 2013
319
101
You might try rEFInd. It is substantially superior to using ALT in many different ways. The best part, IMHO, is that it is sooooooo much faster. It comes up in just a second or so.
The only gripe, I have with rEFInd, is, that it obviously has no way to initialize the GPU, so without a EFI enabled GPU you are as blind as you are with the ALT boot screen.
BootChamp could at least fill that hole.
 
  • Like
Reactions: superparati

ActionableMango

macrumors G3
Sep 21, 2010
9,550
6,815
The only gripe, I have with rEFInd, is, that it obviously has no way to initialize the GPU, so without a EFI enabled GPU you are as blind as you are with the ALT boot screen.
BootChamp could at least fill that hole.
There is a fork of rEFInd that inits GPUs with GOP-compatible firmware. Also Florian says that Clover can init non-EFI GPUs. I haven't tried either of those myself because all I have are EFI GPUs.
 

superparati

macrumors regular
Original poster
Apr 11, 2016
130
24
London
ActionableMango,
rEFInd would have been the perfect solution only if the non EFI GPU was recognisable from the boot.
To do the test I had to remove my Nvidia graphic card and use my official ATI 4870 otherwise I don't have a boot screen because it is a non-EFI card (not flashed).

After I don't under why the boot doesn't work via the system preference / startup disk. Apple should have noticed this error :(
 

JoSch

macrumors 6502
Feb 22, 2013
319
101
There is a fork of rEFInd that inits GPUs with GOP-compatible firmware. Also Florian says that Clover can init non-EFI GPUs. I haven't tried either of those myself because all I have are EFI GPUs.
Interesting infos. When I tested Clover, I couldn't find such functionality. Where can I find out more about the feature?
 

JoSch

macrumors 6502
Feb 22, 2013
319
101
So, I put Clover on a USB stick and enabled the ATI injection. Lo and behold, I have a Clover boot screen on my RX480. It even wakes up my LG monitor, which tends to go to sleep rather quickly.
Booting OSX or Windows doesn't work yet, but the GPU boot screen experiment can be probably called a success in my case.
 

JoSch

macrumors 6502
Feb 22, 2013
319
101
Ok, OSX boots, but doesn't reinitializes the GPUs anymore, if I boot with Clover.
Anyone here with an idea how to solve this.
Also, my legacy install of Windows 10 (updated from Win7) also doesn't boot. Is Clover only able to boot (U)EFI OSes?
 

ActionableMango

macrumors G3
Sep 21, 2010
9,550
6,815
Ok, OSX boots, but doesn't reinitializes the GPUs anymore, if I boot with Clover.
Anyone here with an idea how to solve this.
Also, my legacy install of Windows 10 (updated from Win7) also doesn't boot. Is Clover only able to boot (U)EFI OSes?
I've never been through this myself so I hesitate to say anything at all. However, nobody else has chimed in.

All I can suggest is that I've seen in previous attempts there were recommendations to turn off as many options and modifiers as possible because they are for hackintoshes, so they aren't needed on a real Mac and might actually interfere.

There isn't a lot of help here because you are one of only 2 or 3 people who have tried this so far. It is potentially a big deal to many, many people running unflashed and unflashable cards.
 

AidenShaw

macrumors P6
Feb 8, 2003
18,640
4,643
The Peninsula
I've never been through this myself so I hesitate to say anything at all. However, nobody else has chimed in.

All I can suggest is that I've seen in previous attempts there were recommendations to turn off as many options and modifiers as possible because they are for hackintoshes, so they aren't needed on a real Mac and might actually interfere.

There isn't a lot of help here because you are one of only 2 or 3 people who have tried this so far. It is potentially a big deal to many, many people running unflashed and unflashable cards.
Wouldn't it be so much simpler if Apple OSX actually supported UEFI booting like the other grown-up operating systems?
 

Codeplayer

macrumors newbie
Feb 19, 2018
1
0
Estonia
I had to disable SIP to use my Kore 2 controller, and bootchamp works like before.
I can confirm, that still works in High Sierra, thanks!

How to do it was tricky, but simple with instructions:

1. Boot into recovery (Hold Command + R after turning the mac on)

2. From menu bar find Terminal

3. Type in terminal: csrutil disable

4. Bootchamp works now.
 

MIKX

macrumors 68000
Dec 16, 2004
1,775
650
Aussie in Japan
I rarely ever need to use Windows other than for flashing video cards but I have Win 7 & Win 8.1 natively installed on their own dedicated spinner HDDs. I installed by booting from the original Win 7 & Win 8.1 install CDs. Installed the relevant GPU drivers and since then now have a perhaps more 'native' 'real? ' Win setup working. I did not need to install any Bootcamp drivers as Win 7 & 8.1 usually automatically install most drivers. My Apple keyboard works during the install. Of course the downside is that I need to cold boot from the respective Win HDDs but as stated, I rarely ever need to use Win. ( thankfully ).
 

itdk92

macrumors 6502a
Nov 14, 2016
501
180
Copenhagen, Denmark
Hi,

With my Nvidia GT 120 unrecognised it is time to find an alternative solution.
If with El Capitan I was able to boot easily under Windows with the help of Bootchamp, today the same software doesn't work anymore under Sierra.

The command line bless is not supported due to SIP as far as I know which is the main reason why bootchamp is now obsolete.
Therefore numbers of subjects talking about how to replace the command line bless, some people use the command systemsetup
  • sudo systemsetup -liststartupdisks
  • sudo systemsetup -setstartupdisk /Volumes/[your boot volume]
  • sudo systemsetup -getstartupdisk (this command will show you the name of your startup disk).
However, this command doesn't replace completely bless and I head that actually after deactivating the SIP we could use it - which is interesting.

Also today something popup in my mind. After reading some information about the command bless.
My bootcamp partition is running under bootcamp's volume but when I select this partition from system preference startup disk hit the button reboot the computer will display a windows error message - blue screen.

If I press ALT, the only way to boot under windows is to select the partition EFI boot.

So by mixing the information from the command line bless I discover why when I select the Windows startup disk from preference system my computer doesn't boot.
The following command line shows me two boot disks:
  • sudo systemsetup -liststartupdisks
  1. /System/Library/CoreServices (macOS)
  2. /Volume/BOOTCAMP/WINDOWS (Windows)
The boot volume "/Volume/BOOTCAMP/WINDOWS" is not the right one.

I decided to actually try this command line:
  • sudo bless -mount /Volumes/BOOTCAMP -setBoot
  • sudo reboot
And bingo my computer did reboot under windows.

For those who are looking for a solution this one could be a quick fix.

Sources:

Amazing work. Thanks a lot.
 

Alexandor4

macrumors newbie
Mar 24, 2020
1
0
Is there any way to chose boot volume without disabling SIP and without using the System Pref > Startup Disk route. I just want to have a command I can run in Alfred to boot into windows quickly without the hassle. I also don't want it to force restart.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.