Enabled AirPrint in iOS 4.2/iTunes 10.1/Shared Printers/Windows 7

Discussion in 'iPhone' started by realeric, Nov 12, 2010.

  1. realeric, Nov 12, 2010
    Last edited by a moderator: Oct 8, 2012

    realeric macrumors 65816


    Jun 19, 2009
    United States
    I have AirPrint work with shared printers in Windows 7 (64bits). Here is the step by step instructions.

    1) Install iTunes 10.1
    2) Download AirPrint.zip (airprint.exe, libairprint.dll, XpdfPrint.dll)
    3) Unzip it.
    4) Make a folder, "C:\Program Files (x86)\AirPrint\"
    5) Copy the files to "C:\Program Files (x86)\AirPrint\"
    6) Run "cmd.exe" as administrator
    7) Run the following commands (There should be a space between '=' and '"')

    Windows 64bits:
    sc.exe create AirPrint binPath= "C:\Program Files (x86)\AirPrint\airprint.exe -s" depend= "Bonjour Service" start= auto
    sc.exe start AirPrint

    Windows 32bits:
    sc.exe create AirPrint binPath= "C:\Program Files\AirPrint\airprint.exe -s" depend= "Bonjour Service" start= auto
    sc.exe start AirPrint

    8) Let Windows Firewall allow AirPrint to communicate on the networks (Double click on the airprint.exe)

    Attached Files:

  2. iceterminal macrumors 68000


    May 25, 2008
    Dallas Tx.
    Great, now all I need is a working release version of iTunes 10.1, and iOS 4.2. ;)

    I'm wondering if they'll have all of this working when they actually do the release.
  3. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    Thank You!!!!! :D

    This works flawlessly!

    Now I can print at work on my Windows network!
  4. smokescreen220 macrumors regular


    Jun 21, 2010
    California Native
  5. tbolt macrumors newbie

    Nov 12, 2010
    I wouldn't say flawlessly..
    It works but is intermittent. Try this:

    1. Print out a simple page (say the goole homepage for example)
    2. Try and print the same page like 10 times
    3. Switch to another page - print it a couple of times.

    After a few minutes, you will see that you are back to the
    No Printers Found message.

    It's intermittent, it may start working again later.
    Flawless is not the word I would use for it.
  6. cc999 macrumors 6502

    Jul 15, 2008
    Mac OS

    What about Mac OS? I have a Macbookpro with itunes 10.1 installed, my iphone4 with the 4.2 GM. Do I need to get airprint for Mac?

    Any help would be appreciated.....

    Charlie C
  7. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    You can get the instructions for OSX here ----> gumballtech.com

    It's actually pretty simple - it's just a matter of adding a few files and sharing your printer. You can do it manually or use the utility they have on the gumballtech web site.
  8. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    Ya, I'll give you that - it's not 100% perfect, but all you have to do is tap the printer/select printer and the printer(s) reappear. Same issue in OSX, BTW.
  9. imacken macrumors 65816

    Feb 28, 2010
    If only it was as simple as that. It is definitely intermittent - sometimes the printers are there, and sometimes they are not. Still, when it works, it works OK as long as the doc doesn't have much in the way of fancy formatting.
  10. ILBandit macrumors regular

    Sep 7, 2008
    It seems to work better of you are sharing the printers on a Mac. If sharing on a Windows PC, it will always ask for a password, but if you switch over to sharing them from a Mac OS, just 1 click ( no password required) and it will print right away.
  11. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    Yes, I agree. OSX AirPrint seems to work much better. The userid and password in windows is kind of a pain...
  12. imacken macrumors 65816

    Feb 28, 2010
    Windows asked for my login user name and password the first time I printed, but never since.
    That seems perfectly logical, if you ask me. It certainly would be a pain if it happened every time.
    Do you guys having this issue have a login on OS X?
  13. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    No userid and password is required for AirPrint in OSX. All that's necessary is to share the printer(s).

    In Windows, I've noticed that Win7 asks for the password the first time but never again (at least so far). In WinXP (at work), it seems to ask for the password the first time and then again intermittently.
  14. thefreeagent macrumors member

    Nov 7, 2010
    New Mexico
    Question about Win7...

    So, I followed the instructions (thank you for this), which worked right away, but after I close the command prompt box, the printer then disappears from AirPrint on my iPad/iPhone...

    So, my question is this: Does the command prompt box (which opens after I double click on AirPrint.exe) have to remain running on my Windows machine in order for AirPrint to work?

    This would be unfortunate, and a pain in this ass, if it is this case...

    Any input is appreciated!
  15. exhibit.b macrumors regular

    Jul 11, 2008
    I keep getting this message.

    C:\Users\Brian>sc.exe create AirPrint binPath= "C:\Program Files\AirPrint\airpri
    nt.exe -s" depend= "Bonjour Service" start= auto
    [SC] OpenSCManager FAILED 5:

    Access is denied.

    C:\Users\Brian>sc.exe start AirPrint
    [SC] StartService: OpenService FAILED 1060:

    The specified service does not exist as an installed service.
  16. joec1101 macrumors 6502a

    Jun 29, 2010
    So Cal, USA
    No, command prompt does not need to remain open - you're just using it to execute the appropriate commands to set up AirPrint.

    Are you *sure* you're typing everything *exactly* per the instructions? Even something off by a space or case inversion can cause it to fail.

    Try saving the above instructions to a text file and then copy/paste the commands into the command line so it's exactly correct.

    To check if AirPrint did get installed, in Win7, run "services" (without the quotes) from the start menu and see if AirPrint is running as a service. It should be started, set for automatic start and dependent upon Bonjour. If you don't see it there, you may have typed the commands incorrectly. In this case, just try it again and use copy/paste this time.

    Also, make sure you have Administrator privileges or login as Administrator to run these commands. If you're Windows userid is set up as a user or anything less than Administrator, it probably isn't going to work.
  17. rwilliams macrumors 68040


    Apr 8, 2009
    Raleigh, NC
    Thank you for these tips. I was able to get my iPod Touch to print to our old Windows XP machine with a USB printer. At first, it would not recognize the printer, so I connected the printer to my MacBook and printed a page from there. The iPod was then able to not only see it connected to my MacBook, but was also able to see the printer as it's usually shared - from the XP machine. I reconnected the printer to the XP machine, selected it from the iPod, and then printed after entering the username/password combo for the computer.
  18. melvin1337 macrumors newbie

    Nov 19, 2010
    I'm using this in a domain network, Win7 Pro 32bit

    Everything is fine until I get to the password prompt

    I input domain\username and my password and I get the message that I input the incorrect password

    Anyone have any ideas on this?
  19. imacken macrumors 65816

    Feb 28, 2010
    Well, all I know is that I input my login username and password once, and never got prompted again. Are you trying your login name?
  20. melvin1337 macrumors newbie

    Nov 19, 2010
    Yes, I stated so in the first post I think..

    Or do you mean that I should try without entering the domain name?
  21. imacken macrumors 65816

    Feb 28, 2010
    I would try all ways - with and without. Try various combinations. Do you put the domain name in when you are logging in?
  22. melvin1337 macrumors newbie

    Nov 19, 2010
    I have tried different combinations:


    And probably a few more... I'm done at work for the week, so there will be no further testing till monday... I do hope I can get it to work at home now though..
  23. zTaras macrumors newbie

    Nov 19, 2010
    my ipad found my printer but i have no idea what password and login it ask me about. Can smb tell me where can i find them?:confused:
  24. imacken macrumors 65816

    Feb 28, 2010
    It's the user name and password that you use to login to your computer.
  25. zTaras macrumors newbie

    Nov 19, 2010
    but the problem is that i have no password and login on my computer((((

Share This Page