Enabled AirPrint in iOS 4.2/iTunes 10.1/Shared Printers/Windows 7

Discussion in 'iPhone' started by realeric, Nov 12, 2010.

  1. ldeschenes macrumors newbie

    Joined:
    Nov 23, 2010
    #51
    Thanks. that did work for me.

    BTW, for those that have Windows 7/XP Home version, Group Policies Edit is not included. Use instead regedit and change to 0 the LimitBlankPasswordUse parameter on the entry MACHINE\System\CurrentControlSet\Control\Lsa
     
  2. ldeschenes macrumors newbie

    Joined:
    Nov 23, 2010
    #52
    Thanks for the info.

    BTW, for the Windows users that are not used to Apple software (like me), you MUST FIRST INSTALL BONJOUR prior to running Airprint Installer. You download it at http://support.apple.com/kb/dl999

    That worked fine for me after I did that!
     
  3. IphoneHack macrumors newbie

    IphoneHack

    Joined:
    May 12, 2010
    Location:
    Germany
    #53
    Great Install

    Thanks for the tip, installed and worked for me perfectly, great collaborative thread!

    ! J !
     
  4. mrmike316 macrumors regular

    Joined:
    Jun 21, 2009
    #54
    I can see the printer, but I keep getting the damn username and password prompt. I dont have a username or password anyone have any sugestions THANKS
     
  5. DrFillster macrumors member

    Joined:
    Aug 23, 2008
    #55
    Turns out even with a network printer you must enable sharing. Rather than right-click on "properties", I had to right-click on "printer properties". Sounds kinda stupid now.....

     
  6. Felix Martinez macrumors newbie

    Joined:
    Jul 14, 2008
    #56
    Same here!
     
  7. mrmike316 macrumors regular

    Joined:
    Jun 21, 2009
    #57
    you need to enable a guest account in user account control. Restart and it should work. That is the way i finnaly got it working,appears to working fine now....
     
  8. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #58
    XP works fine

    Yup. I have windows XP and its working perfectly.
     
  9. boonleng macrumors regular

    Joined:
    Aug 30, 2007
    Location:
    United States
    #59
    I still hope Apple will put back the native support without going through these troubles.
     
  10. BadaBing!! macrumors 6502

    BadaBing!!

    Joined:
    May 16, 2010
    #60
    Even easier, and worked for me.

    1) Install iTunes 10.1
    2) Download AirPrint.zip (airprint.exe, libairprint.dll, XpdfPrint.dll)
    3) Unzip it.
    4) Make a folder, "C:\Program Files (x86)\AirPrint\"
    5) Copy the files to "C:\Program Files (x86)\AirPrint\"
    6) Run "cmd.exe" as administrator
    7) CD "C:\Program Files (x86)\AirPrint\"
    8) Airprint -i

    It'll install the service.
     
  11. gouda272 macrumors regular

    Joined:
    Feb 20, 2010
    #61
    Thanks for this great thread. got my kyocera FS-C5100DN working again on 4.2.1!!
     
  12. danshep macrumors newbie

    Joined:
    Nov 23, 2010
    #62
    airprint on the iPhone

    There were several sets of solutions for using airprint.

    This one worked for me on my iPhone. The elpamsoft download was simple. No need to make directories. The app file did it all.

    I had already shared out the printer, so after I clicked the install, I checked my iPhone and the printer was already showing. Ligntning fast.

    Printed a test page and worked fine. One happy camper.
     
  13. RhythmGuru macrumors member

    RhythmGuru

    Joined:
    Nov 7, 2010
    #63
    Same Problem Here

    I have AirPrint working as well, but ONLY when airprint.exe is open and running in the command prompt. As soon as I close it, my printer disappears. Have followed instructions a few times, AND used the quick install program. No dice. Windows XP. Any ideas?
    I can print from my Ipad and Iphone, but once again, only when the prompt is open and I can see the connections happening and logging in realtime. The service is running, etc.
    I guess another question is, how do I write a quick script to always start Airprint.exe when the PC boots up?
     
  14. BullittMustang macrumors 6502a

    Joined:
    Mar 27, 2008
    #64
    Is there any way to get this to work on an HP wifi enabled printer without having my computer on? Other printing aps work fine that way, I'd like to have AirPrint work that way.
     
  15. ceconrad macrumors newbie

    Joined:
    Nov 23, 2010
    #65
    Works great for a PCL printer, not so well for PS

    Thanks realeric!

    Instructions worked perfectly for me first try.

    There do seem to be some slight incompatibilities between AirPrint and PostScript (at least the PostScript driver for my Xerox 6180). After the main printout I get some extra pages with some PostScript error messages.

    I installed a PCL 6 driver for the same printer and it worked perfectly with no errors. However the print quality isn't as nice (a bit blurred/less crisp than when printing with the PS driver).

    Anyway, it's really cool that I can print from my phone now. But perhaps the reason they didn't go live with this is because the AirPrint interface still needs some work, as evidenced by the minor things I've just mentioned above (PS errors, fuzzy text).
     
  16. cheeseplane, Nov 24, 2010
    Last edited: Nov 24, 2010

    cheeseplane macrumors newbie

    Joined:
    Jun 1, 2010
    #66
    Nope, unfornately not... Has been a pain in the ass for me too.

    Hmm, that's weird. I've had no single problem on XP (Home Edition) with the quick install prog. Try the following: open up Run, type in 'services.msc', and look for Airprint -> Rightclick, Properties. Find the option to run the service automatically when booting.

    It should look something like this (and yes, I'm Dutch ;)) http://dl.dropbox.com/u/668991/AirPrint.Service.jpg
     
  17. Amazing Iceman macrumors 68040

    Amazing Iceman

    Joined:
    Nov 8, 2008
    Location:
    Florida, U.S.A.
    #67
    You need to use the username and password you use to log into your PC. If you don't have one, use the Administrator account. Otherwise, create a new account and make it either Power User or Administrator.
    It's working for me since I typed the Administrator account and password.
     
  18. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #68
    Wired Printer?

    Has anyone gotten this working on a wired, non wireless enabled printer? It works perfectly on my wireless HP, but when I try to print from my wired lexmark, I click print and it just says waiting for printer.
     
  19. django696 macrumors member

    django696

    Joined:
    Jul 6, 2010
    Location:
    South Carolina
    #69
    I downloaded the elpam,my printer now shows up on IP4, but does not print. Shows the lock symbal, but I have it shared. I also have the printer wired to the back of my router, I can print from my pc and playstation but not the phone. Any ideas for me??????
     
  20. djltoronto macrumors member

    Joined:
    Dec 22, 2009
    #70

    what OS?
    elaborate on how you have it shared?



    I have XP, and have a network printer shared VIA my XP machine. (having a network printer alone is not enough).

    (note, if you have done this already - I have no further advice - sorry)

    Must be shared a la
    [​IMG]
     
  21. realeric thread starter macrumors 6502a

    realeric

    Joined:
    Jun 19, 2009
    Location:
    United States
    #71
    It may work, but the dependency with bonjour service doesn't set properly.
     
  22. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #72
    I finally got this thing working on Win7. Thought I'd post this here just in case anyone else finds this info useful.

    First of all, I was able to see the shared printers on my iPad, but when I tried to select one, it would keep spinning wheels without offering me any password screen. I solved this by going into Firewall settings, and checking both "private" and "public" on AirPrint, Bonjour, and Bonjour Service. All three were initially just checked on "private." I'm not sure if all three need to be checked on "public," but I'm not turning them on and off one-by-one just to see what happens. :p

    Next, since I don't usually use a password on my user account, I turned on the Guest Account, as has been suggested in this thread. Voila! I can now print from my iPad! However, this left me with a login screen asking me to select between my User Account and the Guest Account every time I rebooted Windows. I found a way to bypass this. Open the "run" window (select "run" from Start Menu or press Win+r), then type: control userpasswords2, and hit enter. Uncheck "User must enter user name and password." You'll be asked to select a user account to automatically boot into.

    Now, I can boot into Windows without having to enter a password or select between user accounts, and the iPad prints using the Guest Account. :)
     
  23. mmdmurphy, Nov 25, 2010
    Last edited: Nov 25, 2010

    mmdmurphy macrumors newbie

    Joined:
    Nov 25, 2010
    #73
    Printing from iPad

    Ok, uh, everyone get ready to say "RTFM"... Ready?

    I did all that, but now how do I tell my iPad to look for a printer?

    --------------

    Nevermind. The correct answer is to find an app that supports it..... I used Evernote, opened a document, and "clicked" on the square box with the arrow pointing to the upper right. Email and Print came up as the 2 options. I chose Print. At first, it didn't see a printer, then after I restarted the Bonjour service (and because of the dependency, the AirPrint service also restarted), it found it. Prompted for user name and password, and after I put that in, I was able to print my document.
     
  24. django696, Nov 25, 2010
    Last edited: Nov 25, 2010

    django696 macrumors member

    django696

    Joined:
    Jul 6, 2010
    Location:
    South Carolina
    #74
    Finally got it working,went from the spinning wheel to, no printer found, to enter password. had to redownload elpam,then enter a password on my admin account. Thanks for all the help and suggestions & Happy Thanksgiving, don't eat too much bird!!!! I'm running XP on a dell laptop with a HP printer D-7460
     
  25. Amazing Iceman macrumors 68040

    Amazing Iceman

    Joined:
    Nov 8, 2008
    Location:
    Florida, U.S.A.
    #75
    If the AirPrint service doesn't start...

    If the AirPrint service doesn't start, don't forget to install Bonjour support for Windows.

    You can get it at the Apple website; just Google it.

    It seems I lost the link :confused:
     

Share This Page