Enabled AirPrint in iOS 4.2/iTunes 10.1/Shared Printers/Windows 7

Discussion in 'iPhone' started by realeric, Nov 12, 2010.

  1. nmat macrumors newbie

    Joined:
    Mar 24, 2011
    Location:
    Lisbon, Portugal
    #101
    After some months, could you tell me how this has been working out for you? Does this method work flawlessly, or it requires occasional maintenance? I was looking for a way to print wirelessly from my iPad, but I want a reliable setup.
     
  2. 46romik macrumors newbie

    Joined:
    May 1, 2011
    Location:
    Russia, Belgorod
    #102
    Hi! Immediately apologize for my English, I write you from Russia:)
    I have a problem with printing from ipad (first generation) on the HP 1102w. There windows 7 itunes latest version, everything is connected through an access point zyxel p330. The printer is shared, Guest account wound up, firewalls disabled.
    Safari can not find the printer, but if try to print with other programs, they find my printer, but not through airprint, and through bonjour. However, despite the fact that finding through bonjour, trying to print but the printer does not print anything. I beg you to help sort out.
    :apple:
     
  3. jweaver macrumors member

    Joined:
    Apr 15, 2011
    #103
    I really hope that someone here can help me...

    I stumbled upon this post and after a few attempts, managed to find the necessary files to work with XP (32 bit).

    To my surprise it worked first time.. My printer (Dell 1320c) appeared on my iPad and it worked perfectly.

    But tonight I tried to print and my iPad says "No Printers Found".. I have hit the "Select Printer" option countless times and I get the same message every time.

    The thing is that NOTHING has changed on my PC or network.. But out of frustration, I did the following

    1. Removed the Airprint service and started again

    2. Did a system restore back to before I installed Airprint and started again.

    3. Removed my printer and drivers and started again.

    And in every case, I can't see the Airprinter on my iPad.. I can't for the life of me work out what I am doing wrong and I hope someone here can help..

    My fingers are crossed!

    Jon
     
  4. jweaver macrumors member

    Joined:
    Apr 15, 2011
    #104
    I fixed it.. After a very late night (3:30am) I gave up.. I don't know why I stayed up so late, but I got so engrossed and frustrated that I just couldn't stop.. In the end I ran out of things to do. Believe me I tried everything and ended up learning an awful lot about "services"..

    Today I noticed that my "TVersity" was only intermittently showing in AirPlayer, so i started to think that this was a wider/bigger problem. But weirdly I COULD connect to my PC using VNC and SplashTop.

    Using a network tool called "scanny" I was able to see the Print and Bonjour ports were open and by stopping the relevant services, I could see the ports were appearing and disappearing..

    But it still didn't work and I started to think "router".. Instead of rebooting my router, I simply reserved a new IP address for the iPad and then renewed my lease.. And when I got the new address, suddenly everything started working again.. TVersity was permanently shown under AirPlayer and my printer immediately appeared under "Print".

    So I am pretty sure that this was a router problem.. Will keep an eye on this over the coming weeks to see if it re-occurs!

    Jon
     
  5. Radoo macrumors regular

    Joined:
    Feb 5, 2011
    Location:
    Europe
    #105
    Thank you for this feature. Works like a charm.
     
  6. gschallner macrumors newbie

    Joined:
    May 26, 2011
    #106
    Error

    >>> Let Windows Firewall allow AirPrint to communicate on the networks (Double >>> click on the airprint.exe)[/QUOTE]

    When doing this, I get an error message:
    Unable to remove "C:\DOCUME~1\Standard\LOCALS~1\Temp\/cupslite" No such file or directory
    XpdfPrint library version = 3.02.33

    What can I do about this? I am using WinXP-Pro 32Bit and have got an iPhone4 vers. 4.3.3

    Thx
    Georg
     
  7. bryter, Jun 7, 2011
    Last edited: Jun 7, 2011

    bryter macrumors newbie

    Joined:
    Nov 24, 2010
    #107
    I keep getting the error as seen in the attachment. I tried re adding everything but no luck

    EDIT: Deleting the airprint service from Services fixed the issue. It is working now :)
     

    Attached Files:

  8. hbspro macrumors newbie

    Joined:
    Sep 13, 2011
    #108
    Air print installation problems

    Hi I'm trying to install air print activator on my w7 PC but I receive the following message:
    unable to remove "c:\User"Jorge\AppData\Local\Temp\/cupslite/cupslite" - no such file or directory
    HP Laserjet Professional P1102w: DeviceCapabilities(DC_ENUMRESOLUTIONS) failed
    XpdfPrint library version = 3.02.33

    Does anybody knows what sould I do???
    Any help would be appreciated
     
  9. stogie53 macrumors regular

    stogie53

    Joined:
    Dec 4, 2008
    #109
    Help!!!

    I have the same problem except for Epson nx510 printer!!


     
  10. nick2421 macrumors newbie

    Joined:
    Oct 13, 2011
    #110
    Airprint.exe Update for IOS 5 / Itunes 10.5 / Windows 7

    Hi,

    Has anyone found a new workaround for this airprint.exe to work with iOS 5 and Windows 7?

    As soon as I upgraded my ipad 2, the printing workaround no longer works with iOS 5. I have held off updating my wife's iPhone as the workaround still works with iOS 4.

    Not sure if the developer abandoned the project. The last post on the below link was Nov 2010.

    http://jaxov.com/2010/11/download-airprint-installer-for-windows-7-xp-vista/

    I'm guessing the code needs to be updated to be iOS 5 ready.

    Hopefully someone will work there magic soon.

    Thanks,
    Nick
     
  11. djltoronto macrumors member

    Joined:
    Dec 22, 2009
    #111
    Yes please, hopefully someone smarter than I can get this working!
     
  12. ScoutDad macrumors member

    Joined:
    Mar 25, 2011
    #112
    Anyone out there have any news on whether this has been updated for iOS 5? I miss not be able to print from my iPhone/iPad. :( This worked perfectly for me under iOS 4.
     
  13. ScoutDad macrumors member

    Joined:
    Mar 25, 2011
    #113
    Did a little more searching and found this program: Fingerprint

    http://www.collobos.com/index.html

    Downloaded a 7 day trial version. They have it for both macs and PCs. I'm evaluating the PC version and it seems to work thru my networked Hp 1320 printer as long as my PC is on. I'll test it out over the next week before I decide whether it's worth the $10.
     
  14. meterman macrumors newbie

    Joined:
    Dec 4, 2011
    #114
    I am getting the same error.

    I was able to get everything running about a year ago, but I was running Vista 32bit and obviously iOS4, I have recently upgraded to Win7 64bit (on the same PC).

    I did restart Bonjour and made sure multicast was enabled. Still no luck.

    get this failure running Airprint.exe

    Listening for connections on 0.0.0.0:631...
    Listening for connections on [::1]:631...
    Unable to remove "C:\Users\Jim\AppData\Local\Temp\/cupslite/cupslite" - No such
    file or directory
    Canon MP830 Series Printer: DeviceCapabilities(DC_ENUMRESOLUTIONS) failed
    Canon Inkjet MP830 Series: DeviceCapabilities(DC_ENUMRESOLUTIONS) failed
    XpdfPrint library version = 3.02.33

    I installed the 7 day trial of FingerPrint, which works well.

    I'd rather get AirPrint running.

    any help would be appreciated.
     
  15. ssanders79 macrumors member

    ssanders79

    Joined:
    Mar 24, 2009
    Location:
    Celebration, Fl
    #115
    FingerPrint works great, but I am not to the point where it is worth the $10. I used it once after setting it up in the trial and it worked great. I rarely print so it was nice to have available when AirPrint + iOS 4 worked. I hope there are some devs out there that can put together a free alternative compatible with iOS 5.
     
  16. meterman macrumors newbie

    Joined:
    Dec 4, 2011
    #116
    It's been awhile since I've revisited trying to find a solution. Has anyone made any progress with this topic?

    I ran the following to remove the service:
    C:\Users\Jim>sc.exe delete airprint
    [SC] DeleteService SUCCESS

    C:\Users\Jim>sc.exe create AirPrint binPath= "C:\Program Files (x86)\AirPrint\ai
    rprint.exe -R _ipp._tcp,_universal -s" depend= "Bonjour Service" start= auto
    [SC] CreateService SUCCESS

    C:\Users\Jim>sc.exe start airprint

    SERVICE_NAME: airprint
    TYPE : 10 WIN32_OWN_PROCESS
    STATE : 2 START_PENDING
    (NOT_STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
    WIN32_EXIT_CODE : 0 (0x0)
    SERVICE_EXIT_CODE : 0 (0x0)
    CHECKPOINT : 0x0
    WAIT_HINT : 0x7d0
    PID : 10064
    FLAGS :

    after that I run the AirPrint.exe and get the same error as in the quotes.
     

Share This Page