Enabled AirPrint in iOS 4.2/iTunes 10.1/Shared Printers/Windows 7

Discussion in 'iPhone' started by realeric, Nov 12, 2010.

  1. gpc17 macrumors regular

    Joined:
    Aug 11, 2010
  2. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #78
    Initial command results in success
    Second command returns
    [SC] StartService FAILED 2:
    The system cannot find the file specified

    Any ideas (by the way, the Firewall sees the AirPrint and it shows as auto started service dependant upon Bonjour)
     
  4. shadowness macrumors regular

    Joined:
    Apr 24, 2010
    #79
    Print to pdf

    Anybody tried using any virtual printers like PDF creator or bullzip with AirPrint?

    I have explained the problem here in this thread on the iPad forum
    http://forums.macrumors.com/showthread.php?t=1055264


    Have anybody succeeded in printing to PDF in windows at all?
     
  5. fabienduchene macrumors newbie

    Joined:
    Nov 28, 2010
    #80
    This is a classic error message: not enough privileges

    Hi Brian,
    you are running the cmd.exe command prompt under the identity of a user who does not has the right to create a service.
    Before typing the sc.exe commands, you need to open a command prompt with higher privileges.
    This can be achieved by typing runas /user:[USER_WITH_HIGHERPRIVILEGES] cmd.exe
    You will then be prompted for the user password.

    Or, if you are running Windows Vista or 7, you can type cmd.exe right on the top of the Start icon, and then right-click on cmd.exe and select "Run as an administrator".

    Hope this helps.

    Cheers.
     
  6. RhythmGuru macrumors member

    RhythmGuru

    Joined:
    Nov 7, 2010
    #81
    Thanks for the input. I have verified that the service does start when the PC is rebooted. My issue is that the printer isn't actually recognized by my iPhone and iPad unless I manually start the airprint.exe file, which then opens the cmd prompt and shows the IP connection log, etc., as I print. Without that program open, my printer doesn't show up. I don't believe I did anything wrong in setup, as I tried both the quick install and manual methods.

    I was curious if I could "autostart" airprint.exe when my PC restarts, so I don't forget to start it manually. That's where I thought a script would be nice... Not sure if that's the answer or not.
     
  7. danpass, Nov 30, 2010
    Last edited: Nov 30, 2010
  8. big samm macrumors 65816

    Joined:
    Oct 27, 2008
    #83
    can someone plese tell me how to remove airprint form my windows vista 64bit? each time i try to delete the AirPrint folder it says i need some permission to delete it... what permission? am the administrator and i dont have a password on the laptop...
     
  9. lindsey328 macrumors newbie

    Joined:
    Jun 30, 2010
  10. PJS2020 macrumors newbie

    Joined:
    Dec 28, 2010
    #85
    Intermittent

    Thanks realeric for posting a solution to printing from iPad. This worked perfectly first time with my Windows XP PC and Brother printer. Unfortunately, as per tbolt's post, it has been getting less and less reliable and now most of the time the iPad doesn't find any printers. I have tried all the usual things (restarting both the PC and the iPad) and have also made sure the AirPrint service is started and the Bonjour service is running. WiFi network is fine also.

    Any ideas as to why it could have stopped working or gone very intermittent? Is there an update to the AirPrint service exe available that might improve it?

    Thanks.
     
  11. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #86
    Perhaps you need to stop the process first. Open task manager, go to process tab, look for AirPrint.exe, stop process.
     
  12. CrashMeister macrumors newbie

    Joined:
    Jan 4, 2011
    #87
    Not working on a Domain (Work)

    I have installed and started the service, can see the printers, but cannot get past the login screen on the iPad.

    I am trying to use this at work, within a Domain. I have tried using my username/pswd, Guest, AirPrint and who knows how many other combinations. Every time I get 'invalid password...'.

    Has anyone gotten this to work within a Domain ? If so, please let us know how.

    Thanks,
    Craig.
     
  13. Stratus Fear macrumors 6502

    Joined:
    Jan 21, 2008
    Location:
    Atlanta, GA
    #88
    The only way I've been able to get it to work on a domain is to put any users who need AirPrint capability in the Print Operators group on the domain. Not ideal, but I haven't found any other workaround.
     
  14. CrashMeister macrumors newbie

    Joined:
    Jan 4, 2011
    #89
    Bummer. Thanks. I was trying to slip in under the wire.

    I've sent a request to the network guy, but I suspect he will be unhappy. Oh well...
     
  15. CrashMeister macrumors newbie

    Joined:
    Jan 4, 2011
    #90
    Our network guy obliged, and I am now a member of the print operators group.

    Still no luck using my ID/pswd.

    The message I get when trying to sign is says: Password required for "Dell Laser Printer xxxx @ mycomputername.co-name.local".

    How exactly are you guys specifying your credentials?
     
  16. Stratus Fear macrumors 6502

    Joined:
    Jan 21, 2008
    Location:
    Atlanta, GA
    #91
    I was specifying my username in DOMAIN\username format, and it was working for me. Try that. If your own computer is hosting the printer, it may be a good idea to restart the computer first (so the computer can refresh domain settings and realize that your user is a Print Operator).
     
  17. CrashMeister macrumors newbie

    Joined:
    Jan 4, 2011
    #92
    Tried all of the above and then some, but still dead in the water. Our network guy will look into it, but it is at the bottom of his 'to do' list. He's just doing me a favor.

    BTW, works fine at home on my iMac.
     
  18. fabienduchene macrumors newbie

    Joined:
    Nov 28, 2010
    #93
    Printing from iphone, ipad or mac using airprint in an Active Directory domain

    Please check out that blog post "Printing from iphone, ipad or mac using airprint in an Active Directory domain"

    Hope this helps.

    Cheers.
     
  19. theone09 macrumors regular

    Joined:
    Nov 17, 2008
    #94
    yes, working perfectly on my iphone/ipad!! in fact, you can enable your "Guest" in windows, then when it asks you windows account, just enter the word "Guest" without quotes. Thank you!!
     
  20. DanMan9 macrumors newbie

    Joined:
    Feb 21, 2011
    #95
    Me too:mad:, can any1 help?:eek:
     
  21. stocis macrumors newbie

    Joined:
    Oct 20, 2010
    #96
    installed airprint fine, services running fine
    ipad finds the printer but as soon as i press it it keeps showing the spinning loading circle.. please help me guys. been tryin for ages to work this out.

    windows 7 x64
    samsung clp310
     
  22. danizzz, Mar 15, 2011
    Last edited: Mar 15, 2011

    danizzz macrumors newbie

    Joined:
    Mar 15, 2011
    #97
    Sr guys i have big time trouble to make it work!

    When i enter those two lines in the "cmd" i receive:

    [sc]create service failed 1073:

    [sc]start service failed 1056:

    If i start airprint.exe i receive in the dos:

    Listening for connections on 0.0.0.0:631...
    Unable to remove "C:\DOCUME~1\DANILO~1.000\IMPOST~1\Temp\/cupslite/cupslite" - N
    o such file or directory
    XpdfPrint library version = 3.02.33


    Dont't know what to do....


    I have a canon MP600 wired via usb to a HP wifi laptop.
    OS is windows 7.

    Help!
     
  23. lalvarado macrumors newbie

    Joined:
    Mar 15, 2011
    Location:
    Dubai
    #98
    I have, by using a PDF creator called CutePDF. It installs a "printer" driver you can use to send any document a converts it to PDF. The issue I had initially was that when printing from Windows the application asks for a name and destination folder for the PDF. But when I tried from the iPad it was not asking me for anything even though it was telling me the file got printed. Then I figured out the software was putting the new PDF file in the \Windows\Temp\cupslite folder with a number as a the name, which increases by one everytime you print a new file.
    I created a shorcut to that folder and, voila, I can convert files from the iPad into PDF then bring them back to the iPad.
    Just don't forget to share the CutePDF "printer" the same as with any other. My system is a Win7 x32 but I guess this should work with any other OS.

    I hope this helps. Cheers.
     
  24. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #99
    Try deleting those quotes and retyping them. Rich text styled quotes dont work.
     
  25. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #100
    thanks for this!
     

Share This Page