Enabled AirPrint in iOS 4.2/iTunes 10.1/Shared Printers/Windows 7

Discussion in 'iPhone' started by realeric, Nov 12, 2010.

  1. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #26
    OK, I had the exact same problem. I created a password for login, and then the Airprint issue was solved.
     
  2. zTaras macrumors newbie

    Joined:
    Nov 19, 2010
    #27
    Thanks a lot! It all works:D
     
  3. derrick1985 macrumors newbie

    Joined:
    Nov 20, 2010
    #28
    Hi,

    I can't seem to get this to work for me unfortunately.

    I downloaded and followed the instructions to the letter, and I cannot see any printers when I try to print.

    I have a Brother Printer that is connected via ethernet to my router, which the other computers (and iPhone) in my house connect to. I have iTunes 10.1 (NOT BETA) and iOS 4.2.1 installed on my iPhone 4. Windows Firewall, AVG Free anti virus.

    Not sure what is going on here, was really looking forward to AirPrint in this iOS and would like to get it working.

    Thanks in advance.
     
  4. derrick1985 macrumors newbie

    Joined:
    Nov 20, 2010
    #29
  5. iPipe macrumors newbie

    Joined:
    Nov 21, 2010
    #30
    Hi all. I am italian and sorry for my bad english.
    I've followed step by step the guide. The iPad detects the printer but when I click on the button "print" I get the message: "contact printer".
    Anyone have an idea for help me?
    I've on the iPad iOS GM iPad 4.2.1, but I think that isn't important.

    Thanks
     
  6. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #31
    Great Instructions. Working perfectly for me. For everyone who is having a problem with asking for a username or password, you need to enable a guest account in user account control. Restart and it should work.

    The only problem is that you need to have AirPrint.exe open every time you want to print. This creates an annoying cmd prompt window. Anyone know how I could keep AirPrint.exe open in the background without this window?

    Thanks!:apple:
     
  7. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #32
    Creating a password solves A LOT of sharing issues for any OS.
     
  8. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #33
    Sorry, but you don't need to create a Guest Account. It works with your normal login/password.
    Secondly, the Airprint.exe shouldn't have to be run every time. Follow the instructions carefully.
     
  9. reyno28 macrumors member

    reyno28

    Joined:
    Jun 17, 2010
    #34
    Is it possible to connect to a networked printer at work while im connected to the work wireless. Its the same wireless that the laptops are connected to and they can connect to the printers.
     
  10. iPipe macrumors newbie

    Joined:
    Nov 21, 2010
  11. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #36
    Oh ok. I don't have a password on my account so I found that enabling a guest account would work.

    When I don't have AirPrint.exe open, my printer isn't detected. I have to have it running to use AirPrint. How did you do it?
     
  12. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #37
    This is what is happening to me. As soon as I close the cmd prompt window it stops working.:eek:
     
  13. KTK1990 macrumors 6502

    Joined:
    Dec 26, 2008
    #38
    Thank you. It worked good, but I cant get it to work.

    The account I have on the computer I installed it on does not have a password. Is there a way to have it with no password? Or use the usercontrolpass32(Or similar command) to login automatically with the password?
     
  14. StepsAscend macrumors newbie

    Joined:
    Mar 14, 2009
    #39
    This works!

    To anyone having trouble, go to Control Panel and user accounts and turn on the Guest account. When iPad prompts for user and pass, just put Guest as the user and leave password blank. Or use a password if you like.
     
  15. elie195 macrumors newbie

    Joined:
    Sep 16, 2009
  16. jim4637 macrumors newbie

    Joined:
    Jul 25, 2010
    #41
    You need to run "cmd" as administrator.

    Go to Start>All Programs>Accessories>Command Prompt... Right-click on Command Prompt and select "Run as administrator" then hit enter, after the security warning just copy and paste...



     
  17. DrFillster macrumors member

    Joined:
    Aug 23, 2008
    #42
    Thanks for all the hard work putting this together!

    I have a Windows 7 machine set to a homegroup, an Epson 610 networked printer

    I have followed the instrutions I believe...
    It says the airprint service is working.

    And it can't find my printer. I'd appreciate any help.

    TIA,

    Phil
     
  18. MaFt macrumors newbie

    Joined:
    Feb 12, 2009
    #43
    Sweet. Cheers guys!

    I already had the AirPrint files (I saved them from beta1 before updating to public release as I knew it wasn't included) so all I needed was the command for actually running the service.

    Thanks muchly!

    MaFt
     
  19. melvin1337 macrumors newbie

    Joined:
    Nov 19, 2010
    #44
    For those of you who don't wish to use a password, you can allow blank passwords to be used on your computer, this way the only thing you need to insert when connecting to a printer is your username

    Here's how:

    [Start] [Run] and type gpedit.msc and click [OK]
    Navigate to Computer Configuration/Windows Settings/Security Settings/Local Policies/Security Options
    Double click on Accounts: Limit local account use of blank passwords to console login only.
    Select the radio button next to Disabled and click [OK]

    :D
     
  20. H14 macrumors newbie

    Joined:
    Nov 23, 2010
    #45
    .. or you could just download and install the "AirPrint Installer for Windows" from http://elpamsoft.com/Downloads.aspx. Very straightforward and easy install, got printing working instantly!
     
  21. melvin1337 macrumors newbie

    Joined:
    Nov 19, 2010
    #46
    Does this do exactly the same as OP is describing, or does this do something else?
     
  22. H14 macrumors newbie

    Joined:
    Nov 23, 2010
    #47
    It does exactly the same, but the only thing you need to do is click "install". Even the firewall exceptions should be added automagically by the program.
     
  23. mdhansen5 macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Colorado
    #48
    Working perfectly. Thanks so much for your work!
     
  24. Dems133 macrumors newbie

    Joined:
    Dec 11, 2009
    #49
    need help

    I’ve all done this, and this worked it said succes (or something) but on my device I see no printers – and yes he is on!
    I’ve tried to open it opens the terminal window and says this:
    Listening for connections on *********…
    Listening for connections on *******….
    Unable to remove “C:\Users\MyName\Appdata\Local\Temp\/cupslite/cupslite” – No such file or directory
    Canon Inkjet iP4200: DeviceCapabilities failed
    XpdfPrint library version = 3.02.33
     
  25. Advance The Man macrumors 6502

    Joined:
    Apr 6, 2005

Share This Page