External HDD only mounts after 20 minutes of whirring, is it dying?

Discussion in 'macOS' started by baryon, Oct 12, 2016.

  1. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #1
    I'm using a 2TB Samsung (Model: HD204UI) 3.5 inch hard drive in a Sharkoon QuickPort Duo USB 3 dock, and most of the time it works fine, it's fast, no problems. I use it to back up another external drive with a little app called Backup Buddy, so it's not the end of the world if it dies. I just want to know what this is and if I can fix it.

    Then sometimes, like right now, I plug it in and it won't show up on the desktop. Its drive access LED is blinking furiously and it's making a lot of noise. It's definitely "doing something" but the OS won't let me access it until it's done with whatever it's doing.

    During this time, in Activity Monitor, the process called "fsck_hfs" is using 70% of the CPU. I imagine this is related to the HFS partition on that disk. I guess the OS is seeing something wrong with the disk and is trying to fix it.

    It will do this on other computers, and in other enclosures too. Other WD hard drives I have run fine in the same dock.

    Once, I noticed that there was a "DamagedFiles" folder on the root of that drive with two tiny unreadable files in it.

    Screen Shot 2016-10-12 at 15.07.15.png

    When I open Disk Utility while it's plugged in but not mounting, Disk Utility refuses to load anything, it just says "Loading Disks" and I can't use it at all, like this:

    Screen Shot 2016-10-12 at 14.52.33.png

    Then eventually (in about 10-20 minutes) the drive stops whirring, fsck_hfs stops taking up 70% of CPU, and the drive mounts on its own and Disk Utility starts working again, reporting no issues.

    Then a few months later, the issue happens again.

    What could this be exactly? It seems like a specific file system repair thing that the system is doing. Could it be normal housekeeping? Or is my drive dying physically? Should I try formatting it and starting over with it?

    Is it possible that there is nothing physically wrong with the disk, but the "Backup Buddy" app I'm using keeps messing something up while backing up? Can anyone recommend another simple incremental backup app (like Time Machine)?

    Thanks for any help!
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
  3. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #3
    Have you ruled out the dock that it is in, ie. used another cradle or connector? Sounds like it is the drive, but you never know.
     
  4. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #4
    Yes! I tried it with the enclosure it originally came with and it did the same thing once or twice, even connected to another Mac.
     
  5. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #5
    Thanks, however it seems like I can't read the SMART status of this particular disk. All other disks (including external) I've tried display SMART status correctly but this one seems to be "not supported". I doubt it doesn't support SMART altogether since it's not such an old drive, but I guess this drive just doesn't communicate its status over USB. It works fine with my external WD drives with the same dock, and the internal Apple SSD...
     
  6. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #6
    Hmm, OK Baryon -- thank you for taking the time to run through the troubleshooting!

    Well if the cables are all OK, it's likely to be the drive. To be honest, if it's an older drive, it'll likely be failing from wear-and-tear anyway.

    Sorry I couldn't be of more help.
     
  7. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #7
    Isn't that actually a Seagate drive rebranded? If so, you might be able to use SeaTools on a Windows-type PC to check it.

    Is it still under warranty?
     
  8. baryon, Oct 12, 2016
    Last edited: Oct 13, 2016

    baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #8
    Didn't think of that, I'll try that out thanks!

    Edit: While SeaTools seems to be able to help with both my internal Apple SSD and my Western Digital USB drives, it can't see my Samsung either...
     
  9. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #9
    What I'd suggest you do:

    1. MAKE SURE THAT EVERYTHING ON THE SAMSUNG DRIVE IS BACKED UP (shouting intentional)
    2. Re-initialize the drive
    3. Run Disk Utility's "repair disk" function on it. What kind of a "report" do you get about the drive?
    4. If you get a good report, REPEAT the repair disk function at least 5-6 more times in succession.
    5. If you get a good report EACH AND EVERY TIME, then I'd copy back the data to the drive and keep using it -- SO LONG AS IT WAS BACKED UP REGULARLY.

    By the way, I'd suggest either CarbonCopyCloner -or- SuperDuper as THE BEST way to clone the contents of one external drive to another...
     
  10. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #10
    Thanks, I'll try that!
     
  11. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #11
    Are you "ejecting" the drive before you disconnect it? You must do this every time or that could also lead to data corruption.
     
  12. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #12
    Yes, always!
     
  13. Arjunwadhwa16 macrumors newbie

    Arjunwadhwa16

    Joined:
    Nov 20, 2016
    #13
    #1
    Hi guys,

    Got a serious problem.
    My external WD 1TB hard drive had 3 partitions, One major at (800GB) and the other two occupying the remaining space.
    I also had my time machine set up on this major partition (named AJ's Mac)
    Aj's Mac
    Aj Mixed
    Aj Windows
    - Somehow yesterday afternoon , Aj's Mac stopped mounting.
    Unplug, restart, plug in again , no change!
    Mount, unmount, Nothing seems to work on Disk Utility.
    Aj's Mac is still greyed out.
    Where as the other two partitions were mounting.

    I then realised that it shows Free Space : 0kb on this partition. Hence backed up my immediate next partition Aj Mixed and then deleted it to increase the size of Aj's Mac. It stands at 895 gb now and still greyed out, with Aj Windows still mounting.

    Also tried First Aid, result in the picture attached.

    Please guys help me out, i really need this partition, its got all my DATA! :(

    Thanks in advance
     

    Attached Files:

  14. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #14
    Leave it plugged in for an hour or two, maybe it's the same issue as what I was posting about. Is your disk apparently "doing" anything (blinking LED, noise) when it's plugged in, even though it's not mounting? If yes, then let it sit like that for as long as necessary, and maybe eventually it will mount. If it mounts, back it up immediately and replace it.
     

Share This Page