General Going back to stock os killed iMessage

Discussion in 'Jailbreaks and iOS Hacks' started by Mnyc, May 12, 2018.

  1. Mnyc macrumors newbie

    Joined:
    May 12, 2018
    #1
    Long story short, I had a previous iPad jailbroken and iMessages would sync between it and my iPhone seamlessly. I then updated that iPad to a stock os and suddenly the iPad would no longer receive iMessages. If I tried to send from my iPad the status bar showing it was sent would get stuck in the middle, but the other person would receive it and it showed up in the thread on my phone as normal. Checked all the options for what accounts were getting messages, etc. a million times (and read countless threads on steps to take). Nothing worked so I finally gave up.

    Now I have a new iPad and the exact same problem persists so I’m assuming the iPad iCloud backup somehow carried the error over. Any ideas on how to fix it short of wiping the iPad out and not restoring from iCloud? I can’t imagine what the error would be because my jailbreak had no apps which touched on iMessage, although I don’t know if something behind the scenes did.
     
  2. Minorite macrumors regular

    Minorite

    Joined:
    May 8, 2018
    Location:
    Poland
    #2
    I would say it's some kind of iOS bug. iCloud backup was made before or after the iOS update on iPad?
     
  3. Mnyc, May 16, 2018
    Last edited: May 16, 2018

    Mnyc thread starter macrumors newbie

    Joined:
    May 12, 2018
    #3
    First backup was made before the update. Then I restored from that after the update.

    [ETA] Because I'm an idiot, I did not set up as new when I undid the jailbreak on the old iPad and just restored from the iCloud backup, and then did the same when I got the new iPad.
     

Share This Page