Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Hey Siri "You'll need to unlock your iPhone first"

Illusion500

macrumors newbie
Original poster
Jun 22, 2016
14
7
Updated to iOS 10.1 on my iPhone. Now Siri will not open any of my apps from the sleep state. With passcode set to require after 4 hours, and phone passcode unlocked, it does not work.

In iOS 9.X I could say "Hey Siri, open maps" and the phone would wake up and maps would open. (assuming that the phone was not passcode locked, of course)

Now in iOS 10, the same request gets: "You'll need to unlock your iPhone first". But my iPhone is not locked...

I have restarted, I have turned Siri on and off. "Hey Siri" does not serve much purpose for me if she cannot open any apps. It was the driving force behind me upgrading phones and it was totally worth it... until iOS 10

If there is a setting or something I am missing, I would appreciate any help.
 

Freakonomics101

macrumors 68030
Nov 6, 2014
2,668
1,730
I attempted the same exact scenario as explained in your post. It worked as it should for me. Also on iOS 10.1
 
Comment

Illusion500

macrumors newbie
Original poster
Jun 22, 2016
14
7
I attempted the same exact scenario as explained in your post. It worked as it should for me. Also on iOS 10.1
Well, that is terrible. Now I have no idea what to do.

Please confirm, you have a passcode set, not using touch ID to unlock, Passcode timeout set to some large number, phone passcode unlocked but asleep on a black screen and you can use Hey Siri to open apps?

I can get it to work if I remove my passcode completely, but not with a passcode set regardless of timeout.
 
Comment

Illusion500

macrumors newbie
Original poster
Jun 22, 2016
14
7
Actually, after further testing, this happens to me even if I do not use "Hey Sire" and instead activate Siri via home button press. Also, I tested this on my iPad and it too now shows the same behavior. I can no longer use Siri to open any apps from a sleeping iOS device, even if it is not locked, unless I delete the pass-code from the device entirely.
 
Comment

tromboneaholic

Suspended
Jun 9, 2004
3,706
3,024
Clearwater, FL
Steps
  1. Turn your phone on by pressing the home button at the bottom of your phone.
  2. Unlock your phone. ...
  3. Open Settings.
  4. Scroll down and tap Touch ID & Passcode.
  5. Enter your pass-code.
  6. Scroll down to the section ALLOW ACCESS WHEN LOCKED and tap the switch icon beside Siri.
 
Comment

Illusion500

macrumors newbie
Original poster
Jun 22, 2016
14
7
Steps
  1. Turn your phone on by pressing the home button at the bottom of your phone.
  2. Unlock your phone. ...
  3. Open Settings.
  4. Scroll down and tap Touch ID & Passcode.
  5. Enter your pass-code.
  6. Scroll down to the section ALLOW ACCESS WHEN LOCKED and tap the switch icon beside Siri.
Yep, that switch is on. This used to work with iOS 9.X
 
Comment

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,831
19,019
Steps
  1. Turn your phone on by pressing the home button at the bottom of your phone.
  2. Unlock your phone. ...
  3. Open Settings.
  4. Scroll down and tap Touch ID & Passcode.
  5. Enter your pass-code.
  6. Scroll down to the section ALLOW ACCESS WHEN LOCKED and tap the switch icon beside Siri.
They simply allows access to Siri when the device is locked. It doesn't really have much to do with what Siri can in turn do.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.