HomeKit Homekit showing disconnected and other crazy issues

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by samsonite127, Jul 3, 2018.

  1. samsonite127 macrumors newbie

    samsonite127

    Joined:
    Jul 3, 2018
    #1
    OK So I have some very specific issues regarding my Homekit configuration. I have approx 15 devices that work just fine when I am in my home network. I have an appletv Gen 4 on tvOS 11 as my primary hub. I also have a 4th Gen iPad with iOS 10 as a secondary hub. My primary device is an iPhone X that is currently running iOS 12 Beta 3 - which might play into this but I am not sure. Currently my iPhone X - again works with all of my devices when connected to my home wifi. The settings in the home app on the iPhone show the ATV and iPad hubs both as disconnected. Now both of the these devices in the course of troubleshooting have been fully restored and the AppleID's are all confirmed to be matching, Keychain is turned on, and Homekit is enabled. If I turn my phone to LTE all of my of devices turn to NO RESPONSE. Seems like a pretty straightforward problem.

    The kicker is that on the home app on the iPad, using the same account, All of the devices work and the ATV and iPad both show as Connected. The exact same devices that the iPhone show as disconnected. In another twist, if I tether my wifi iPad to my phone (which automatically turns my phone to LTE) all of HomeKit continues to work remotely through the iPad but not the phone.

    I changed the name of my Apple TV on the box and at least confirmed that my Phone recognized that the name changed so there is some kind of connection. Now this could be just an iOS 12 issue that will resolve when the full version is released but I have not seen this issue noted anywhere.

    Anyone have any ideas or thoughts that I may have missed?
     
  2. Marshall73 macrumors 65816

    Marshall73

    Joined:
    Apr 20, 2015
    #2
    I have had issues with Homekit and iOS 12. I was unable to update the software on my new 2nd HomePod as once added it then had no response no matter what I tried even though I could airplay to it. I ended up having to reset it then setup using an iOS 11.4 device under a different user so that I could update it then reset it and add it back to my account.
     
  3. samsonite127 thread starter macrumors newbie

    samsonite127

    Joined:
    Jul 3, 2018
    #3
    It does appear that the issue has been related to iOS 12 beta and Apple seems to have flipped the switch on and just after the Beta 3 was released my Apple TV is being recognized and functional as an away hub. Also they noted in the release notes that they were having issues with inviting iOS 11 users as shared family members to HomeKit and to then invite them at a different email address which I can confirm worked. So at this point I hope we are good and no more surprises.
     

Share This Page