How To: Enable AirPrint on Windows (32/64Bit) with iOS 5+ Support

Discussion in 'iOS 5 and earlier' started by JasonHD, Dec 19, 2011.

  1. agrsaurabh macrumors newbie

    Joined:
    Jun 4, 2012
    #126
    Guest logon Airprint

    My corporate policy does not allow creation of a guest logon. After installing the utility, I can see the list of printers on my iphone 4 (IoS 5.0.1), but there is a lock symbol against it and I cant print. Is there a way to bypass the guest login functionality?
     
  2. balthier07 macrumors newbie

    Joined:
    Jun 5, 2012
    #127
    Need help here :)
    My iPad already detected my Printer but when i hit the "Print" button it displays the message: "Contacting Printer..." It doesnt print at all.
     
  3. FelixTom macrumors newbie

    Joined:
    Jun 5, 2012
    #128
    thanks man, it does work!
    but in fact will it work if I do not turn on my computer?

    ----------

    maybe need some configuration of the printer inside your PC settings?
    sth like sharing your printer
     
  4. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #129
    Nope. AirPrint and Bonjour must be running on your computer. Notice the subject of this thread?
     
  5. sFromGlasgow macrumors newbie

    Joined:
    Jun 6, 2012
    #130
    what to put in the ppd file to select the paper source

    I learnt from earlier posts that under c:\windows\temp\cupslite the airprint service is storing the pdf files. There is also a ppd file which I believe describes my airprint shared printer. It always asks me to put paper into manual feed. Is there any way for me to specify the paper source in this ppd file? Otherwise I will have to print manually again....
    I've got a Canon IP 4500.
    Many thanks!
     
  6. jhardisky macrumors newbie

    Joined:
    Jun 7, 2012
    #131
    Perfect!

    The zip file downloaded quickly and install was less than five minutes. Please read the .readme before you install! THANK YOU!!
     
  7. macbookflasher macrumors member

    macbookflasher

    Joined:
    Jun 6, 2012
    Location:
    New York
    #132
    How To: Enable AirPrint on Windows (32/64Bit) with iOS 5.x Support

    The program “AirPrint Installer” found here enabled windows users to install the AirPrint service. This allowed iOS devices to print to shared printers on the network, via AirPrint, that don"t natively support it. However, iOS 5 broke this neat windows service.

    I have made two .reg files (32/64Bit) to fix the AirPrint service, allowing iOS 5.x devices to use AirPrint through a Windows PC. I have attached a zip file containing both .reg fixes and the installer.

    Instructions:

    After extraction you should have three files:
    - "AirPrint_Installer.exe"
    - "AirPrint iOS 5 FIX - 32Bit.reg"
    - "AirPrint iOS 5 FIX - 64Bit.reg"

    1. Run "AirPrint_Installer.exe" and then click on "Install AirPrint Service".

    2. Run the "AirPrint iOS 5 FIX - 32Bit.reg" or "AirPrint iOS 5 FIX - 64Bit.reg" to install the iOS 5 fix (Choose the correct file for you operating system, 32 Bit or 64 Bit Windows).

    3. Go back to "AirPrint_Installer.exe", make sure "Service Startup" is set to "Auto" and click "Start".

    4. Restart computer.

    If there is a locked icon next to the printer on the iOS device enable the guest account in windows (Control Panel > User Accounts > Manage Another Account > Turn the Guest Account on) . Then in the "AirPrint_Installer.exe" choose to use Guest Account Auth and tick the "Enable Guest Account" box. Then click "Update". You will then need to restart. If you want windows to automatically log you in on startup, type "netplwiz" into the start menu search box, hit enter. Uncheck the box that says “Users must enter a user name and password to use this computer”, and then hit Apply. You’ll see a username and password box. Enter in the appropriate information here and hit OK..

    I hope people will find this helpful, please spread the word...
     
  8. chickoo macrumors newbie

    Joined:
    Jun 11, 2012
    #133
    Print from iPhone/iPad to wired HP C7280

    Many thanks - this has been very useful. I can now print from my iPhone and iPad to an HP C7280 Photosmart printer that is wired into my Windows XP PC via a USB cable.

    Just one point about the LOCK symbol mentioned elsewhere in this thread: I touched the required printer name on my iPhone (or iPad) and it asked me to log on. So I simply logged in with my Windows User Name and Password and voila I was able to print. I did not need to do anything with user accounts etc. I am using Windows XP so this may only work on that platform. Anyway I thought I would mention it in case it helps another reader.

    Thanks again.
     
  9. ipoddude56 macrumors newbie

    Joined:
    Sep 8, 2010
    #134
    I had the same problem running Windows XP (32bit), fixed it by adding Port 631 (TCP) into the Windows firewall exception list.

    Hope this helps someone!
     
  10. AnsM macrumors newbie

    Joined:
    Jun 27, 2012
    #135
    I had 2 problems, with a solution, I want to share:
    1. Airprint service did not run (W7). Manual start from task management to no avail.
    It did after I installed iTunes. Bonjour AND airprint service then running.
    2. No (airprint) printer(s) visible on iPad.
    After reading FAQ on fingerprint SW :rolleyes:, switching OFF/ON Wifi on iPad solved it.
    My 2 printers on Win.7 system are visible and working from iPad. :D
    Thanks and regards (from Holland).
    A.
     
  11. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #136
    I think it's mentioned earlier in this thread but there is a dependency on Bonjour. You can view dependencies via the Dependencies tab in Services if you view the Properties of the service.

    You can also view either of the .REG files in a text editor. The line with DependOnService indicates that there is a dependency.
     
  12. MajorHavoc macrumors newbie

    Joined:
    Jul 4, 2012
    #137
    No joy at all, until....

    Ok, I have read all 6 pages of this and sadly, I could not get this to work. So I walked the steps again....

    I re-installed the program, I did the x64patch, and I see the program at the proper locatation in the (x86) program's folder. (and this was the problem, keep reading...)

    I re installed the latest iTunes with Bonjour, and Bonjour is running.

    I have two printers, one attached via USB, and the other via IP to a "local port". The USB is a Cannon Pixma iP6000D. The other is an HP All-In-One 7590. Both are on and shared.

    I have tired both the Guest account and my own account (which I usually leave on anyway) and it was simply not working.

    I looked at the services list, and I see AirPrint in the list, set to start Automatic, but NOT started (after my last reboot just now.) If I click on Start the service, I got the following error:
    -----------------
    Windows could not start the AirPrint service on the Local Computer.
    Error2: The system cannot find the file specified.
    -----------------
    Hmmm, only one file that could be, so I took a quick trip to RegEdit, and it shows the following for the AirPrint Image Path name:

    C:\Program Files (x86)\AirPrint\airprint.exe -R_ipp_tcp,_universal -s

    It took me a while, but then it clicked. The problem is, my system is on the D drive, not C drive!

    I guess the patch just assumes we all use C for the normal path! DOH!

    In RegEdit, I changed the C: in the above string to D:, and started the service. No error this time, and it is working like a champ.

    SO....

    If your system is not on the C drive, and you apply the patch, you will have to go edit the Registery key (listed elsewhere in this forum) and edit in the right path.

    Thanks for all the clues, thought I would add this one more for people still stuck and thinking they have done everything right, like I did, and it still did not work.

    Cheers
     
  13. MajorHavoc macrumors newbie

    Joined:
    Jul 4, 2012
    #138
    A few more user notes I discovered

    I have a Guest Account, but it is not turned on. However, if, using the install program, I set this to the Guest account, it actually turns it on for you (when you click enable guest account). So be aware, if you think it is off, this will turn it on. Unchecking that box in the installer turns it off for you as well.

    You can use any account, and the lock icon will appear next to the printer(s). Simply tap the printer name in the list, and it will ask you for credentials.

    Seems once you put in the credentials for a locked printer, they are saved by the iOS device. It has not asked me for them again with the locked printers (so far.)

    Even though the installer says you may need to reboot after changing the user account, it seems you do not. I could change it all I wanted and it worked just fine each change without a reboot.

    Thanks again for this great fix.

    ----------

    See my reply above. You can add credentials by clicking the printer in the list.
     
  14. MajorHavoc macrumors newbie

    Joined:
    Jul 4, 2012
    #139
    OK, one strange problem....

    I am trying to print from Notes app, and I press print, and I see it send 9 pages to the HP printer on my PC (by looking at the printer queue windows.) However, it only prints the last page. Nothing else is printed.

    But, if I send to my Cannon, it prints ALL the pages (and I just discovered that my small Pixma prints both sides, did not know that!) :)

    Any idea why one printer might fail to print all the pages?

    Or is this a printer problem?

    thanks.
     
  15. ket000 macrumors newbie

    Joined:
    Jul 7, 2012
    #140
    Prints fine but getting the following extra page printed

    Printing works fine, but it prints one extra blank page and the other page with following text

    Error: undefined
    OFFENDING COMMAND: Pscript_WinNT_Min

    STACK:

    Is there anyway to suppress this message. Looks like airprint.ext is putting invalid postscript code.
     
  16. aksatob macrumors newbie

    Joined:
    Jul 11, 2012
    #141
    Airprint Photo printing

    Hello,

    does anyone get rid of photo printing issue? I have similiar expirience with Windows and Mac AirPrint Activator - works fine for printing from Safari, Mail app, PDF.. But when i try to print photos from album, it redirect priting to manual tray on printer (same on Xerox Phaser and HP printers..). I understand, that its "thinking" that i should use photo paper (and put it to manual tray) but i wants to print on regular letter or A4 paper.

    It can be corrected in printer settings on computer (instead auto select tray - use predefined tray only) but i have printers with more than one tray and want to use them :)
     
  17. g1sdaname macrumors newbie

    Joined:
    Jun 11, 2009
    Location:
    Austell, GA
    #142
    Great thread!

    Thank you for posting this thread! I'm printing all kinds of unnecessary things!
     
  18. FloriBama macrumors newbie

    Joined:
    Jul 19, 2012
    #143
    I second this

    I encountered the same issue plus the document prints legibly but the fonts are slightly off and not as sharp.

    Please advise.
     
  19. DaveInPA macrumors newbie

    Joined:
    Jul 24, 2012
    #144
    Moving to a new PC

    I had this working on my old PC. I've just gotten a new PC and set it up. I installed everything like with the first PC.

    My problem is that when I go to print from my iPad, the Printer Options box comes up and still shows the printer from my old PC. How do I get it to remove the old PC printer (which I've setup on my new PC) and get it to recognize the new one?
     
  20. planteg macrumors newbie

    Joined:
    Jan 20, 2012
    #145
    Hi DaveInPA,

    is the old PC still running ? If so and and AirPrint is still running on it, then the 'old' printer will still show on your iPad since it is still made available even though the real printer is not connected.
     
  21. gefafwisp macrumors newbie

    Joined:
    Aug 4, 2012
    #146
    This is a great solution. Thank you. It's a "nice to have" feature but it's not so useful to me that I'd be willing to pay for it.

    It's the fact that Apple don't provide things like this for free that make me really resent the company.
     
  22. aaronac8 macrumors newbie

    Joined:
    Aug 11, 2012
    #147
    I am having the same problem....Any solutions? What about settings for Recovery tab under Services?
     
  23. Br3tt macrumors newbie

    Joined:
    Aug 15, 2012
    #148
    I've got this up and running on a Win 7 64 bit machine, and a networked HP Deskjet 6980. All I had to do is share the printer.

    One thing I wanted to mention that I did not see in this thread is you do not have to install iTunes just to get the printer working (if you don't use iTunes). You can download the Bonjour service here:

    http://download.cnet.com/Bonjour-for-Windows/3000-18507_4-93550.html?

    It works just the same as if you had done an entire iTunes installation.

    Thanks!
     
  24. Jptoad, Aug 21, 2012
    Last edited: Aug 22, 2012

    Jptoad macrumors newbie

    Joined:
    Aug 21, 2012
    #149
    Please help! Not run after restart!

    I have to say love the program! I have had a lot of issues and continue to fix them as they come up! Mcafee killed and blocked, had to open new ports! MS killed it with new update! Don't know if others have run into the same problem?

    I have reinstall AirPrint several times now! And it will work, if I manually start it after windows starts? I have tryied all three setting, enabled all on all three settings? When restarting computer, AirPrint will not start, unless I go to the services and start it or restart? I have also run the iOS 5 fix file every time I reinstall. Or try something different?

    Running windows xp 32
    Mcafee
    Update iTunes, Bonjour services

    Edit-update! --- Gave up! Broke down and move to FingerPrint! Much easier with firewalls! No problems with Mcafee-xp machine, and no problems w\avast-win7! I just could not get it through the firewalls unless I turned the virus ware off! Opened every port and nothing! Could see that it was listening but the virus ware would not connect! Good luck! Wish it would have worked for me!
     
  25. mad4power macrumors newbie

    Joined:
    Jan 4, 2009
    #150
    Settings not sticking

    Hi, I'm having the same problems, every time I reboot it doesn't work. Did you get this sorted?

    Thanks
     

Share This Page