Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

tombarnes

macrumors 6502
Original poster
Feb 26, 2006
348
1
Surrey, United Kingdom
I've scoured the forums for an answer on this!

My devices, MacBook Pro, iPhone and personal iPad have been all in harmony and working just fine for years. I've just started using iMessage and other iCloud functions on my separate work iPad.

However, my work iPad formats all my phone numbers in some unknown international way. As shown below. Yet all my settings on the work iPad are the same as all m other devices. Consequently, my iMessage thread shows the numbers rather than the contact names.

I've tried changing Language and Region in settings, turning off and on again. Ive tried disabling Contact from iCloud. Turning off and on again. I've reviewed my online settings. HELP!!!

All devices are running the latest iOS/Mac OS. I've tried all of these steps on this troubleshooter https://www.mactip.net/how-to-fix-messages-showing-numbers-not-contact-names/

fullsizeoutput_1fd9.jpeg fullsizeoutput_1fd8.jpeg fullsizeoutput_1fda.jpeg Screen Shot 2019-05-12 at 12.11.58.png
 
Last edited:

mollyc

macrumors 603
Aug 18, 2016
5,431
29,346
Are the people who are showing up as numbers only actual contacts? If I get a message from an unknown sender, it only shows up as their phone number until I assign them an actual name in Contacts. Unknown people don't just show up as a name.

Otherwise I wonder if your work iPad has some enterprise software on it from your employer that is messing things up.
 

tombarnes

macrumors 6502
Original poster
Feb 26, 2006
348
1
Surrey, United Kingdom
Are the people who are showing up as numbers only actual contacts? If I get a message from an unknown sender, it only shows up as their phone number until I assign them an actual name in Contacts. Unknown people don't just show up as a name.

Otherwise I wonder if your work iPad has some enterprise software on it from your employer that is messing things up.

Yes, they are contacts! My iMessage in in sync with my other devices. They show up fine on there.
 

willmtaylor

macrumors G4
Oct 31, 2009
10,313
8,191
Here(-ish)
Just to clarify, you’ve changed language/region settings to something else and then back again to the correct one, right?
 

BrianBaughn

macrumors G3
Feb 13, 2011
8,638
1,789
Baltimore, Maryland
I'm definitely no expert on the various mobile device management (MDM) systems that are available for iOS but perhaps you should check with your IT folks to see if there's some sort of disconnect between Contacts and Messages in their setup.
 
  • Like
Reactions: willmtaylor

jpn

Cancelled
Feb 9, 2003
1,854
1,985
I've scoured the forums for an answer on this!

My devices, MacBook Pro, iPhone and personal iPad have been all in harmony and working just fine for years. I've just started using iMessage and other iCloud functions on my separate work iPad.

However, my work iPad formats all my phone numbers in some unknown international way. As shown below. Yet all my settings on the work iPad are the same as all m other devices. Consequently, my iMessage thread shows the numbers rather than the contact names.

I've tried changing Language and Region in settings, turning off and on again. Ive tried disabling Contact from iCloud. Turning off and on again. I've reviewed my online settings. HELP!!!

All devices are running the latest iOS/Mac OS. I've tried all of these steps on this troubleshooter https://www.mactip.net/how-to-fix-messages-showing-numbers-not-contact-names/

View attachment 836533 View attachment 836534 View attachment 836535 View attachment 836536


its difficult to see from the photos you have attached exactly how yr iPad is formatting the phone numbers. sorry.
but, there have been times when one some of my Messages or phone call Recents does not show the name of the person that messaged or called me, even though their number is correct in my Contacts.
i have found that i have zero problems since i converted all the numbers in Contacts to their full international dialing prefix number, including the +. then the apple iOS software does format these numbers correctly.
but, as i mentioned, occasionally i get a Message or phone call and their number only is showing, not their name.
in that case, what i have needed in order to get their name to show was to add in the same number, but formatted in the following way:
i dont remove the correctly formatted number, i just add it again in the following way.
example: +81 084 3000 1234 (the spaces in this example are put in to make the number easy to understand. in actual practice, do not use spaces or dashes.)
the zero in the grouping 084 should never* be needed when the international dialing prefix and format is used as its used only when you call within a country not internationally. but i have found that adding it in to the format usually solves it for me.

*i believe in the UK and Italy there actually are some dialing sequences that do require this zero for some reason. also, some countries that have converted to newer switching tech sometimes have legacy systems that require the "domestic zero" to still be used.
these exceptions are what i always need to fix.
i had one last week from a mobile phone in Myanmar that the owner has had for some years and a zero is needed for his mobile number to appear...

one more thing: to confirm and force a new sync of yr contacts to correspond to the region that is showing, switch it one time to a different region, then back to the correct region. this will reformat numbers correctly that were entered under a different system....

in one of your photos there is a number with a dash in it. that contact's name will never appear as a name. remove dashes and spaces when you enter numbers. let the software format it for you.
a work place Contact list has contact numbers entered by many people and these people are formatting numbers differently using non-apple devices when they do so. (probably)
in which case, entering the same number again in the same contact is the only way to get names to appear as its not a device or apple software problem but you can mitigate it by entering it in a way that your device understands.
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
I've scoured the forums for an answer on this!

My devices, MacBook Pro, iPhone and personal iPad have been all in harmony and working just fine for years. I've just started using iMessage and other iCloud functions on my separate work iPad.

However, my work iPad formats all my phone numbers in some unknown international way. As shown below. Yet all my settings on the work iPad are the same as all m other devices. Consequently, my iMessage thread shows the numbers rather than the contact names.

I've tried changing Language and Region in settings, turning off and on again. Ive tried disabling Contact from iCloud. Turning off and on again. I've reviewed my online settings. HELP!!!

All devices are running the latest iOS/Mac OS. I've tried all of these steps on this troubleshooter https://www.mactip.net/how-to-fix-messages-showing-numbers-not-contact-names/

View attachment 836533 View attachment 836534 View attachment 836535 View attachment 836536
I know it’s a few months old now, but did you find a solution?
I’m having the same issue in reverse. My iPhone constantly messes up the formatting of my contacts, placing gaps in between the numbers where they shouldn’t exist. If ‘Dial Assist’ is on, my iPhone will not recognise any numbers as it thinks the formatting is some kind of international code. So I keep it off, but changing region under settings is only a temporary fix, as within hours it changes back!
Bizarrely the contacts on my Mac are formatted correctly, despite my phone/MacBook beisynced under iCloud.
I’ve had lengthy discussions with Apple, 3 iOS updates and a new SIM card, all to no avail.
 

Crazy Badger

macrumors 65816
Apr 1, 2008
1,282
681
Scotland
I know it’s a few months old now, but did you find a solution?
I’m having the same issue in reverse. My iPhone constantly messes up the formatting of my contacts, placing gaps in between the numbers where they shouldn’t exist. If ‘Dial Assist’ is on, my iPhone will not recognise any numbers as it thinks the formatting is some kind of international code. So I keep it off, but changing region under settings is only a temporary fix, as within hours it changes back!
Bizarrely the contacts on my Mac are formatted correctly, despite my phone/MacBook beisynced under iCloud.
I’ve had lengthy discussions with Apple, 3 iOS updates and a new SIM card, all to no avail.

Agh! Mine has just done the same today! All my contact on my Mac are fine, but my phone contacts have messed up formating. It almost looks like it's applied some kind of international formatting as the first 2 number are together, but I can't seem to change anything. HELP!
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
Agh! Mine has just done the same today! All my contact on my Mac are fine, but my phone contacts have messed up formating. It almost looks like it's applied some kind of international formatting as the first 2 number are together, but I can't seem to change anything. HELP!
I feel your pain!
For me this has been going on for months, I’m fairly certain I can trace it to IOS 13, but each update doesn’t provide a fix.
As mentioned I can resolve it temporarily by changing my region (settings-general-language) to anything then back to U.K., but literally after a few hours it will revert back. Apple were utterly useless in trying to help, I was on the phone to an engineer from the US for over an hour and he just couldn’t understand it...unfortunately we ended up being disconnected and I couldn’t face going through it all with another engineer.
 

Crazy Badger

macrumors 65816
Apr 1, 2008
1,282
681
Scotland
I think I've managed to find a workaround, although I suspect the real fix is going through and changing all my UK phone numbers to have a +44 prefix.

In Settings > Phone there is a Dial Assist switch right at the bottom. I didn't even know this existed, but it was on so switched it off. I can now dial my contacts as they are saved, albeit with weird spacing between the numbers. I might start the job of changing about 800-900 contacts, although I can't say that fills me with joy :rolleyes:
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
Yes, I knew about the Dial Assist - but thanks. As you say, it means you can at least dial out but the spacing is still there.
I’m slightly encouraged it’s not just me as it must be an Apple bug, but whether it’ll be addressed is anyone’s guess!
 

jezzar1

macrumors newbie
Dec 26, 2009
4
0
I had the same issue which even after changing the region, kept reverting back to another dialling format - not UK.

However, I realised that I had a second language installed on the phone and when I deleted that, it rectified the issue itself.
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
I had the same issue which even after changing the region, kept reverting back to another dialling format - not UK.

However, I realised that I had a second language installed on the phone and when I deleted that, it rectified the issue itself.
Hmmm, I’ve gone through the settings- language and looks like only English (U.K.) is ticked...

I has a little glimmer of hope then ?

hey ho, thanks for your reply, may well help someone else
Cheers
 

Nick Arney

macrumors newbie
Dec 11, 2019
1
0
Guildford, UK
I too have been having this recurring problem and today I seem to have stumbled across a solution that makes little sense and may not last very long but see if it helps. I am UK based but by changing region to English (US) it has reset my contacts numbers to the correct format (even without changing back to UK). So my recent calls list is back to names not just numbers. Fingers crossed it stays correct but we will see!
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
Hmmm, thanks- I’d noticed that too but I’ve always changed back to UK after (as that’s my region). I’ll leave it on US for a while to see if it works. I’ve just updated to the latest iOS and it still happens, so I’m slightly at the end of my tether with it at the moment!
 

Geefunk

macrumors newbie
Nov 24, 2019
8
0
Well since my last reply it’s already messed up, so keeping it on US hasn’t changed anything
 

Prest006

macrumors newbie
Dec 17, 2019
1
0
I have nothing to do with Virgin but I have had this issue for over a year. My numbers are fine on my iPhone SE and Mac but my newish iPad cannot format. I use an Italian TIM SIM card every fall for about 6 weeks and I thought the defunct card still in the iPad might be confusing it. I removed it but I still have contacts with no formatting. The only answer I have is adding the +1 or +39 in the case of Italy.
 

ResidentRob

macrumors newbie
Dec 2, 2020
2
0
Hi All





The fix listed on here is only temporary and will change randomly back to the wrong format at any time as some of you will have noticed



Here is the 100% guaranteed fix

1st off the issue is NOT in the phone or the network provider. Most of us use Icloud to back up our phone numbers and that is the problem

On your computer goto icloud . com and log in

open Contacts then at the bottom left of the screen click on the cog for settings then select preferences

In here look for Formats and see which country it is set to. Obviously for us in the UK we want United Kingdom not United States. Once changed click save

Now restart your phone and hey presto ALL FIXED



Good Luck All



Message to Virgin Mobile Tech support make sure all your staff read this to save the hassle of us customers becoming frustrated with your staff when they are asking for help
 

Edembers

macrumors newbie
Dec 6, 2020
1
0
It turns out that the SIM card sets this! But it remembers it from the last SIM card used, even if that was in a previous iPad!! This is the second iPad I have had without a SIM card, but it still remembers my work SIM card as being the last used. Just putting a local SIM card in for a few seconds corrected it. ?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.