iPad VPN Disconnects when iPad goes to sleep or cuts of by itself and looses connectivity

Discussion in 'iPad Tips, Help and Troubleshooting' started by asnoble, May 9, 2016.

  1. asnoble macrumors newbie

    asnoble

    Joined:
    May 9, 2016
    Location:
    Alabama
    #1
    I have an iPad version 9.3.1. I just installed my companies VPN client which shows up under Settings with an On/Off switch. I notice when on 4G or Wifi after about 5 minutes the iPad will turn the screen off which is great, but when I wake it up and put my password back in, the VPN on the upper right hand corner is gone and I have to start the VPN again. Anyway around this? What can be done to keep that VPN connection alive?
     
  2. Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #2
    For my VPN if I go into Settings>General>VPN and tap the ⓘ bubble I can enable "connect on demand" and the VPN will remain connected - but you then can't turn it off unless you disable this again.
     
  3. asnoble thread starter macrumors newbie

    asnoble

    Joined:
    May 9, 2016
    Location:
    Alabama
    #3
    When I click on the ⓘ all I have is: Type - Server - Account... Your saying you have another option?
     
  4. Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #4
    Indeed. Under those options I can enable connect on demand. But depending on the VPN set up of your employer you may have disabled it. I know where I work we disabled it because we were getting people's Netflix and the like tunnelled which was resulting in unnecessary excess traffic.
     
  5. asnoble thread starter macrumors newbie

    asnoble

    Joined:
    May 9, 2016
    Location:
    Alabama
    #5
    So, there is no other way to make the VPN stay connected until you turn that VPU switch to off? Maybe at least make a time limit where it can stay connected?
     
  6. Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #6
    As your provider has prevented this, no.
     
  7. asnoble thread starter macrumors newbie

    asnoble

    Joined:
    May 9, 2016
    Location:
    Alabama
    #7
    Do you know where the provider would turn that option on at? We are looking for it in the Admin side
     
  8. Cascades42 macrumors 6502

    Joined:
    Jan 25, 2016
    Location:
    UK
    #8
    Sorry, it varies wildly depending on the set up you have - and might not even be possible.
     
  9. adilmalick macrumors newbie

    adilmalick

    Joined:
    Jun 10, 2016
    Location:
    Vancouver, Canada
    #9
    Yes usually people connect on demand from Settings>General with this activity you might be keep on the vpn, i used here might be because i didn't do this activity or i had not faced such an issue with my ipad. However for the simple solution just install the latest Purevpn aap, it keep connect with your ipad even in sleeping mood. However there are several other best vpn for ipad that keep your all ipad credential and soft copies safe and secure.
     
  10. dropme macrumors newbie

    Joined:
    May 4, 2017
    #10
    "VPN-on-Demand" is the only option to keep VPN "always on" for any iOS (both iPhones and iPads).

    However, "VPN-on-Demand" only works with one VPN protocol - IKEv2.

    Your VPN providers should offer IKEv2, and if they offer something else like OpenVPN - you won't get this "always on" option.

    Also, IKEv2 is the only protocol that seamlessly continues to work when you switch from cellular network to wi-fi. Other VPN protocols will drop the VPN connection or endlessly will try to reconnect to the old network leaving you without internet.
     
  11. parisv macrumors member

    Joined:
    Sep 25, 2008
    #11
    i've just added a dummy IKEv2 account but don't see this option?
     
  12. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #12
    I think you have to turn it off to keep the vpn always on??
     
  13. wetcanvas, Aug 3, 2017
    Last edited: Aug 7, 2017
  14. wdembi macrumors newbie

    Joined:
    Sep 11, 2017
    #14
    I know I'm late to the party but on my side of things there was a setting in our Fortigate firewall's vpn config for VPN Idle Timeout. I changed the settings from 300 seconds (coincidentally the same amount as your timeout) to never.

    This resolved the issue for me. Good luck!
     
  15. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #15
    I tried doing the same with OpenVPN app on my iPhone. Selected Option "None" but it still disconnects. Don't know whats wrong.
     
  16. wdembi macrumors newbie

    Joined:
    Sep 11, 2017
    #16
    To clarify, I made this change on the firewall itself where the VPN app is connecting to. Not on the VPN app itself.
     
  17. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #17
    Ok. I don't have any firewall between the device and router. Yet it still keeps on disconnecting.
     
  18. wdembi macrumors newbie

    Joined:
    Sep 11, 2017
    #18
    So your router handles the other endpoint of the VPN? If so, what are your router settings for idle timeouts?
     

Share This Page