iPhone 7/7+ camera issue opens to black/blurry screen with auto-focus flickering

Discussion in 'iPhone' started by cookieme, Oct 4, 2016.

?

Do you have this camera issue: black/blurry screen with auto-focus flickering?

  1. Yes on iPhone 7 (iOS 10.1.1)

    10 vote(s)
    32.3%
  2. Yes on iPhone 7+ (iOS 10.1.1)

    14 vote(s)
    45.2%
  3. Yes iPhone 7 (iOS 10.2 beta)

    1 vote(s)
    3.2%
  4. Yes iPhone 7+ (iOS 10.2 beta)

    6 vote(s)
    19.4%
  1. cookieme, Oct 4, 2016
    Last edited: Nov 10, 2016

    cookieme macrumors regular

    Joined:
    Aug 22, 2005
    #1
    I got a new iPhone 7 running 10.0.2 and I've noticed that now and then when I open the camera app the screen is very dark. If I power off and on (not hard reset), the camera works normally again.

    I'm not sure if this is a hardware defect/bug or an iOS 10 bug?

    Anyone else experience this?

    UPDATE: iPhone 7 running iOS 10.1.1
    I have followed all the troubleshooting steps that Apple has instructed me to and this issue still persists!

    The issue is as follows when you open the camera app:
    - the screen is black/almost black/blurry
    - switching between the front and back facing cameras makes no difference
    - the yellow square (auto-focus) flickers rapidly and sometimes pulses slowly
    - the issue happens in an unpredictable way. You can't make it happen on demand.
    - you cannot take a photo when the issue presents itself

    Very temporary solution:
    - Switch to "video" and back to "photo" mode
    - Sometimes powering on/off can help
    - Sometimes force restarting can help

    Troubleshooting steps you've done:
    - On iPhone: "Reset All Settings"
    - On iPhone: "Erase All Content and Settings"
    - On iTunes: Restore iPhone and setup as new
    - On iTunes: Restore iPhone (Recovery mode) and setup as new
    - Do not restore from an iCloud or iTunes backup!

    IF you have completed the troubleshooting steps outlined above
    AND you have the camera issue as I've described above

    CONTACT APPLE SUPPORT AND GET THEM TO ESCALATE THIS TO THE ENGINEERING TEAM!
     
  2. KarmelVixen macrumors member

    KarmelVixen

    Joined:
    Sep 13, 2016
    #2
    I had something like that happen to me once. It happened the second day I had my 7+. When I would open the camera app it worked fine then the screen would go black. I did ended up doing a hard reset and haven't had a issue since. That's the only issue I ever experienced with this phone.
     
  3. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #3
    I've soft and hard reset the phone several times and it happened again.

    When it's a black screen or barely visible what the camera is pointing at (front and back) if I soft or hard reset the camera works again.

    No one else having this issue?
     
  4. LunkerHunter macrumors newbie

    Joined:
    Jan 12, 2011
    #4
    This started happening to me on my iPhone 7 with 10.0. Reset resolved it a couple days ago, but happened again today and resets and power off/on don't fix it any more. Will update to 10.0.2 tonight to see if that helps, then will try a Reset All settings... If those don't work, off to the Apple Store for a replacement.
     
  5. Sheboygan macrumors member

    Sheboygan

    Joined:
    Feb 27, 2016
    Location:
    St Louis, USA
    #5
    Yes, it's happened to me once. The only way to recover camera operation was to reboot.
     
  6. Appleloves22 macrumors 6502

    Appleloves22

    Joined:
    Sep 14, 2014
  7. jettie1767 macrumors 6502

    Joined:
    Oct 29, 2003
    Location:
    New Jersey, USA
    #7
    Happened to me as well. Had to restart the phone. I've only had my iPhone 7 for 3 days.
     
  8. kristiguin macrumors newbie

    kristiguin

    Joined:
    Oct 18, 2015
  9. iosuser macrumors 6502a

    Joined:
    Mar 12, 2012
    #9
    My daughters SE had this problem a few times. It seems to happen after she plays with Instagram. Couple of times I fixed it by cycling between different photo and video modes. If u use Instagram give it a try.
     
  10. jfc723 macrumors newbie

    Joined:
    Jan 9, 2015
    #10
    again another camera app issue that somehow nobody knows about it! this is the worst camera app update ever.
     
  11. ACURA2015 macrumors regular

    Joined:
    Sep 1, 2015
    Location:
    Miami, Florida
    #11
    same thing is happening here at times, which also includes freezing while simply surfing online, at times to the point I have to hold down the power button for awhile until it shuts off. I don't think is an issue with the device itself because I returned mine and bought a complete new one and still it happens. Hopefully an update will take care of this freezing up issue.
     
  12. Rocko99 macrumors member

    Joined:
    Sep 19, 2016
    #12
    Submit bug report on apples website. Can't fix what they don't know about.
     
  13. jfc723 macrumors newbie

    Joined:
    Jan 9, 2015
    #13
    really? I didnt know that!!! thanks for the great input!!!
     
  14. Benz63amg macrumors 68000

    Benz63amg

    Joined:
    Oct 17, 2010
    Location:
    New York, NY
    #14
    It's a software issue that hopefully Apple will fix in the next iOS update, happened to me many times now on 10.0.2
     
  15. Jukens macrumors regular

    Joined:
    Jun 13, 2013
    #15
    Well yesterday morning my iPhone 7 Plus camera shutter appeared have become faulty. Every time I opened the camera app I was greeted with a black screen when using the rear facing camera. I have had this happen randomly before but a simple restart took care of the issue. I went through all the troubleshooting I could by killing the app, force restart, and then DFU restore and clean setup. After hours of this process I was still greeted with the same issue. Luckily Apple set me up with express replacement. This is my first phone to have a camera module fail and I have had multiple iPhones for every generation. Anyone else have this issue?
     
  16. Danjrel macrumors regular

    Joined:
    Oct 5, 2016
    #16
    Reviting tale, you know how to replace faulty phone.
     
  17. cacassabaum macrumors newbie

    cacassabaum

    Joined:
    Oct 15, 2016
    #17
    I've found if i switch to video then back to photo it works again. It has happened to me many times.
     
  18. kid.icarus macrumors member

    Joined:
    Oct 14, 2014
    #18
    Happened with my 7 + once yesterday. Turning the phone off and on helped.
     
  19. cacassabaum macrumors newbie

    cacassabaum

    Joined:
    Oct 15, 2016
    #19
    Try just switching to video mode and back - much faster than rebooting
     
  20. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #20
    These temporary and frustrating workarounds are great, but the real question is if this is a hardware defect in the iPhone 7 models or if there's a software bug in iOS 10.0.2 which Apple isn't acknowledging!
     
  21. iGeek2014 macrumors 68000

    Joined:
    Jun 29, 2014
    Location:
    === Nowheresville ===
    #21
    It's definitely a bug within iOS 10.0.2 and earlier.

    Had it several times myself. Since using iOS 10.1 PB it's never replicated itself (yet!)
     
  22. dillonm macrumors regular

    Joined:
    Mar 31, 2008
    #22
    I am on the beta and my phone is still doing it! Very frustrating.
     
  23. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #23
    And this is on an iPhone 7?
     
  24. dillonm macrumors regular

    Joined:
    Mar 31, 2008
    #24
    7+
     
  25. Benito macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #25
    I've had this a couple of times. Also, when the camera was the last app open and I unlock the phone and it opens to the camera app, I've also had to open upside down with the shutter button on the top. It flips back to the right orientation in a moment but it is weird. I've also had the animation for opening the camera app from the lock screen Only open half way so that the lock screen and camera app are both half on the screen. I then have to reswipe to the left to fully open the camera app. I've never had problems with the camera app before iOS 10.0.2.
     

Share This Page