Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Do you have this camera issue: black/blurry screen with auto-focus flickering?

  • Yes on iPhone 7 (iOS 10.1.1)

    Votes: 10 32.3%
  • Yes on iPhone 7+ (iOS 10.1.1)

    Votes: 14 45.2%
  • Yes iPhone 7 (iOS 10.2 beta)

    Votes: 1 3.2%
  • Yes iPhone 7+ (iOS 10.2 beta)

    Votes: 6 19.4%

  • Total voters
    31

cookieme

macrumors regular
Original poster
Aug 22, 2005
156
1
I got a new iPhone 7 running 10.0.2 and I've noticed that now and then when I open the camera app the screen is very dark. If I power off and on (not hard reset), the camera works normally again.

I'm not sure if this is a hardware defect/bug or an iOS 10 bug?

Anyone else experience this?

UPDATE: iPhone 7 running iOS 10.1.1
I have followed all the troubleshooting steps that Apple has instructed me to and this issue still persists!

The issue is as follows when you open the camera app:
- the screen is black/almost black/blurry
- switching between the front and back facing cameras makes no difference
- the yellow square (auto-focus) flickers rapidly and sometimes pulses slowly
- the issue happens in an unpredictable way. You can't make it happen on demand.
- you cannot take a photo when the issue presents itself

Very temporary solution:
- Switch to "video" and back to "photo" mode
- Sometimes powering on/off can help
- Sometimes force restarting can help

Troubleshooting steps you've done:
- On iPhone: "Reset All Settings"
- On iPhone: "Erase All Content and Settings"
- On iTunes: Restore iPhone and setup as new
- On iTunes: Restore iPhone (Recovery mode) and setup as new
- Do not restore from an iCloud or iTunes backup!

IF you have completed the troubleshooting steps outlined above
AND you have the camera issue as I've described above

CONTACT APPLE SUPPORT AND GET THEM TO ESCALATE THIS TO THE ENGINEERING TEAM!
 
Last edited:

KarmelVixen

macrumors member
Sep 13, 2016
52
37
I had something like that happen to me once. It happened the second day I had my 7+. When I would open the camera app it worked fine then the screen would go black. I did ended up doing a hard reset and haven't had a issue since. That's the only issue I ever experienced with this phone.
 

cookieme

macrumors regular
Original poster
Aug 22, 2005
156
1
I've soft and hard reset the phone several times and it happened again.

When it's a black screen or barely visible what the camera is pointing at (front and back) if I soft or hard reset the camera works again.

No one else having this issue?
 

LunkerHunter

macrumors newbie
Jan 12, 2011
13
2
This started happening to me on my iPhone 7 with 10.0. Reset resolved it a couple days ago, but happened again today and resets and power off/on don't fix it any more. Will update to 10.0.2 tonight to see if that helps, then will try a Reset All settings... If those don't work, off to the Apple Store for a replacement.
 

iosuser

macrumors 65816
Mar 12, 2012
1,005
752
My daughters SE had this problem a few times. It seems to happen after she plays with Instagram. Couple of times I fixed it by cycling between different photo and video modes. If u use Instagram give it a try.
 

jfc723

macrumors newbie
Jan 9, 2015
20
2
again another camera app issue that somehow nobody knows about it! this is the worst camera app update ever.
 

IGWT15

macrumors 6502
Sep 1, 2015
349
103
Miami, Florida
same thing is happening here at times, which also includes freezing while simply surfing online, at times to the point I have to hold down the power button for awhile until it shuts off. I don't think is an issue with the device itself because I returned mine and bought a complete new one and still it happens. Hopefully an update will take care of this freezing up issue.
 

Benz63amg

macrumors 601
Oct 17, 2010
4,219
851
It's a software issue that hopefully Apple will fix in the next iOS update, happened to me many times now on 10.0.2
 

Jukens

macrumors 6502
Jun 13, 2013
268
223
Well yesterday morning my iPhone 7 Plus camera shutter appeared have become faulty. Every time I opened the camera app I was greeted with a black screen when using the rear facing camera. I have had this happen randomly before but a simple restart took care of the issue. I went through all the troubleshooting I could by killing the app, force restart, and then DFU restore and clean setup. After hours of this process I was still greeted with the same issue. Luckily Apple set me up with express replacement. This is my first phone to have a camera module fail and I have had multiple iPhones for every generation. Anyone else have this issue?
 

cookieme

macrumors regular
Original poster
Aug 22, 2005
156
1
These temporary and frustrating workarounds are great, but the real question is if this is a hardware defect in the iPhone 7 models or if there's a software bug in iOS 10.0.2 which Apple isn't acknowledging!
 
  • Like
Reactions: iAnimal

Benito

macrumors 6502a
Jan 5, 2010
618
314
Toronto, Canada
I've had this a couple of times. Also, when the camera was the last app open and I unlock the phone and it opens to the camera app, I've also had to open upside down with the shutter button on the top. It flips back to the right orientation in a moment but it is weird. I've also had the animation for opening the camera app from the lock screen Only open half way so that the lock screen and camera app are both half on the screen. I then have to reswipe to the left to fully open the camera app. I've never had problems with the camera app before iOS 10.0.2.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.