iPhone not recognised(no device found) in iTunes and Xcode

Discussion in 'iOS Programming' started by ionicdev, Apr 22, 2016.

  1. ionicdev macrumors newbie

    ionicdev

    Joined:
    Apr 22, 2016
    Location:
    Singapore
    #1
    Specs:
    1. MacBook Pro (13-inch, Late 2011)
    2. OS X El Capitan (Version 10.11.4)
    3. iTunes (12.3.3.17)
    4. Xcode (Version 7.1.1)
    5. iPhone 4s (iOS 9.3.1)

    Problem statement:
    1. My iPhone is not appearing in iTunes nor Xcode whenever I plug it to my mac directly through usb cable. The Photos app connects and shows though the list of my pictures from the iPhone.
    2. iPhone appears in System Information under USB section.
    3. I have the latest version of iOS and OSX as well as the Xcode and iTunes.
    4. Strange, when I connect my iPhone to a Windows machine, the iTunes in that PC recognises and show the devices and I am able to sync.
    5. I have been dealing with this problem for almost 3 days now.
    6. Of course, I am trusting the computer from the iPhone when the alert to the computer pops up.
    7. When I connect my iPhone to other Mac it is recognised and syncing is working.
    8. When i put my iPhone to recovery mode through iTunes my device shows and is recognised and i’m asked to update or restore it. I’ve done both but my iPhone restarts in the middle of the process and gets unrecognised again because it goes out of the iPhone recovery mode.
    9. Wireless mouse to connected to my mac via usb is working in all ports.
    10. I have USB 2.0
    11. I encounter the error “Could not connect to the Device”, “Could not connect to this iPhone “iPhone”, and “Operation timed out” from iTunes.
    12. It seems that this problem popped up with El Capital because i am able to connect few months ago to iTunes and Xcode with Maverics. I just returned coding again in Xcode after a few months of break and noticed the problem when i’m about to deploy my app to iPhone.
    What I have done so far but didn't work:
    1. Change usb port
    2. Restarted mac, iTunes, Xcode and iPhone.
    3. Downgraded iTunes to lower version (12.1). I put it back to latest version upon seeing that it didn’t work.
    4. iPhone Recovery Mode
    5. Reset SMC, PRAM, NVRAM
    6. Reset my iPhone settings (Reset All Settings)
    7. Clear /var/bd/lockdown folder contents
    8. sudo kextload /System/Library/Extensions/AppleUSBEthernetHost.kext and uninstall then install latest iTunes
    9. sudo launchctl stop com.apple.usbmuxd exit iTunes and open it anew.
    10. sudo nvram boot-args=kext-dev-mode=1
    11. Disable system integrality protection
    12. Uninstall my antivirus
    13. Created another admin account in my mac and tried connecting the device.
    14. Searched the net for various solutions.
    15. installed anti malware and scanned mac.


    Hoping someone could give light and lead with this problem.
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Few random thoughts:

    Look at the OS X system console.app when connecting the device.
    In Xcode look at the Devices window. Does the phone appear there? If so look at the console there.
    You might have a hardware problem with no software fix.
     
  3. ionicdev, Apr 22, 2016
    Last edited: Apr 22, 2016

    ionicdev thread starter macrumors newbie

    ionicdev

    Joined:
    Apr 22, 2016
    Location:
    Singapore
    #3
    Thanks PhoneyDeveloper for responding.

    I'll tried your suggestion to look at the console.app and I got his upon connecting my iPhone.

    23/04/2016 12:04:17.497 PM com.apple.usbmuxd[919]: GetConfiguration failed: 0xe00002ed

    any idea?
    My device does not appear in the Xcode's devices window.
     
  4. ionicdev thread starter macrumors newbie

    ionicdev

    Joined:
    Apr 22, 2016
    Location:
    Singapore
    #4
    --- Post Merged, Apr 23, 2016 ---
    Solved the issue by replacing my old usb cable with a newly bought one from Apple store.
     
  5. AxoNeuron macrumors 65816

    AxoNeuron

    Joined:
    Apr 22, 2012
    Location:
    The Left Coast
    #5
    It's funny, I was going to suggest that but then I read over your post and figured you had probably already tried that.
     

Share This Page