Newer version VLC?

Discussion in 'PowerPC Macs' started by MacSoftware3, Mar 14, 2018.

  1. MacSoftware3 macrumors member

    MacSoftware3

    Joined:
    Jun 26, 2017
    #1
    Hi everyone,

    I was wondering if it isn't possible to compile a newer version of VLC (with support for playing YouTube) on an older version of Mac OS X (10.4.11+). If that's possible, how can someone start with doing that? I was wondering this because we also have TenFourFox running on 10.4.11, which is based on a newer version of Firefox.
     
  2. MacSoftware3 thread starter macrumors member

    MacSoftware3

    Joined:
    Jun 26, 2017
    #3
  3. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #4
    Hard to say exactly what VLC would need to be updated for PowerPC and Tiger, but it has been 4 years since the final PowerPC version was released for Leopard, and 9 since the last Tiger version. Safe to bet there was a good reason development ended (could just be demand, but could be more architecture) so it would take someone with greater programming knowledge than I to see how much further VLC could be pushed.
     
  4. MysticCow macrumors 6502a

    Joined:
    May 27, 2013
    #5
    They release their source code, so there is a BIGGER reason why we're stuck with an old version...because that dog won't hunt.
     
  5. wicknix macrumors 6502

    wicknix

    Joined:
    Jun 4, 2017
    Location:
    Wisconsin, USA
    #6
    VLC is in macports, however it hasn't been patched for ppc, or just flat out isn't supported on ppc anymore.

    Matt$ sudo port -v install vlc
    Password:
    Error: VLC cannot be installed for the configured build_arch 'ppc' because it only supports the arch(s) 'x86_64'.
    To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
    Error: Processing of port vlc failed

    Cheers
     

Share This Page

5 March 14, 2018