Onyx and 5770 boot

Discussion in 'Mac Pro' started by Jackdown_101, Mar 6, 2017.

  1. Jackdown_101, Mar 6, 2017
    Last edited: Mar 6, 2017

    Jackdown_101 macrumors newbie

    Joined:
    Feb 28, 2017
    #1
    Hi again people,

    As you may be able to deduce from my recent posts I'm currently playing around a bit with my 2009 4,1 with 5,1 update.

    I have recently installed a flashed XFX 5770 and despite probs with known issues such as pci fan speed and display port output was pleased with how it was working.

    The general computer however was a bit temperamental but not unusable.

    This is probably where I get my noobiness explained to me but I thought that maybe a cleanup would help and ran it through a basic Onyx maintenance run. HD verify, permissions check, general clean up. Having done this I've now lost boot screens on the 5770. The GPU fan spins up really fast on boot and runs fast throughout operation (although perversely the pcie fan now runs at the normal speed). This happens when booting on both the drive that I've run Onyx on AND my other Sierra boot drive that was in the machine at the same time..... So I'm a bit worried about what has been been 'fixed.'

    Couple of other people seem to have mentioned it happening but I've not yet come across a solution.

    I'm running a new installation of Sierra now to see if that helps but any thoughts as to what else it could be? Might it have messed with the 5,1 EFI flash or something?

    Once again thanks for looking and helping out.
     
  2. JedNZ macrumors regular

    JedNZ

    Joined:
    Dec 6, 2015
    Location:
    Deep South
    #2
    I've used OnyX for years and have never had a problem with it messing with things it doesn't/shouldn't have access to. I too flashed my PC 5770, so I probably had a similar setup. Bu can you confirm your system setup (most of us pop this in our signature - helps the community respond more easily) including other PCIe cards and what slots they're in, ram, USB devices attached etc.

    How about reseating the PCIe card? Take your time - and for goodness sake use a static tether, or otherwise earth yourself.

    Egg sucky stuff (ignore if you already know/have done this): So have you reset the SMC? If not, power down, and then unplug the power cable completely. Wait 20 seconds, then plug the power cable back in. Wait another 10 seconds, then power up. Check to see if any problems. If so, reboot and reset the PRAM by holding down Cmd+Opt+P+R (all at the same time) and continue to hold these keys down while your computer boots 3 times. Basically you want to hear the startup chime (Ta DAA!) 3 times, all the while holding down those keys. How does it go now?
     
  3. Jackdown_101, Mar 6, 2017
    Last edited: Mar 6, 2017

    Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #3
    Thanks for the reply.

    I too have been more than happy with Onyx in the past.

    I'd run an SMC reset but not a PRAM one. The XFX 5770 I've got doesn't seem to like them and it leads to the glitchy boot screen that some people have mentioned. A glitchy boot screen is better than none at the moment though so I'll give it a go if necessary once the install has run.

    I have also tried the 5770 in both slot 1 and 2 with the same result. Works fine after the login screen but all of a sudden no boot or access to recovery.

    Replacing the 5770 with the GT120 everything works fine.

    It is the fact that I'm getting the same problems on a drive that in theory I've not run Onyx on that is worrying me at the moment.

    Thanks agian

    Mac pro 4,1 2x 2.26 (flashed to 5,1)
    24GB RAM
    2 x 500GB HDD
    XFX 5770 single slot
    Sierra 10.12.3
     
  4. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #4
    OK the process I have now followed is....

    With GT120 installed,
    I have now reinstalled (not clean) 10.12.3 on my HD from recovery.
    Booted and set up/ updated osx
    Reset PRAM
    Reset SMC
    Booted and shut down

    Removed GT120 from slot 1
    Installed XFX 5770 in slot 1
    Booted with no boot screen.
    Reset SMC
    Reset PRAM
    Still no boot screen on the 5770 that was definitely working before running Onyx.
    Like I said currently when it boots the GPU fan spins up quite fast and remains running fast when not in use. It wasn't doing this when providing boot screens either.

    Anyone have any more thoughts?

    Thanks again guys.
     
  5. JedNZ macrumors regular

    JedNZ

    Joined:
    Dec 6, 2015
    Location:
    Deep South
    #5
    Well you've done everything right by the looks of it then. Thinking cap on some more…

    I have to use a DVI to VGA cable to see boot screens on my 5770. Have you tried the other ports?
    How about installing it in PCI slot 2? Any difference?
     
  6. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #6
    So gave up last night and went to bed. Turned on the computer this morning and have got boot screens. All be it with the garbled line glitch, a couple of flashed to black and an ott graphics card fan that wasn't an issue before running Onyx.

    So it seems better but still a bit broken. Any ideas where I should be looking next?

    Thanks again.
     
  7. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #7
    My understanding is that boot screen has nothing to do with the OS. Even no HDD, the boot screen still there. So, quite possible that it's your GPU create all the problems, especially XFX is a well known brand that not working well with Mac Pro.
     
  8. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #8
    Yeah I found out a bit too late about the XFX issues. Have to say though it was working fine up until last night after Onyx. I do now have access to boot screens and recovery (Having done nothing different so far) so that's good. Just annoying that the fan in the card is now constantly running as fast and loud as it was when under a bit of load a couple of days ago......

    Although the Pcie fan is back down from defaulting to 1100 to running at 800 rpm.

    All fun and games I guess.
     

Share This Page