OS X El Capitan on Unsupported Macs

Discussion in 'OS X El Capitan (10.11)' started by TMRJIJ, Jun 5, 2015.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. muddblood macrumors newbie

    Joined:
    Dec 14, 2014
    #951
    Hello Mac Rumors. I am trying to install El Capitan on a late 2006 MBP (2,2, 2.33GHZ Core 2 Duo) using MacPostFactor. I have a dmg installer for El Capitan that worked flawless on a 2008 MBP (direct upgrade), but MacPostFactor cannot find the dmg installer...it seems it needs a .app installer?
     
  2. jared1201 macrumors newbie

    Joined:
    Aug 2, 2017
    #952
    Hiya people,

    I'm trying to install El Capitan on a Macbook 2,1 using MacOS Extractor. However, i am confused as to what boot.efi file to use. In the folder there is boot.efi and boot32.efi. Which should I use?
     
  3. Frustrated123, Aug 7, 2017
    Last edited: Aug 7, 2017

    Frustrated123 macrumors newbie

    Joined:
    Aug 5, 2017
    #953
    OK, so I replaced the core duo processor in my iMac 4,1 (early 2006) with a core 2 duo, and using a firmware upgrade, the iMac "officially" became an iMac 5,1 (late 2006) capable of taking 4GB ram (though understandably the iMac can utilize only 3GB ram).
    The good news is that using one or the other of the three methods listed in the first post, I was able to run Mountain, Mountain lion, Mavericks and El Capitan (tried them all).
    The bad news (and I have read several posts on the issue with no answers) is that while Lion and Mountain lion would run perfectly with 4GB ram installed; Mavericks, Yosemite or El Capitan would not! Anything above 2GB ram, like 3GB or 4GB will get the iMac either hung at booting or a kernel panic.
    I absolutely and already tried ram from PNY, Kingston, Micron, Samsung and Crucial, so it is definitely not the ram per se!
    Having a love-hate relation with El Capitan running with only 2GB ram.

    Any of you gurus can explain this frustrating mystery? o_O
     
  4. Blixa83 macrumors newbie

    Joined:
    Aug 15, 2017
    #954
    Hello! Sorry, if my question seems stupid, but I haven't found an answer to it here yet.

    I have a macbook 4.1 (white, early 2008)
    It is running on Yosemite, thanks to your soft guys. If I would want to update to El Capitan - can I do so straight ahead, or should I patch it once again first?

    Thank you!
     
  5. 14dcutaneo macrumors newbie

    14dcutaneo

    Joined:
    Aug 28, 2017
    Location:
    USA
    #955
    Hey everyone, I have an iMac late 2006 (5,1) that I'm trying to install El Capitan on. I know there has been a lot of trouble with these units and installing newer software, but nothing seems to be working. Since this mac was not mine initially, it seems that the RAM inside is from a 3rd party. There was also 3GB installed, but have knocked it down to 2 as I'm aware that the iMac 5,1 cannot boot to El Capitan, Yosemite, and Mavericks at more than 2GB of RAM. Could the fact that the RAM in the machine is not from apple cause my bootable USB made from macOS Extractor to just hang at the apple logo? I've tried replacing the boot.efi in the install drive with the boot.efi from macOS Extractor, and even tried boot32.efi. Stuck at the grey apple logo every time. Any suggestions? I've been at this for a long while but to no avail.
     
  6. muddblood macrumors newbie

    Joined:
    Dec 14, 2014
    #956
    Is this thread dead?
     
  7. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #957
    Hi!
    --- Post Merged, Sep 3, 2017 ---
    Yes, MacPostFactor needs the original app installer from the Mac App Store
     
  8. muddblood macrumors newbie

    Joined:
    Dec 14, 2014
    #958
    Shoot. Ok. Thanks.
     
  9. PhillT, Sep 3, 2017
    Last edited: Sep 4, 2017

    PhillT macrumors newbie

    Joined:
    Sep 8, 2009
  10. yeffer46 macrumors newbie

    yeffer46

    Joined:
    Sep 5, 2017
    Location:
    colombia
    #960
    cordial saludo tengo un problema teno un imac de 2006 core 2 duo me dice que puedo actualizar hasta lion pero no meda la oppcion de actualizar por ende quiero correr un yosemite o otro sistema operativo mas actual actualmente tengo snow leopard 10.6.8 y muchas aplicaciones no me corren pero MacPostFactor no corre en snow leopard solo en lion hacia arriba que puedo hacer compañeros ya me urge cambiar de sistema operativo , muchas gracias por cualquier ayuda
     
  11. lisekanter macrumors newbie

    lisekanter

    Joined:
    Oct 2, 2015
    #961
    i Have a trouble.. got error MacBook 4.1

    "Error while getting file ID of /volumes/OS X Base System/boot. Ignoring.

    I do everything, when i choose OS X Base System partition to boot its booting to OS X Lion again..

    I try bless only partion but with no succes.
     
  12. Mathewww macrumors newbie

    Joined:
    Sep 14, 2017
    #962
    I have a MacBook 2,1 late 2006.
    I have succesfully installed El Capitan by following the Method 3 v3 - @skyfly555's method but I have updated the system directly on my external HDD and cannot boot again on it.

    So I have deleted all the HDD and did the same method again.
    This time it does not work at step 9.
    The command "sudo kextcache..." returns the following error message (and a lot more after this one)

    Kernel file /Volumes/Capitann/System/Library/Kernels/kernel does not contain requested arch: i386

    Can you help me please ?
    Best regards
     
  13. Maanghod macrumors newbie

    Joined:
    Sep 14, 2017
    #963
    Hello OS X Hackers! First of all, I want to tell you that I very much respect your work, passion and dedication. You truly bring old macs to life! I want to ask you a question though: I have a Macbook 3,1 (Late 2007) on El Capitan. Built-in Output, Microphone and Line-In work great. My problem is that I have a USB Audio Interface that worked just fine under Yosemite, but it doesn't get recognized in System Preferences. If I do the ioreg usb command in Terminal, it's there. I can even change settings on it through the special program that comes with it.
    Bottom line: It shows up as a USB Device, but not as an audio device... I know that you probably did not engineer the kexts with usb audio functionality in mind, but could you please suggest an idea? It would mean a lot to me... Thank you!
    --- Post Merged, Sep 14, 2017 ---
    So I checked EC-Base Kexts from your files and APPLEUSBAUDIO is not included... That must be the problem. You guys are great anyway, thanks a lot. El Capitan runs flawlessly and the new graphics kexts are great... Do you think something can be done about the usbaudio kext? :)
     
  14. Maanghod macrumors newbie

    Joined:
    Sep 14, 2017
    #964
    Hey guys! Thank you for whatever help you may have been preparing to give me, but I solved it myself - installed appleusbaudio from Yosemite!
     
  15. IIcx macrumors newbie

    IIcx

    Joined:
    Jan 29, 2017
    #965
    Just picked up a 2.16ghz black 2.2 macbook with 3gb RAM and for the life of me can't get this to work.
    MacPostFactor results in an unbootable drive that no longer shows up under bootable disks after an "Option" boot, and macOS Extractor makes a USB drive or 2nd partition that only boots to the Apple logo and then hangs there. Have tried both the normal and 32bit boot efi's and with/without the optional video support with no luck on ether, and after 9 reinstalls of Lion I'm starting to get frustrated.

    Can anyone confirm what steps/options they did to get 10.11 on a 2.2? Also if possible what versions of Macpostfactor or Macos_extractor were used? Bout ready just to install Windows and call it a day.
     
  16. mattschwantes, Sep 16, 2017
    Last edited: Sep 16, 2017

    mattschwantes macrumors newbie

    Joined:
    Dec 27, 2016
    #966
    @Mathewww I'm not really active with this anymore, but when I did this multiple times before it is successful about 50% only. The step that seems to cause the problems is copying the kexts, it always looks like it works but doesn't actually copy them over sometimes.

    It seems to only work reliably if you delete the existing kext ("rm -R kext.old") and then copy ("cp -R kext.new"). I do this one kext at a time so it requires a lot of careful typing. After that the kextcache bits should work. No guarantees though. My machine is also MacBook 2,1. Good luck!
     
  17. mattschwantes macrumors newbie

    Joined:
    Dec 27, 2016
    #967
    @IIcx on MacBook 2,1 only method 3 seemed to work for me. It appears 2,2 is the same.
     
  18. IIcx macrumors newbie

    IIcx

    Joined:
    Jan 29, 2017
    #968
    Thank you mattschwantes. I'll see if I can dig up a spare drive for my for my old pro tower and give it a go.
     
  19. saimadma macrumors newbie

    saimadma

    Joined:
    Sep 18, 2017
    #969
    Hi,
    I wanna ask you if this can be done on MBP2,2?
    Actually, I have tried but it didn't succeed.
    I did everything follow from post #1 and the one I quoted.
    I'm stuck with prelinking kernel command.
    I always get a message "xxxxx.kext has incorrect permissions; omitting." and kernel file is not created.
    Gonna say that EVERY kexts are saying this and I'm sure that my hackintosh is indeed SIP disabled.
    I thought because I'm running Sierra so, I install El Capitan. Finally, just got the same thing.
    I tried both El Capitan with 10.11 and 10.11.6(Official App Store one). Nothing is different.
    Moreover, I got an El Capitan clone in dmg from online (10.11) and I tried with modded boot.efi and install your kexts.
    It worked and finally booted up! but it worked for a few minutes on Desktop just and restart.
    I haven't tried your boot-vs-67.efi because while I'm writing this, I decided to go back to Yosemite.
    MacPostFactor gave me an error 1 with El Capitan too.
    I'm so frustrated right now.
    Any workaround?

    Or anyone with MBP2,x with El Capitan works, pls tell me. I have been trying to install El Capitan for almost a week now.
     
  20. mattschwantes, Sep 20, 2017
    Last edited: Sep 20, 2017

    mattschwantes macrumors newbie

    Joined:
    Dec 27, 2016
    #970
    When you say it worked for a few minutes and then restarted, you mean you got a kernel panic/crash right? Using wrong boot.efi is likely cause of this. The one done by pikeralpha for Yosemite does boot ElCapitan, but then it crashes shortly thereafter on the desktop.

    I don't have a Pro and neither many people here since this thread is primarily intended for non-Pro systems, so this advice is admittedly uninformed. Maybe try using one of @skyfly555 boot.efi from method3? Just an educated guess though.

    Also please see my comment in post #966 about overwriting/copying kext. You need to be sure you actually replace the old ones. Sometimes it fails to overwrite depending how you try to do it.
     
  21. Mathewww macrumors newbie

    Joined:
    Sep 14, 2017
    #971
    So I will try again.
    Regarding kexts, there is an AppleHDA.kext in EC-Base-kexts directory and one in EC-GMA950-kexts directory. Which one should I copy ? Both ? Is there a particular order to do so ?
    Thank you.
    --- Post Merged, Sep 20, 2017 ---
    I have noticed that the command "chown -R root:wheel" does nothing. To actually change file owner I have untick the option "Ignore ownership on this volume" (Right click on volume > Read info > Option below permissions)
     
  22. mattschwantes macrumors newbie

    Joined:
    Dec 27, 2016
    #972
    Depending on your actual configuration, some of the commands may not succeed. You have to verify every step along the way. Thanks for your suggested solution.

    Regarding AppleHDA.kext they are just duplicates. Check the files and they are same. I asked this exact same question in post #944. @skyfly555 answered it in post #946.
     
  23. EugW macrumors 68000

    EugW

    Joined:
    Jun 18, 2017
    #973
    I searched this thread for "MacBook4" but it would seem all of the posts are just of failures or partial failures.

    I didn't scour every single post individually. Has anyone been able to get an problem-free install of El Capitan on MacBook4,1?

    In the meantime, I've retired the MacBook4,1. I've replaced it with a MacBook5,1 and installed Higher Sierra on it (which is super easy BTW), but it'd be nice to be able to get El Capitan on the MacBook4,1 too.
     
  24. zappaesque, Sep 21, 2017
    Last edited: Sep 25, 2017

    zappaesque macrumors member

    zappaesque

    Joined:
    Jun 10, 2017
    #974
    I got it to work on my 4,1. I used my 2009 Macbook Pro to install El Cap onto the drive, then hooked it up to my Mac Pro (which is a 2,1 running El Cap unsupported) to do all of the command line fu and file moving. I initially had trouble with getting it to boot from refind, but I downloaded the refind usb image, installed it to usb and booted from it, removed SIP, booted my el cap install, and found firmware.scap in the standalone/i386 directory and the APPLE directory had returned in the EFI partition. I deleted these, reblessed the refind x64 efi, rebuilt the kext cache, and everything works. Now I just need to figure out why my graphics memory only reports 6mb, but that's a kext issue I'm sure I can fix after I get some sleep...

    EDIT: Doh! I installed the x1300 kexts by mistake. Installing the x3100 kexts, changing their permissions to root:wheel, and rebuilding the kext cache fixed the video problem.

    As far as how it runs... pretty darn good. Some choppiness, but it's reasonable. DVD Player and Maps don't work, but there are other apps (VLC, Google Maps, Movist) that can take their place. 720p videos play fine on YouTube; 720p60 videos are choppy. Grid stack view is really slow, so I changed it to List view instead. Launchpad is decent and not too slow; just a bit choppy. No transparency anywhere. cDock2 can be used to theme the dock to not be blasting white. And of course, brightness controls and wake from sleep don't work. Shady can be used for brightness controlling, and NoSleep can be used to keep the Macbook from sleeping, but you'll have to shut it down if you want to be mobile. Overall, it runs better than Yosemite did on this Macbook.

    Now, to get it to work on my 3,1...

    EDIT: With a quick disk clone and some editing to boot 32-bit EFI and GMA950 kexts, it's now also running on my 2,1 Blackbook (see photo)...

    EDIT #3: ... and now on my 3,1. That's all of them!
     

    Attached Files:

  25. Mathewww macrumors newbie

    Joined:
    Sep 14, 2017
    #975
    Finally it is working on a Macmini2,1 (Intel Core2Duo 1,83 Ghz / 2Go RAM / GMA950)
    I will also try on my MacBook 2,1, there is no reason (same proc, same graphic card, better freq (2Ghz), more RAM, SSHD)
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page