Prohibitory sign on iBook G4

Discussion in 'PowerPC Macs' started by DarkerJ, Jan 19, 2016.

  1. DarkerJ macrumors newbie

    Joined:
    Jan 3, 2016
    #1
    Starting a new thread because I didn't want to double post on an old thread. So here's what I'm trying to do: Install OS X 10.4 or 10.5 on an SSD in my iBook G4, with a broken DVD drive. What I have: A PC with TransMac, Images for 10.5 and 10.4.3, a FireWire 400 cable, an iBook G3/500 with 10.2.8 and 9.2.2, a DVD with 10.4.3 on it, a USB made with a Mac with the 10.5 image on it, is bootable, the old hard drive from the iBook with Tiger still on it. What I can't do: 1. Copy the Leopard image to a section of the G3s drive, 10.2's disk utility wont copy disks or images, nor will Disk Copy 2. Target the DVD of the G3, spits DVD out 90% of time, 3. Boot to USB on G4, both 10.4 and 10.5 give a prohibitory sign. What I can do: 1. Sacrifice OS 9, not much is used on its partition, and if there is a way to get around #1 of what I cant do that doesnt involve upgrading (because I cant get it to use my Tiger DVD), let me know. SuperDuper wont copy system files, so no go there. 2. Make a Linux stick, if that will help anything 3. Parition the SSD with APM, already been done. One more question: Can I just use root and Finder to copy everything from my Leopard stick to an 8GB partition on the G4's SSD? I swear no matter what I try with this thing, something always throws a wrench in my plans...
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Errr ... not sure how helpful this will be, but way back when I had a world of problems trying to install Tiger on a 1.67GHz PowerBook G4 ... basically I mounted the Tiger installation to an external USB drive and had to do a number of things to boot from that, it was a real pain as the PPCs don't offer USB boot like the Intel ones.

    My written instructions that I noted down at work are below, but I'm not sure how helpful this is; you may need to have a heavy slice of intuition and luck. I kinda wish I took screenshots :(

    I'd recommend doing the below on an Intel Mac (SL or higher) if you have one. I'm also going on the assumption that you have a Tiger install that isn't on a DVD -- if not, let me know and I'll source one for you.

    1) Format pendrive/external HDD to be PowerPC Compatible in Disk Utility
    2) Mount the Tiger OS installation to the pendrive (using the ‘restore’ function)
    3) On the PPC Mac, plug in the pendrive, then hold down Cmd+Alt+F+O on startup to get into the open firmware.
    4) Type ‘devalias’, and look for anything that says ‘ud’. This would be the external drive you're trying to boot from.
    5) Type ‘devalias ud /exactly_what_it’s_called’ (make ud equal to what’s in the devalias). It usually looks like pciblahblahblah.
    6) Verify the disk (dir :ud3,\). If that doesn’t work, try ud2 or ud1. This’ll make sure that all the files are as they should be.
    7) Find the CoreServices folder (dir ud:<number>,\System\Library\CoreServices)
    8) Then boot from it (boot ud:<number>,\System\Library\CoreServices\BootX)

    Just to add to the above, that was on an install for Tiger (OS X 10.4), so I'm not sure if Leopard has the \System\Library\CoreServices file for the install.

    Please can you take photographs of any problems you run into, quote my reply, and I'll try to see if the cogs in hazy memory will clock back into life so I can be a little more helpful :)

    Speak with you soon!
     
  3. DarkerJ thread starter macrumors newbie

    Joined:
    Jan 3, 2016
    #3
    When I've tried booting from USB, thia happens, both Tiger and Leopard do this: [​IMG] (in verbose mode) I have to type boot /pci@f2000000/usb@1b/disk@1:\\:tbxi , same when I point directly to BootX, though I've never tried devalias. I have to have tbxi at the end, otherwise it complains about LOAD SIZE too small. And I did use an intel mac to make the stick, but its the leopard install dvd on th of my SSD and go from there. Tell me, is it possible to just copy every single file manually using Finder on jaguar, logged in as root and with AppleShowAllFiles being true, or is there something more I need to do to make it bootable? Somehow i got Jaguar to boot on my G4 via target disk, which had issues with the display but booted nonetheless. Also, the G3 was able to attempt to boot from stick (I got a spinning Apple logo and everything)
     
  4. iModFrenzy macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #4
    I don't get why G4s disagree with USB booting. My G3 boots up through USB perfectly fine.
     
  5. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #5
    /pci@f2000000/usb@1b/disk@1:,\system\library\coreservices\bootx try this assuming your USB stick is in the same port as that screen shot... (IIRC its what i did when i got your issue booting my iBook G4 from usb)
     
  6. Markus23, Feb 2, 2016
    Last edited: Feb 2, 2016

    Markus23 macrumors newbie

    Joined:
    Feb 2, 2016
    #6
    Hi, I think I might know what your issue is. This just happened to me yesterday when trying to boot an iBook G4 off USB with a Leopard install image.

    For some reason OpenFirmware doesn't look past the first 2 partitions on the USB stick. As you can see from the screenshot, it tries booting from partition 0, then partition 1 and then partition 2. However you most likely need to tell it to boot from partition 3.

    Due to the way the old Apple partition map format works, even if you create only a single partition on a USB stick it will be numbered as partition 3 (at least that's how it is in my case). Check your USB stick using the "diskutil list" command on a working Mac to be sure.

    I don't recall the exact syntax to specify the partition but try something like this (note the extra :3 after the device ID, this is the partition number):

    boot /pci@f2000000/usb@1b/disk@1:3,\\:tbxi

    Also just for fun, at least on my iBook G4, "usb0" is a shortcut for "/pci@f2000000/usb@1b", which can save some typing. Type devalias at the OpenFirmware prompt to see if you also have that alias defined. In my case I can boot from USB using something like "boot usb0/disk@1:3,\\:tbxi".

    --- Post Merged, Feb 2, 2016 ---
    By the way, I recommend finding the "PowerPC ONLY" version of 10.5.8 in a certain grey corner of the internet. It's been prestripped to remove all Intel code and is the best performance you're going to get on an iBook G4.

    However it's a disk image itself, not an installer. So what I ended up doing was booting a regular Leopard install image off USB, then inserting my 2nd USB stick with the above PowerPC only disk image on it, and using disk utility to restore the image to the iBook's harddrive. Alternatively, you can run tools to strip the Intel code from 10.5.8 yourself after a regular installation.
     

Share This Page