Second Annual Winter PowerPC Challenge! January 1-8, 2018

Discussion in 'PowerPC Macs' started by Gamer9430, Oct 18, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #176
    And there is the conundrum. ;)
     
  2. amagichnich macrumors 6502

    amagichnich

    Joined:
    Feb 3, 2017
    Location:
    Stuttgart, Germany
    #177
    I should have taken my name off the list - I couldn't use PPCs this week because I needed my Windows tower. If only Leopard had powershell and ms remote desktop. And 8 cores :D I have to script and virtualize in parallel very much. Hadn't have much free time thsi week...

    But today I kinda started and with interesting results :D

    Day 1 (or 6)

    Put away all x86 machines and the eMac back on the table. Connected the loose cable ends with a 12->7V cable to have the fan running slow.

    Downloaded the newest episode of the Lunduke Show and watched it. Ca. 90 minutes later I see something shocking! Poor eMacs HDD temp is at 79°C (174.2°F)!! As it has no other sensor I can only guess what the CPU had at that time... 10 more at least.... What's the highest temp a G4 can survive? I always thought 90 upwards is deadly? However I didn't seem to get worse, so can proudly say I've passive cooled an eMac while watching a video and browsing with TFF FPR5b!
    My problem was the adapter; maybe it’s a faulty one because the fan wasn’t running at all now but when I started it definitely ran.

    Now an eMac is a very durable as maybe everyone here knows. Mine for example was stored for some years in a (humid) garage by the previous owner and I had to store it in a garage for 2 months too. Before today it was another 2 months in box in my cellar.

    And today approx. 90°C… Then I discovered something: I always thought my eMac is loud. Naive. When I plugged the fan in again without the volt regulator first everything was okay again, but after 30 seconds or so the fan got louder and louder ‘till I thought the eMac might get up in the air and fly away :D that was when I realized how loud an unregulated eMac fan really can be. It seems that despite being annoyingly loud the fan usually is regulated down to maybe 9 or 10V. And that may be the answer why my fan stopped – the bridge takes out 5V. The eMac starts fine with the fan running and then reduces the voltage to say 9V. 9 minus 5 equals 4 and 4V aren’t enough to spin that old not lubricated fan I think.

    Pic1: I rearranged the pins internally so I could use standard cables. I redirected them out so I could easily fiddle around with them
    emac fan.jpg

    After these events I decided to stick to the iBook G4 12” 1.33 for today as it is the coolest running machine I own and still the second fastest right behind the PB.

    What else happened? I finally adjusted many things to better fit the 12” screen. There is too much space wasted by default:
    wastespace.png

    Better:
    better.png

    Excel and Dock default; nearly no usable space on a 12" screen if you want the Dock visible and need the toolbox often:
    excel.png

    Optimized a bit:
    word.png
    I set the Dock to smallest size and modified the toolbar. The most important shortcuts are now there, only for formatting I need the menubar and never have to open the toolbox again. If I could remove the ribbon bar above the ruler and shrink the bottom status bar I'd be happy :D
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
  4. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #179
    You can also try rdesktop and TsclientX to do MS RDP.

    https://forums.macrumors.com/threads/tsclientx-2-0-beta-released.2003482/#post-25285143

    In theory you could run a x86_64 bit Linux VM using qemu on your PPC and then install the Linux All-in-one AppImage

    https://github.com/PowerShell/PowerShell

    https://blogs.msdn.microsoft.com/powershell/2016/08/18/powershell-on-linux-and-open-source-2/

    I've been installing a qemu Linux 64 bit the entire morning, no luck yet but out of curiousity I want to know wether PowerShell would run :)
     
  5. Lastic, Jan 7, 2018
    Last edited: Jan 7, 2018

    Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #180
    Day 6 afternoon

    I continued on the G5 and tried to play some games I've found on the web since I have an Xbox controller hooked to it,
    Geforce 6600 and an Apple 30" Cinema Display at 2560 x 1600.

    Braid works flawless in 2560x1600 with the Xbox Controller, I really love this game

    Black & White plays OK but 800 x 600 resolution

    Colin McRae Rally Mac Demo crash when selecting Xbox controller or 2560 x 1600, works with keyboard at 1900 x 1600

    DeltaForce BlackHawk Down 1280 x 1024 in cornered window isn't the resolution I wanted

    Oni works perfect 2560 x 1600

    Halo Combat Evolved works 2560x1600 and Xbox controller

    Marathon Infinity 2560 x 1600 works but Xbox controls are a bit weird

    Quake 4 only runs at 1600 x 1200 and no Xbox controller detected

    Cube 2 Sauerbraten crashes once the game starts

    Prey no CD , bought it now at Amazon.de for 2,99 EUR

    Total Immersion Racing no CD , bought it now at Amazon.de for 0,16 EUR :)

    True Crime doesn't start after the install

    Tony Hawk's Pro Skater 4 doesn't start the very long install

    Tremulous works but you have to play online

    I watched Son of Zorn at watchcartoononline.com in LWK and an episode of Marvel Agents of SHIELD in Coreplayer

    I was a bit disappointed of gaming on the G5 but maybe I missed a really nice game, I prefer side-scrollers or platform games, mostly I expected more of the 2560x1600 resolution I have at my disposal.

    Day 7

    Trying to install a 64 bit Linux VM but so far it crashes after partitioning or installing packages .

    Played around a bit with RetroArch, got it working but it freezes if I have it scanning an entire ROM collection ?

    I do have to say that so far the 14" iBook has been a pleasant suprise to me.
     
  6. amagichnich macrumors 6502

    amagichnich

    Joined:
    Feb 3, 2017
    Location:
    Stuttgart, Germany
    #181
    First, thanks! But there's a big but: I can't find an option for setting a remote desktop gateway and without that I can't log on to the server farm :(

    Haha, great solution :D can't use it though as I have only single processor G4s and need usually 3 linux x86_64 VMs running in parallel, often 2 as a cluster.
    I need Powershell, RemoteDesktop (with RDG) and HyperV running in parallel, so for my work I have to use a windows machine with 2 24" screens. Maybe with a mighty G5 Quad I could do that, but my G4s are all out :(

    But now is weekend and I can use them and only them ;)
    What I did today: Watching Lunduke rant while coding a bit C++ to explore Xcode. Usually I use Kdevelop for C and C++, Eclipse for Java and Powershell for, well, Powershell scripts :D

    Watched 'King Arthur: Legend of the sword' on DVD yesterday evening... Quality sucks! I'm sure DVDs where way better some years ago. it felt like it was a 360p YT video! Sound was okay, but the picture was a mess
     
  7. macgeek18 macrumors 68000

    macgeek18

    Joined:
    Sep 8, 2009
    Location:
    Northern California
    #182
    I sadly did not use my PPC Macs this week. I spent most of the week on the go and my PB could not keep up with my battery life and power needs. I spent the week on my Note 8 and Thinkpad X220.
     
  8. mmphosis macrumors member

    mmphosis

    Joined:
    Jan 3, 2017
    #183
  9. AphoticD macrumors 6502a

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Queensland, Australia
    #184
    That looks like it is the 3rd edition of the same book. The one updated for 10.5 & 10.6.

    Journal update:

    Day 6 - Took the wife and kids on a little holiday to Bris-Vegas (Brisbane) for the weekend and brought along my PB G4 12” to do some work from the hotel. I didn’t try connecting to WiFi, but was able to get some Leopard Xcode work done later in the night once things were quiet. I made some improvements to my custom (Tiger compatible) animation framework.

    Day 7 - Sunday. Relaxed and took the kids to a robotics event called code-a-bot held at QUT (Qld University of Tech). The kids had fun playing with the virtual bots on the big screen and designing their own little recycle bots. Played with the Sphero SPRK+ and some good fun tinkering with magnets, electronics and makeymakeys.
    --- Post Merged, Jan 7, 2018 ---
    How did you shrink the TFF toolbar?

    Also, those eMac HDD temps are alarming. I would shut it down if I saw HDD temps going over 60C. Most of my HDDs (G5s and G4s) operate around 35-45C and that is in the Aussie summer.

    I would consider putting new thermal paste/pads on the eMac’s CPU and GPU, clearing out any dust and finding a way to cool off that HDD before it fails.
     
  10. eyeleica macrumors newbie

    eyeleica

    Joined:
    Nov 15, 2016
    Location:
    Las Vegas, Nevada
    #185
    I ended the WinterPPC Challenge like it started, on my G5. It is the computer of most use anytime, so Challenge or not, it is usually used. During the week I used my G4 15" powerbook and Pismo. The Pismo has gotten slower using the internet, but I was able to write several emails on it to my senior US Senator. I spent a day in the OS 9 environment on the Pismo.I love the simplicity and elegance of OS9. The G4 Powerbook has no battery, but I still take it on the road hoping an electrical plug will be available when needed. It was used at home one day during the week.
    Like some other people, using a smart phone or iPhone has become most used than a desktop or laptop computer. I'm sorry I am in that crowd. But I still love using a keyboard and mouse, especially the old clicky keyboards like the Extended Apple Keyboard and the IBM's.
    Thanks for the opportunity to participate in the Challenge and start 2018 on the right step.
     
  11. amagichnich macrumors 6502

    amagichnich

    Joined:
    Feb 3, 2017
    Location:
    Stuttgart, Germany
    #186
    For the toolbar I used an addon called 'More or less window padding' but it is far from optimal. Keeps resetting and mixes up the colours. I think the answer is in the source code or in one the many settings in about:config. Couldn't find it there though.

    As said I didn't watch the temps but a video, sometimes in full screen ;) With the fan running the HDD gets up to 50°C usually, but the problem was that the fan stopped running. Interesting was that even with these high temps everything worked as smooth as it should.
    A plan is to add two small 40mm fans on the heatsink that blow with constant 12V to improve cooling and noise, but I haven't found a way to cool the other components properly that way so I'm keeping the big loud fan for now.
    A repaste of the CPU is already done ;) the GPU is cooled passively I think.

    As I usually use Leopard only I tried yesterday and today to use Tiger all day and it's amazing how much faster a PPC is with it. Only problem is that I can't get purge to run, even when I install the complete Xcode suite. Is there something I'm missing? Do I have to link something manually?
    I know what inactive memory is designed for, but when I quit an app I don't want to use it again soon and reassigning inactive memory seems to be buggy on machines without much memory. The eMac with 1GB RAM swaps out 300MB upwards with 400MB beeing inactive
     
  12. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #187
    Day 8 A Retrospective

    I mostly used the following 2 machines during this challenge :

    Powermac 11.2. Dual G5 Processor @2.3GHz. Late 2005 , 12 GB RAM , SATA SSD

    iBook G4 14" 1.42 Ghz 1,5 GB RAM , mSATA SSD

    I did try to use this one as my train commute companion

    iBook G4 12" 1.07GHz 1,25 GB RAM , mSATA SSD , Newertech Battery

    but it was no match for Coreplayer, let alone running Qemu VM's on it like my Powerbook G4 12" 1.5 GHz .

    As such the bulky 14" iBook has been my train companion and couch laptop and I must say that I'm impressed
    by it's keyboard, the downsides are that my Newertech Battery didn't arrive during the challenge and that I can't hook
    it up to any of my Cinema Displays since they use DVI.
    Performance wise it has hold it's own during this challenge.

    I've used TFF-FP5b 99% of the time during this Challenge and it has improved, sitting in the background it eats up
    less CPU even with a lot of tabs opened.

    Before I would default to LWK but unless I need Flash or Java or direct Youtube playback , TFF will now be my main
    browser.

    Off course LWK, SMTube , Coreplayer only made this Challenge possible for me personally, without them I would feel
    pretty restricted.

    The G5 which was an upgrade from a DP 2.0 Ghz G5 hooked to an 30" Apple Cinema Display has proven it's value.
    I was a bit disappointed by the gaming options not taking advantage of the 2560x1600 resolution but when this machine came out a lot games were FPS or based on the same engines.
    Loving the more particular games like Braid or other indie games , I do hope that there would be a retro-development for
    G5's pushing the limits of these Power horses.

    I lacked personal motivation to start learning C/Objective-C but will pick it up.
    Didn't really do anything usefull with the Xserve G4 and RAID yet neither.

    Survivors of this challenge :

    Powerbook G4 12" 1.5 Ghz + 21" Cinema Display

    Powermac 11.2. Dual G5 Processor @2.3GHz. Late 2005 , 12 GB RAM , SATA SSD + 30" Cinema Display

    iBook G4 14" 1.42 Ghz 1,5 GB RAM , mSATA SSD

    Xserve G4 + Xserver RAID

    Will be sold :

    Powermac G5 DP 2.0 Ghz with an 21" Cinema Display

    iBook G4 12" 1.07GHz 1,25 GB RAM , mSATA SSD (might put the HDD back in and put the SSD in the PB G4) , Newertech Battery (waiting on keyboard to arrive)


    Powerbook G4 12" 1 Ghz and the original box

    Let me finish with the 27" Thunderbolt Display VS 30" Cinema Display both playing StarTrek Discovery

    IMG_3431.JPG

    IMG_3433.JPG
     
  13. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    ten-zero-eleven-zero-zero by zero-two
    #189
    I use the Stylish addon with a few styles…

    Add-ons Manager (Build 20151029151421).png
     
  14. skinniezinho macrumors 65816

    Joined:
    Jan 1, 2009
    Location:
    Portugal
    #190
    In the last day of the contest I've tried to connect my iphone SE (running 11.2.5) to my Powerbook, and surprisingly nothing happen.
    I though that like in windows it would let me import my photos, but nothing. Is this normal, any workaround?
     
  15. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #191
    Day 9 , at last the keyboard for the 12" iBook G4 arrived and it fits, no more bulging cable underneath the spacebar.

    iBook keyboards Portrait.JPG
    iBook keyboards Sideview.JPG


    So tomorrow the iBook G4 12" goes back with me on the train commute for a real test-ride .

    The Newertech battery for the 14" iBook G4 went on a plane from Chicago US on the 20th of December only now to
    have arrived at my Capital's airport, US -> Europe takes 20 days to fly the distance apparantly :)
    --- Post Merged, Jan 9, 2018 ---
    Day 8

    I decided to install Debian 9 netinstall minimal (textmode)+ssh via qemu-system-x86_64 on my MBpr to speed things
    up, well after 2 hours :) and installing fuse and sudo and wget to retrieve the All-in-one PowerShell image , it's working

    Day 9 MBp Qemu Debian Powershell.png
    I tried on the G5 also with the same parameters -m 512M -net nic -net user but it keeps crashing once it gets to the login
    start process , also on the G4's.

    Day 9 G5 no Debian.png
    I have uploaded the qemu image if anyone with qemu on PPC Linux or OS X Leopard wants to give it a try, I wonder
    if qemu 2.9.0 on PPC Linux would be able to start it ?

    Here is Debian 9 minimal text console install ,SSH server with root (toor) and 1 account user (user) , fuse and sudo installed, PowerShell is in the home directory :

    2 GB Qemu diskimage !!!

    https://www.dropbox.com/s/xb11zfnvyozh28s/debian9_x86-64.tar.gz?dl=0
     
  16. thefriendshipmachine macrumors regular

    Joined:
    Apr 14, 2017
    #192
    holy cow, so I can use this disk image on my powerbook g4 to run x86 debian on qemu? I wonder if I could run docker and nodejs inside of it.
     
  17. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #193
    In theory yes but

    • on my PPC's OS X 10.5 Macports qemu-system-x86-64 2.2.0 crashes once it has to start the logon console so doesn't work

    • depending on the processor and memory you can assign to it , it will be dog slow or reasonable to work with
     
  18. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #194
    I love the blog. Since SMB is the default for the newer macOS versions, and most recent versions support it you could theoretically just rock SMB and never touch AFP.

    Bleh... What an excuse... That's what iCloud backups are for :D
     
  19. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #195
    Day 10

    This morning @Dronecatcher notified me via his post that SMTube had updated to version 18.1 because of Youtube changes.

    SMTube 18.1 YEAH.png

    I compiled SMTube on my iBook G4 this morning during the train commute and had a functioning App ... or not

    SMTube 18.1 Coreplayer RIP.png
    What Coreplayer no longer works as a playback option ???

    Unfortunately it seems that Youtube now parses a HTTPS feed which Coreplayer doesn't understand

    10/01/18 13:11:15 [0x0-0x13013].com.yourcompany.smtube[196] BrowserWindow::eek:penYTUrl: command:

    "/Applications/CorePlayer.app/Contents/MacOS/CorePlayer "https://r2---sn-cxab5jvh-cg0ee.googlevideo.com/videoplayback?ratebypass=yes&expire=1515607874&sparams=clen,dur,ei,gir,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,pcm2cms,pl,ratebypass,requiressl,source,expire&ipbits=0&lmt=1505717347586771&ip=37.62.219.12&key=yt6&pcm2cms=yes&mv=m&source=youtube&ms=au&mn=sn-cxab5jvh-cg0ee&mm=31&id=o-AEsPCGvEaz0WA--K-ZDQR0hBMMuzw6KeuGS2KS_GGxLg&dur=596.009&clen=34740004&gir=yes&pl=17&ei=4gJWWqXaCsqC8gO18JawAQ&beids=[9466594]&signature=6D633673B8339B41BFD878AA2A350E80DC76461A.D85C5B6AAFF7904318E360ED009529B9A528B62C&mime=video/mp4&initcwndbps=1103750&mt=1515586152&itag=18&quality=medium&requiressl=yes""

    Ok, let's try SMTube 18.1 and mplayer

    SMTube 18.1 mplayer OK.png
    OK, that still works , maybe SMTube 17.5 still works with Coreplayer

    SMTube 17.x Game Over.png

    SMTube 17.5 or lower no longer works entirely :(

    Got home in the early afternoon since I had only 1/2 day of work , found my games from amazon.de in my letterbox.

    Day 10 Prey for TIR.JPG

    Prey now works in 1920x1200 but seems to lack Joystick support.

    Total Immersion Racing acts really strange , on my G5 the installer hangs.
    I tried on my PB G4 and the installer started but after a very long waiting period, tried to use my PB DVD via Firewire Target mode to my G5.
    The installer completed on the G5 with the PB's DVD, tried to run the game but it crashes immediately on the G5.

    I will give it another try on the PB G4 but I wanted to use the G5 for it's 30" Display and horsepower.

    A big boo to Youtube , still going to look if there is a way to get the feed to Coreplayer in a way that Coreplayer understands .
     
  20. Dronecatcher macrumors 68020

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #196
    Isn't that your own compiled Mplayer?

    For me neither Mplayer, VLC, Quicktime nor Coreplayer work now.
     
  21. bobesch macrumors 6502a

    bobesch

    Joined:
    Oct 21, 2015
    Location:
    Kiel, Germany
    #197
    Unfortunately MS RDP-Client for PPC/Leopard has not been updated to deal with that server-client-certificate-stuff for WinServer2008 and above.
    The only way to connect to a WinServer is via VirtualPC+WinXP-SP2/3 (or WinXP-SP2Fundamentals) or Win7 and RDP-Client6 or above.
    With a G4-Book VPC7/WinXPFundamentals or MicroXP is the best choice for my purposes...
    There are CiscoIPSec-VPN-solutions for that virtual environment too since Leopard/PPC lacks of support for the Cisco IPSec-protocol.
     
  22. Lastic, Jan 10, 2018
    Last edited: Jan 10, 2018

    Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #198
    Correct, I use mplayer 1.3.0 from Macports , I could have sworn that I tried VLC this morning but you are right VLC no longer works.

    mplayer 1.3.0 still does , PB G4 12" Better Performance on battery, 360p playback

    Picture 4.png
    I remember that I once created a mpkg for mplayer 1.3.0 on the G5 but it didn't work on your DLSD.
    So I'm now creating the Macports mpkg installer for mplayer 1.3.0 again on my PB G4.
    Normally you should be able to install it without Macports,Xcode on OS X 10.5 on a G4.

    --- Post Merged, Jan 10, 2018 ---
    Looks like FreeRDP is the only open-source RDP client that supports RD Gateways

    https://ifconfig.dk/freerdp/

    but I just tried compiling it from source on the PB G4 and it fails , sigh, Oh Debian Why Have Thy Forgotten Us ,
    Macports has it but not in the older version that I run on OS X 10.5

    Correction it exists in Macports 2.3.4 , now installing it sudo port install freerdp, will create an mpkg also for those without Xcode and Macports.

    --- Post Merged, Jan 10, 2018 ---
    @Dronecatcher Here is mplayer 1.3.0 mpkg (no Xcode/Macports needed) created on my PB G4 OS X 10.5

    https://www.dropbox.com/s/pyowzy1fehk4l1i/MPlayer-1.3.0_2.mpkg.zip?dl=0
     
  23. Dronecatcher, Jan 10, 2018
    Last edited: Jan 10, 2018

    Dronecatcher macrumors 68020

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #199
    Thanks...sadly doesn't work on my DLSD - I click in SMTube and nothing happens. When I try it in Terminal to play a local clip it says "Illegal Instruction" - I think that's exactly what happened before and I when I tried compiling MPlayer it failed to complete.
     
  24. Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #200
    Indeed it's the same error as when I had provided you mplayer mpkg build on my G5 , I thought the issue was G5 vs G4 but looks like creating the mpkg on a G4 didn't help.

    Are you compiling mplayer from source or installing it via Macports ? Maybe I can guide you through the install/compile process.

    Since I use the same base image on all my *books , they already have mplayer 1.3.0 from Macports installed and it's dependencies ( which might be installed for other ports ) so it's difficult for me to install mplayer from scratch using Macports. Usually I keep a text file around how I had to correct a broken port install , will check that this evening.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page