Unable to create partitioned drive and install windows.

Discussion in 'iMac' started by KG101, Dec 29, 2015.

  1. KG101 macrumors newbie

    KG101

    Joined:
    Dec 29, 2015
    Location:
    T'ville
    #1
    Hi, I have been trying for some time to install windows on my late 2013 Imac Yosemite 10.10.5.

    I originally used bootcamp but when selecting a drive to install windows on I was unable to with the following error message.

    "Windows could not be installed to this disk, the selected disk has an MBR Partition table, on EFI systems windows can only be installed to GPT disks.

    I did some looking around found a few people with the same issue and so I attempted to partition the drive using Disk Utility, had the issue that it didn't format to NTFS but I found a way around that eventually and have come full circle to the same message i recieved using bootcamp, that the drive needs to be GPT.

    More looking around and I have read that when partitioning the drive in Disk Utility I need to make sure the GUID option is selected and this is where i am currently stuck as the options icon and the partitioning layout options are currently greyed out.

    I am selecting the top level drive in Disk utility and i can select the partitioning tab but am not able to change the layout or the options I can add a partition to the drive when I add the drive using +. I have tried Disk repair and verify. I can remember earlier that I was able to access these options but am not now, I feel there is some sort of residual partition left on the drive that needs to be cleared but am not sure how. Boot camp does not give the option to remove any partitions.

    This is what i see in Disk utility -[​IMG]

    I have tried to use Dos Prompts Diskpart feature when at the start of the windows installation, but it still gives a message saying that the drive has MBR partitions.

    It might be worth noting that when in the dos prompt the HD i'm trying to partition actually had GPT selected and in disk utility if i just add a partitioned drive it appears the GUID option is also selected, issue remains though when i try to install windows on the drive it says it needs to be in GPT.

    Below is the Drive info (it says it is already GUid, so not sure why its rejecting windows if GPT and GUID are the same thing... not sure on that one)

    Name : APPLE HDD WD10EZES-40UFAA0 Media

    Type : Disk



    Partition Map Scheme : GUID Partition Table

    Disk Identifier : disk0

    Media Name : APPLE HDD WD10EZES-40UFAA0 Media

    Media Type : Generic

    Connection Bus : SATA

    Device Tree : IODeviceTree:/PCI0@0/SATA@1F,2/PRT0@0/PMP@0

    Writable : Yes

    Ejectable : No

    Location : Internal

    Total Capacity : 1 TB (1,000,204,886,016 Bytes)

    Disk Number : 0

    Partition Number : 0

    S.M.A.R.T. Status : Verified

    If anyone is familiar with this or knows a way around this would be great if you could help out, let me know if any more information is required.

    Thanks
    KG
     
  2. Erdbeertorte macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia
    #2
    When you click on + you have to select the new partition to change the format and you have to install something like Paragon or Tuxera NTFS if you want to format it with NTFS:

    Bildschirmfoto 2015-12-30 um 05.17.47.png

    I haven't used BootCamp for a very long time. But I never had to create a second Partition before. The Assistant did it always by itself. If I remember correctly the BootCamp Assistant did not even work, when I already had two partitions. :rolleyes:
     
  3. KG101 thread starter macrumors newbie

    KG101

    Joined:
    Dec 29, 2015
    Location:
    T'ville
    #3
    Hi, thanks for the reply, I'm in the process of installing now with a solution found online, will update the post soon as currently on my phone.
     
  4. zhaoxin macrumors regular

    Joined:
    Jan 28, 2015
    #4
    It is true that Windows needs the disk to be GPT on a EFI machine. Or it can't boot from the disk. You need to backup and re-partition your disk with gpt. When you try that, you can choose the Options, which is current grey on the right bottom corner of the partition layout chart.
     

Share This Page