Andreas_T

Cancelled
Original poster
Dec 8, 2016
1
1
Hi everyone! I waited long enough to post this, but it is getting very annoying at this point.

I have Mazda 3 2010 car and I always connected my phone via Bluetooth to stream music, audio and calls. Never had any issues up until iPhone 7 Plus / iOS 10.

I gave it a good few months before getting to this point - being really frustrated that there is no fix yet.

Here is the problem:
- When streaming audio using any app (Music / Pandora / SoundCloud / Spotify ), the audio stops for a few seconds and Mazda audio interface goes from 'Connected' to 'Searching'. Then the connection resumes after few seconds, sometimes longer and music continues to play where left off.

-Sometimes the music streaming does not stop, but instead seems to be speeding up in playback for few seconds (1.2X - 1.5X normal playback speed).

-It happens randomly. Sometimes the audio can stream for 30 minutes without any problems. Sometimes it disconnects every few minutes.

I cannot notice any pattern. Running background apps or not running. Removing phone profile from car and re-pairing does not help.

Searching forums, it seems like a lot of people are having similar type of issues. Is this hardware related or software?

Running iOS 10.1.1(14B100), AT&T, iPhone 7 Plus Jet Black 128GB

***Please, if you have the same problem with your Bluetooth, post your problem. We need this solved. Thanks.

***EDIT: Talked to Apple Support and opened a case about this. The support was amazing as always and I will be sending them as much of information about this as humanely possible!
 
Last edited:
  • Like
Reactions: ptesone

FreakinEurekan

macrumors 68040
Sep 8, 2011
3,451
425
Eureka Springs, Arkansas
I have a 2010 Mazda 3, with the iPhone 5s no issues like you're describing. My 7 Plus arrives on Tuesday, I'll keep an eye on this thread & update with results.

I've actually been considering replacing the stereo with a CarPlay aftermarket unit. I wear Made for iPhone hearing aids, and in the Mazda the only issue I have had, is phone calls (sent or received) seem to bounce back & forth between the Mazda system and my hearing aids. No such issue with the aftermarket Pioneer bluetooth in my truck.
 
Comment

FreakinEurekan

macrumors 68040
Sep 8, 2011
3,451
425
Eureka Springs, Arkansas
I've had the 7 Plus about 5 days, have used it with the Mazda some but not extensively - running iOS 10.2. So far, no issues. But, I don't think I've used it for more than 30 minutes or so at a time. I just don't drive that much.

Did you see any difference/improvement on iOS 10.2?
 
Comment

ptesone

macrumors newbie
Oct 27, 2009
26
4
Running iOS 11 (15A5318g)
Sprint
iPhone 7 Plus

Connected to:
SONY Bluetooth speaker SRS-XB2
Bluetooth drops out and stutters during music from any source.

Didn’t do that before latest update
 
Comment

Melis4

macrumors newbie
Mar 7, 2019
1
0
New Zealand
Hi there,

I am having this same issue with a new iPhone XS - did you ever find a solution?

Thanks,
Melissa


Hi everyone! I waited long enough to post this, but it is getting very annoying at this point.

I have Mazda 3 2010 car and I always connected my phone via Bluetooth to stream music, audio and calls. Never had any issues up until iPhone 7 Plus / iOS 10.

I gave it a good few months before getting to this point - being really frustrated that there is no fix yet.

Here is the problem:
- When streaming audio using any app (Music / Pandora / SoundCloud / Spotify ), the audio stops for a few seconds and Mazda audio interface goes from 'Connected' to 'Searching'. Then the connection resumes after few seconds, sometimes longer and music continues to play where left off.

-Sometimes the music streaming does not stop, but instead seems to be speeding up in playback for few seconds (1.2X - 1.5X normal playback speed).

-It happens randomly. Sometimes the audio can stream for 30 minutes without any problems. Sometimes it disconnects every few minutes.

I cannot notice any pattern. Running background apps or not running. Removing phone profile from car and re-pairing does not help.

Searching forums, it seems like a lot of people are having similar type of issues. Is this hardware related or software?

Running iOS 10.1.1(14B100), AT&T, iPhone 7 Plus Jet Black 128GB

***Please, if you have the same problem with your Bluetooth, post your problem. We need this solved. Thanks.

***EDIT: Talked to Apple Support and opened a case about this. The support was amazing as always and I will be sending them as much of information about this as humanely possible!
 
Comment

FreakinEurekan

macrumors 68040
Sep 8, 2011
3,451
425
Eureka Springs, Arkansas
Hi there,

I am having this same issue with a new iPhone XS - did you ever find a solution?

Thanks,
Melissa
Still no troubles here with streaming audio from an iPhone X now on iOS 12.1.4.

Phone calls are tricky and the “Be-Doop” noise when a call disconnects is HORRIBLY loud. I don’t really talk on the phone much though.

What I’d like to do is replace the stereo with an aftermarket CarPlay unit, which would also let me add a rear-view camera. The view out the back of the Mazda 3 sedan is hideous, the side pillars make it very difficult to back out of angled street parking for example. But I’d want wireless CarPlay and just not willing to part with that much cash...
 
Comment

Ritik

macrumors newbie
Oct 2, 2019
1
0
Hi everyone! I waited long enough to post this, but it is getting very annoying at this point.

I have Mazda 3 2010 car and I always connected my phone via Bluetooth to stream music, audio and calls. Never had any issues up until iPhone 7 Plus / iOS 10.

I gave it a good few months before getting to this point - being really frustrated that there is no fix yet.

Here is the problem:
- When streaming audio using any app (Music / Pandora / SoundCloud / Spotify ), the audio stops for a few seconds and Mazda audio interface goes from 'Connected' to 'Searching'. Then the connection resumes after few seconds, sometimes longer and music continues to play where left off.

-Sometimes the music streaming does not stop, but instead seems to be speeding up in playback for few seconds (1.2X - 1.5X normal playback speed).

-It happens randomly. Sometimes the audio can stream for 30 minutes without any problems. Sometimes it disconnects every few minutes.

I cannot notice any pattern. Running background apps or not running. Removing phone profile from car and re-pairing does not help.

Searching forums, it seems like a lot of people are having similar type of issues. Is this hardware related or software?

Running iOS 10.1.1(14B100), AT&T, iPhone 7 Plus Jet Black 128GB

***Please, if you have the same problem with your Bluetooth, post your problem. We need this solved. Thanks.

***EDIT: Talked to Apple Support and opened a case about this. The support was amazing as always and I will be sending them as much of information about this as humanely possible!

hi i recently just got my Mazda 3 and this problem is driving me crazy. Did you find any solution for this? I’ve tried reconnecting and anything else I could think of however none were a success?
Thanks

iPhone 7 Plus 128gb
iOS 13
 
Comment

Cavediver

macrumors newbie
Nov 12, 2020
1
0
Hi everyone, Id like to chime in on this topic with what I did to resolve the same problem. I also have a 2010 Mazda 3, and have been using an iPhone X. Two wks ago, I upgraded to an iPhone 11 pro max. Nothing bluetooth was connecting to my new phone. After looking into it, it seems the bluetooth not connecting is a common problem, and many online searches were saying to reset the network settings on the phone.I simply had to reset the network settings on my phone. This ONLY erases your wifi, and wifi password. So that was an easy fix to log back into my home wifi. Then, on my car, I had to delete ALL old pairings in the car bluetooth. Once I did that, and then tried to pair my new phone, my phone was now seeing the Mazda, and everything went smoothly. When I did the erasing in my car however, I did it through the CarPlay button on the steering wheel, using the voice prompts. Hope this helps some of you.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.