External SSD issue: EFI partition missing after reformatting, now can't be read altogether

Discussion in 'macOS Mojave (10.14)' started by iglaoftheninth, Apr 19, 2019.

  1. iglaoftheninth, Apr 19, 2019
    Last edited: Apr 19, 2019

    iglaoftheninth macrumors newbie

    iglaoftheninth

    Joined:
    Apr 19, 2019
    #1
    (MacBook Pro 13" late 2013, 8 GB RAM, i5 2.4 GHz)

    Hi all! I recently got a 1 TB Seagate Backup Plus external SSD and was planning to install Mojave on it. After plugging it in for the first time, I opened Disk Utility to change the partition map from MBR to GUID and then started up the installer. The drive's icon was greyed out and the installer told me that I couldn't boot up from it, so I opened Disk Utility again to see what's wrong. I noticed that the EFI partition was now missing for some reason, which I guessed was the cause of the problem.

    I wasn't sure what to do at this point, so I tried to erase the drive again, but the process failed with a "couldn't unmount disk" message. Then I tried to erase it via Terminal, but again, the operation timed out while unmounting the drive. What's worse, when I unplugged it and then plugged it back in, the drive didn't show up on Finder or Disk Utility, though it's still listed when I entered the diskutil command on Terminal (only the size, no volumes listed). Any idea what's happening here? Thanks a lot in advance!
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Did the drive come with any "Seagate factory installed" utility software on it?

    If so, you might have to nuke this stuff before going further. This 3rd-party software (although placed there with good intentions) can often "muck things up" with the Mac OS.

    I believe you can go to Seagate's support pages and download a utility that will remove the factory-installed stuff (if, in fact, it's there).

    Do that, and THEN try erasing it with Disk Utility again.
     
  3. iglaoftheninth thread starter macrumors newbie

    iglaoftheninth

    Joined:
    Apr 19, 2019
    #3
    No, but the manual told me that I had to download the Paragon NTFS for Mac driver to write files on it. Right now the drive isn't showing up on Disk Utility at all, so I'm not sure what I can do from there.
     
  4. NoBoMac macrumors 68020

    Joined:
    Jul 1, 2014
    #4
    Since you are intending to use the drive as a Mac drive, don't need Paragon.

    Seen similar years ago. Since can see the drive via diskutil, reformat the drive with diskutil as exFAT/NTFS/etc (PC format). The drive should then show in Disk Utility GUI, and then can try taking next steps.
     
  5. HenryAZ macrumors 6502a

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #5
    Instead of using the Erase button in Disk Utility, use the Partition button. One partition, and choose your format.
     

Share This Page

4 April 19, 2019