aroom

macrumors member
Nov 26, 2014
75
151
Did anybody successfully upgrade to Catalina using dosdude1's patcher and a defect Macbook with AMD GPU?

I have a Late 2011 MBP and think about updating to Catalina. But I fear, that after updating I won't be able to boot again. So it would be great to read some reports.
I've been using it a while without big issue. as I couldn't implemented the usual temperature mitigation code my mbp was running a bit hot, so I decided to continue on high sierra
 

Arnas Bartulis

macrumors newbie
Jan 1, 2020
1
0
Hello !

I'm using a 17" MBP early 2011. I tried nearly (all?) manipulations advised on this thread, none of them worked : the computer boots, chimes, but the screen remains completely off. I saw a 2 or 3 posts of people facing the same situation, but couldn't find answer to their problem.

Does anyone have an idea ? It would be miraculous !
Same here... sometime with "chim" screen is black, sometimes without "chim" only coolers work. But if I'm lucky to make it boot fast, EFI method for turning AMD dGpu is ok :) Sometimes it boots from the first time, sometimes it take 5 tries in row to succeed. I've noticed that if you leave and give time to heat up for some minutes, then turn off and immediately on, the screen comes on and mac boots normally.
And when booted it works stable. I'am using it for home audio recording studio. (15" MBP, 2011)
 

bmwpowere36m3

macrumors 6502
Nov 8, 2007
294
0
Same issue plagued my early 2011 15" MBP... OS X started reporting more and more issues when using Safari with many tabs open or hours. Often times freezing up or rebooting. Eventually it wouldn't boot past the gray start up screen. Tried resetting SMC and NVRAM a few times and luckily enough, it booted and I was able to run TM. It ran a little longer and finally wouldn't boot past gray startup, no matter what I tried.

Figured the laptop was done, not worth replacing the logic board with another "ticking time-bomb". Found this thread and first tried the commands to disable the GPU. Laptop booted normally, but the fix only last so long and was a little buggy. However, it confirmed the GPU was the issue. Some more searching and I stumbled on the CMIzapper chip... for $70 figured it was worth a shot.

Success! Laptop works great now and I upgraded the original HDD to a SSD... wow that really is noticeable in how quickly things load. Hopefully get a few more years out of the machine.
 

Cerberus333

macrumors newbie
Jan 15, 2020
1
0
Hi, I read most of the post on this and some other threads but can’t seem to find any answer. My MacBook 8,2 recently started to boot on grey screen. After research, I did everything posted here and everything worked on Sierra. So then I decided I want Mojave and did the patched installation disabled gpu and now Mojave works, even the brightness keys work that are supposed not to... Anyway now my only problem is video playback, it’s glitchy and unusable when playing anything else beside h264. I suppose it has to do with metal not being supported. Is there anyway to make video playback on Mojave? Sorry if this question has been answered before or if I am on the wrong thread
 
Last edited:

Sakic10

macrumors member
Mar 25, 2011
74
0
Calgary, Alberta
Hi, I'm wondering if you guys have the answer for me. I used the macmod to use Linux to set up Intel as the graphics on my 2011 15". I can now boot into safe mode and AMD is still there under hardware. Is removing the Radeon chip 100% necessary? That I have no experience with doing. Currently the computer will not boot regularly, only in safe mode.
 

rmw700

macrumors newbie
Jan 23, 2019
5
1
I finally got the problem resolved by using Real Mac Mods
IT Elite Compute Service
1298 E Philadelphia Ave
Boyertown, Pa
Adam@realmacmods.com
$85 to do gpu bypass and soder jumper on logic board

Works with one gpu now
 

Shianh

macrumors newbie
Feb 1, 2017
3
5
Hi everyone,

I have a 2011 17-inch MBP that I had reballed (yes I watched Rossman's video). It lasted over a year, which I guess is better than average.

I'm now considering permanently bypassing the AMD GPU, BUT - I am concerned about the following:

  1. Brightness control no longer working (this is documented)
  2. External monitor no longer possible (this is documented)
  3. Can no longer use certain apps, namely Parallels Desktop (I'm suspecting this)
I wanted to ask the folks here in this community and on this thread with some experience with this issue if:

  • A) they know of a way to address issue #1 and/or 2 above, and
  • B) they can confirm that indeed, Parallels Desktop cannot run if your Mac can only use the Intel chip)
  • C) if I try the command-only solution (not dosdude's physical chip), can I revert back to how it was before, and if so, is there a guide somewhere on how to revert?
Thanks in advance and if anyone has their MBP only running on the Intel chip, if you could try installing a trial of Parallels Desktop and see if it will run and boot a VM (I think it comes with a free Linux VM), I would be eternally grateful to you.

Cheers
 

Kweb

macrumors newbie
Jan 22, 2020
2
0
So the issue I am having is this.

If I am not plugged in and the computer goes to sleep, I get a black screen. After restarting it wont boot up, but I get a chime and can heard CD drive. I need to chuck the MBP under a blanket and over heat it to get the screen to work. A trick i founds is just to keep a screen saver on so it doesnt go to sleep and keeping it attached to power at all hours. 30 days uptime is my record, before I sometimes forget to plug it in. :)

For what its worth I added the sleep/hibernation tricks but I think something else besides the GPU might be going haywire. Since they don't seem to be doing much.

Running Mojave. Also should add the sound has gone out but will randomly come back. maybe Just a bad logic board after my heat treatments..

Any words of wisdom anyone can add that arent already here in 109 pages of posts?
 

Dman91

macrumors member
Jun 27, 2011
45
0
@AppleMacFinder

Thank you for the detailed instructions, my MacBook Pro is back to life after almost 3 years, I tried the simple Mac version, but a few things are off, for instance the graphics sometimes get all crazy again after shutdown/boot up and I have either to repeat the steps, or sometimes it just boots fine after a few restarts.

Sometimes when I restart the Mac, the screen goes black but the cursor is still visible and the machine does not reboot.

Do you have any suggestions?

Thanks
 

hermannkm

macrumors newbie
Feb 23, 2019
1
0
Fix for 17 inch dGPU switch issue

(Tested successfully in both “early” and “late” 2011 17 inch MacBook Pro)




This guide is based on the experience of many users (including me) while trying to fix the very well known issue with AMD dGPU on 17’’ MacBook Pro from 2011 (both early and late):



Step 0) As a starting point I made a clean installation of Sierra (Version 10.12.4) — This is just a step for establishing a common middle ground and is not really needed….

0.1)
To do this just download the installer from the App Store and then use “DiskMaker X” to create a bootable installation.

0.2) After the bootable image is created, proceed to turn off your computer and hold the “Alt” or “Options” Key. Select the Sierra installer and proceed with the installation (I format the HDD partition to make a clean install on it)



Note: You might need to do this on another computer. Just buy one of those cheap usb to sata connectors and use it to connect it to another Mac so you don’t risk having your installation failed because of your machine.



Step 1) Prepare a Bootable USB pendrive with a non GUI Linux (Credits to AppleMacFinder)



1.1) Download ArchLinux ISO


You need a working computer for that and a spare CD/DVD/USB drive. Download the latest Arch Linux ISO image from this page - https://www.archlinux.org/download/ , at the time of writing it is archlinux-2017.03.01-dual.iso . Then you could either simply burn this ISO to CD/DVD (which later could be either inserted to MBP's SuperDrive or External DVD Drive connected to MBP by two USB cables) or create a bootable USB: use the great detailed instructions from this page, https://wiki.archlinux.org/index.php/USB_flash_installation_media



1.2) Creating the bootable USB with the .iso:

In macOS


First, you need to identify the USB device. Open /Applications/Utilities/Terminal and list all storage devices with the command:

*) diskutil list


Your USB device will appear as something like /dev/disk2 (external, physical). Verify that this is the device you want to erase by checking its name and size and then use its identifier for the commands below instead of /dev/diskX.

A USB device is normally auto-mounted in macOS, and you have to unmount (not eject) it before block-writing to it with dd. In Terminal, do:

*) diskutil unmountDisk /dev/diskX


Now copy the ISO image file to the device. The dd command is similar to its Linux counterpart, but notice the 'r' before 'disk' for raw mode which makes the transfer much faster:

*) sudo dd if=path/to/arch.iso of=/dev/rdiskX bs=1m

After completion, macOS may complain that "The disk you inserted was not readable by this computer". Select 'Ignore'. The USB device will be bootable.


Step 2) Boot to Linux (Credits to AppleMacFinder):

2.1) Boot to it:
insert this CD/DVD/USB to Macbook Pro, hold Option key while booting, choose "EFI boot" (that is your bootable installation media), press "e" key to edit the GRUB options of the Arch Linux archiso x86_64 UEFI CD menu entry while it is selected at the main screen, add nomodeset to the end of this line and press Enter. If everything is done correctly, you will find yourself at the Linux console! (It takes some time so be patient and wait for the prompt)


2.2) Edit EFI vars: looks like efivarfs filesystem is mounted by default! So you can already cd /sys/firmware/efi/efivars and ls to explore this directory and see if there is a "gpu-power-prefs-..." variable (where ... is UUID of this variable).


2.2-Case 1:

If there is such a variable, its better to remove it with rm.

*) rm gpu-power-prefs-…


In my case the efivarfs has been mounted by default with read/write permissions, but if you are getting the "operation not permitted" message while attempting to rm, it means that in your case efivarfs has been mounted as read-only and you need to remount it with read-write permissions and try again (credits to totoe_84 for this valuable addition) (Try this and then try to remove it):

*) cd /

*) umount /sys/firmware/efi/efivars/

*) mount -t efivarfs rw /sys/firmware/efi/efivars/

*) cd /sys/firmware/efi/efivars/

*) rm gpu-power-prefs-…


If this also fails (If you still can’t erase the file) use chattr command to disable file immutability and then erase the file:

*) chattr -i "/sys/firmware/efi/efivars/gpu-power-prefs-…”

*) cd /sys/firmware/efi/efivars/

*) rm gpu-power-prefs-…


2.2-Case 2:

The file gpu-power-prefs-… doesn’t exist well then you don’t have to delete it hahaha. (I repaired 2 17 inch models and 1 didn’t have it, so it’s fine)


2.3) Create a new gpu-power-prefs-… file (Original credit mentioned above, https://github.com/0xbb/gpu-switch/blob/master/gpu-switch, Credits to AppleMacFinder):

*)
printf "\x07\x00\x00\x00\x01\x00\x00\x00" > /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9


2.4) Add immutability to the gpu-power-prefs-… file (Credits to AppleMacFinder):

This chattr command is supposed to lock a file to make it accessible only by "superuser" - and so that, while booting, your EFI will have no chance to screw up your gpu-power-prefs-... variable under any circumstances


*) chattr +i "/sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9"


2.5) Unmount efivars and reboot (Credits to AppleMacFinder):

Could not unmount efivars if you are inside this directory, so change to the root directory

*) cd /

*) umount /sys/firmware/efi/efivars/

Guarantees that your EFI variables are flushed to efivarfs filesystem, please unmount it safely before rebooting)

*) reboot


3) Eliminate AMD Kexts (Credits to newfield),
Note: You might need to do this every time you do an OS updates, since each update normally writes the AMD Kexts again.


(His words and this also happened to me!: After disabling the dGPU using Arch, normal boot would hang halfway. Although safe boot would work. I wound up having to remove all the AMD kext files in the Terminal in Recovery Console)


Trying to remove them in Single User just gave me sandbox errors. (Summary -> Don’t do it in Single User Mode the one that you boot with Cmd + S)


3.1) So what you have to do is:

If you have FileVault Unlock it first:


Unlock first.

Then Boot into Recovery (“cmd + r”, it will boot without failing, if it fails then repeat step 2 and then after that boot directly into recovery with command + R, I had to do this once because the dGPU got active again after booting into the os with AMD kexts)

*)
Boot into recovery mode (Command + r)

*) Start Terminal

*) diskutil cs list (find UUID for drive)

*) diskutil coreStorage unlockVolume UUID

*) cd /Volumes/Macintosh\ HD

*) mkdir AMD_Kexts

*) mv System/Library/Extensions/AMD*.* AMD_Kexts/

*) reboot



(If you only have one storage with 1 partition just use "cd /Volumes/Macintosh\ HD" and the remaining commands after starting the terminal)


Extra STEP), if your PC is now working! Download “steveschow” branch of gfxCardStatus (gfxCardStatus v2.4.3i) or just download the app directly from:

URLS:


https://github.com/steveschow/gfxCardStatus/releases

https://github.com/steveschow/gfxCardStatus

With this application you can even prove that the dedicated GPU can't get activated. Even if you try to change the selected GPU to the dedicated one, it just won't change.


—————

The End!


AND VOILA!!! You have a working 17 inch MacBook Pro. As I said I tested this with an early 2011 and late 2011 17 inch MacBook Pro’s and both are now running (Before they were both dead)


Big thanks to AppleMacFinder, to the makers and contributors of this thread, to gfxCardStatus maker and forkers :D (steveschow) and to switch-gpu makers I can’t thank you guys enough as I am so happy to bring both of this incredible machines back to life. With this post I am not trying to take any credit, but as I had 2 machines I run into different issues with both, which could be helpful to others, thats why I was inclined to make “my own” guide and share it with you.


I just created an account here to share this, Hope it helps more people!
Just followed your steps and was able to get my MBPro Early 2011 working again (without AMD GPU) - thanks, really GREAT. Just two remarks:
1. Creating a new gpu-power-prefs is easily done be using the gpu-activity-... filename completed with a tab key and then changing the beginning of the filename.
2. Deleting AMD Drivers did not work for me either way. But the MBPro 2011 allows to take the HD out of the case into an external drive case. Then it was easily done from another MB to delete/move these files.
 

Uque

macrumors newbie
Feb 7, 2020
1
0
Hi guys.
Sorry if this has been asked already, couldn't find an answer.
I'm trying to revert dosdude1 utility for disabling the radeon gpu, in order to do the now updated process found here.

However, when I went into the extensions folder I couldn't find any radeon kext file, apparently the patch moves all the files to a folder called .AMDRadeon_backup, they are all there. I've tried using commands like mv, cp -R, in order to move the kexts back to the Extensions folder but couldn't do it.

Does anyone know how to restore this kexts?

Thanks!
 
Last edited:

BrattishBenny

macrumors newbie
Feb 13, 2020
2
0
Hi guys.
Sorry if this has been asked already, couldn't find an answer.
I'm trying to revert dosdude1 utility for disabling the radeon gpu, in order to do the now updated process found here.

However, when I went into the extensions folder I couldn't find any radeon kext file, apparently the patch moves all the files to a folder called .AMDRadeon_backup, they are all there. I've tried using commands like mv, cp -R, in order to move the kexts back to the Extensions folder but couldn't do it.

Does anyone know how to restore this kexts?

Thanks!
I just reinstall the OS lol