Resolved Force 2011 MacBook Pro 8,2 with failed AMD GPU to ALWAYS use Intel integrated GPU (EFI variable fix)

Discussion in 'MacBook Pro' started by AppleMacFinder, Mar 18, 2017.

  1. zaurak macrumors newbie

    Joined:
    Apr 12, 2010
    #101
    Thank you AppleMacFinder for the solution, I will try it, however I will order the replacement chip. Please confirm that I will be able to restore the original settings, for the chip to be able to run. Thanks
     
  2. Leehro macrumors member

    Joined:
    Aug 11, 2007
    #102
    Is anyone else having issues since updating to 10.12.4? I had this working on my Early 2011 MBP for months under 10.12.3.

    I re-applied the fix last night (booting arch linux and set the gpu-power-prefs var through the efivars filesystem), and I could boot macOS with the internal GPU occasionally.

    Now, even when I can get a successful boot, I still hear capacitors whining (this was my first symptom of a bad discrete GPU, and it means the chip is powered and running). It seems anything that tries to access the discrete GPU immediately locks up the machine. If I quit gfxCardStatus, the mac locks up. If I try to set gfxCardStatus to integrated only, the computer freezes up. Media apps like EyeTV cause it to freeze up too.

    Any thoughts? I'm pretty sure the 10.12.4 update put all the AMD kexts back. Do I need to remove those again? The "100% working solution" part doesn't mention that.
     
  3. photomatix macrumors newbie

    Joined:
    Apr 7, 2017
    #103
    This worked for me! Now I have my Mac back again!

    When I started having this problem it was right after I had updated to the latest MacOS beta(10.12.5 I believe). Is it just chance that my GPU failed right after that update or was there a firmware updated that bricked the GPU? I'm having trouble finding what exactly the 10.12.5 update installed. If that's what happened, is there a way to revert to the previous GPU and/or EFI "firmware"? Does that make sense?

    This is a little over my head so I may not be using the correct terms.
     
  4. zaurak macrumors newbie

    Joined:
    Apr 12, 2010
    #104
    It worked like magic, even in the boot screen, amazing. Thanks AppleMacFinder. Somebody can confirm, that if I remove the created power-pref file and I will do a hardware repair, the dGPU will work again?

    I'm running Early 2011 17 inch, MacOS 10.12.4
     
  5. Ciroxxx macrumors newbie

    Joined:
    Apr 19, 2017
    #105
    Eventually I succeeded too!!!
    I recommend removing the .kext files.
    I applied the procedure advised by @AppleMacFinder without removing .kext files but when viewing for example a video the system freezed again (trying to switch to dGPU).
    Also on reboot the system freezed again on the gray screen.
    When I rebooted to ArchLinux I noticed that the file gnu-power-prefs-..... wasn't anymore there, so some process erased it.

    After moving the .kext files, resetting Nvram and SMC and applying the procedure by @AppleMacFinder everything worked perfectly.

    Many many thanks @AppleMacFinder
     
  6. FGuarini, Apr 19, 2017
    Last edited: Apr 24, 2017

    FGuarini macrumors newbie

    Joined:
    Apr 19, 2017
    #106
    Fix for 17 inch dGPU switch issue

    (Tested successfully in both “early” and “late” 2011 17 inch MacBook Pro)



    This guide is based on the experience of many users (including me) while trying to fix the very well known issue with AMD dGPU on 17’’ MacBook Pro from 2011 (both early and late):



    Step 0) As a starting point I made a clean installation of Sierra (Version 10.12.4) — This is just a step for establishing a common middle ground and is not really needed….

    0.1) To do this just download the installer from the App Store and then use “DiskMaker X” to create a bootable installation.

    0.2) After the bootable image is created, proceed to turn off your computer and hold the “Alt” or “Options” Key. Select the Sierra installer and proceed with the installation (I format the HDD partition to make a clean install on it)



    Note: You might need to do this on another computer. Just buy one of those cheap usb to sata connectors and use it to connect it to another Mac so you don’t risk having your installation failed because of your machine.



    Step 1) Prepare a Bootable USB pendrive with a non GUI Linux (Credits to AppleMacFinder)



    1.1) Download ArchLinux ISO

    You need a working computer for that and a spare CD/DVD/USB drive. Download the latest Arch Linux ISO image from this page - https://www.archlinux.org/download/ , at the time of writing it is archlinux-2017.03.01-dual.iso . Then you could either simply burn this ISO to CD/DVD (which later could be either inserted to MBP's SuperDrive or External DVD Drive connected to MBP by two USB cables) or create a bootable USB: use the great detailed instructions from this page, https://wiki.archlinux.org/index.php/USB_flash_installation_media



    1.2) Creating the bootable USB with the .iso:

    In macOS

    First, you need to identify the USB device. Open /Applications/Utilities/Terminal and list all storage devices with the command:

    *) diskutil list


    Your USB device will appear as something like /dev/disk2 (external, physical). Verify that this is the device you want to erase by checking its name and size and then use its identifier for the commands below instead of /dev/diskX.

    A USB device is normally auto-mounted in macOS, and you have to unmount (not eject) it before block-writing to it with dd. In Terminal, do:

    *) diskutil unmountDisk /dev/diskX


    Now copy the ISO image file to the device. The dd command is similar to its Linux counterpart, but notice the 'r' before 'disk' for raw mode which makes the transfer much faster:

    *) sudo dd if=path/to/arch.iso of=/dev/rdiskX bs=1m

    After completion, macOS may complain that "The disk you inserted was not readable by this computer". Select 'Ignore'. The USB device will be bootable.


    Step 2) Boot to Linux (Credits to AppleMacFinder):

    2.1) Boot to it: insert this CD/DVD/USB to Macbook Pro, hold Option key while booting, choose "EFI boot" (that is your bootable installation media), press "e" key to edit the GRUB options of the Arch Linux archiso x86_64 UEFI CD menu entry while it is selected at the main screen, add nomodeset to the end of this line and press Enter. If everything is done correctly, you will find yourself at the Linux console! (It takes some time so be patient and wait for the prompt)


    2.2) Edit EFI vars: looks like efivarfs filesystem is mounted by default! So you can already cd /sys/firmware/efi/efivars and ls to explore this directory and see if there is a "gpu-power-prefs-..." variable (where ... is UUID of this variable).


    2.2-Case 1:

    If there is such a variable, its better to remove it with rm.

    *) rm gpu-power-prefs-…


    In my case the efivarfs has been mounted by default with read/write permissions, but if you are getting the "operation not permitted" message while attempting to rm, it means that in your case efivarfs has been mounted as read-only and you need to remount it with read-write permissions and try again (credits to totoe_84 for this valuable addition) (Try this and then try to remove it):

    *) cd /

    *) umount /sys/firmware/efi/efivars/

    *) mount -t efivarfs rw /sys/firmware/efi/efivars/

    *) cd /sys/firmware/efi/efivars/

    *) rm gpu-power-prefs-…


    If this also fails (If you still can’t erase the file) use chattr command to disable file immutability and then erase the file:

    *) chattr -i "/sys/firmware/efi/efivars/gpu-power-prefs-…”

    *) cd /sys/firmware/efi/efivars/

    *) rm gpu-power-prefs-…


    2.2-Case 2:

    The file gpu-power-prefs-… doesn’t exist well then you don’t have to delete it hahaha. (I repaired 2 17 inch models and 1 didn’t have it, so it’s fine)


    2.3) Create a new gpu-power-prefs-… file (Original credit mentioned above, https://github.com/0xbb/gpu-switch/blob/master/gpu-switch, Credits to AppleMacFinder):

    *) printf "\x07\x00\x00\x00\x01\x00\x00\x00" > /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9


    2.4) Add immutability to the gpu-power-prefs-… file (Credits to AppleMacFinder):

    This chattr command is supposed to lock a file to make it accessible only by "superuser" - and so that, while booting, your EFI will have no chance to screw up your gpu-power-prefs-... variable under any circumstances


    *) chattr +i "/sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9"


    2.5) Unmount efivars and reboot (Credits to AppleMacFinder):

    Could not unmount efivars if you are inside this directory, so change to the root directory

    *) cd /

    *) umount /sys/firmware/efi/efivars/

    Guarantees that your EFI variables are flushed to efivarfs filesystem, please unmount it safely before rebooting)

    *) reboot


    3) Eliminate AMD Kexts (Credits to newfield),
    Note: You might need to do this every time you do an OS updates, since each update normally writes the AMD Kexts again.


    (His words and this also happened to me!: After disabling the dGPU using Arch, normal boot would hang halfway. Although safe boot would work. I wound up having to remove all the AMD kext files in the Terminal in Recovery Console)


    Trying to remove them in Single User just gave me sandbox errors. (Summary -> Don’t do it in Single User Mode the one that you boot with Cmd + S)


    3.1) So what you have to do is:

    If you have FileVault Unlock it first:

    Unlock first.

    Then Boot into Recovery (“cmd + r”, it will boot without failing, if it fails then repeat step 2 and then after that boot directly into recovery with command + R, I had to do this once because the dGPU got active again after booting into the os with AMD kexts)

    *) Boot into recovery mode (Command + r)

    *) Start Terminal

    *) diskutil cs list (find UUID for drive)

    *) diskutil coreStorage unlockVolume UUID

    *) cd /Volumes/Macintosh\ HD

    *) mkdir AMD_Kexts

    *) mv System/Library/Extensions/AMD*.* AMD_Kexts/

    *) reboot



    (If you only have one storage with 1 partition just use "cd /Volumes/Macintosh\ HD" and the remaining commands after starting the terminal)


    Extra STEP), if your PC is now working! Download “steveschow” branch of gfxCardStatus (gfxCardStatus v2.4.3i) or just download the app directly from:

    URLS:

    https://github.com/steveschow/gfxCardStatus/releases

    https://github.com/steveschow/gfxCardStatus

    With this application you can even prove that the dedicated GPU can't get activated. Even if you try to change the selected GPU to the dedicated one, it just won't change.


    —————

    The End!

    AND VOILA!!! You have a working 17 inch MacBook Pro. As I said I tested this with an early 2011 and late 2011 17 inch MacBook Pro’s and both are now running (Before they were both dead)


    Big thanks to AppleMacFinder, to the makers and contributors of this thread, to gfxCardStatus maker and forkers :D (steveschow) and to switch-gpu makers I can’t thank you guys enough as I am so happy to bring both of this incredible machines back to life. With this post I am not trying to take any credit, but as I had 2 machines I run into different issues with both, which could be helpful to others, thats why I was inclined to make “my own” guide and share it with you.


    I just created an account here to share this, Hope it helps more people!
     
  7. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #107
    This fix works for the 15" also?
     
  8. FGuarini macrumors newbie

    Joined:
    Apr 19, 2017
    #108
    If you have the 15 inch MacBookPro with the Nvidia cards and your able to boot into the system but after sometime your machine hangs (because the dGPU goes active). Then I would recommend you just use the gfxCardStatus v2.4.3i program described in "Step Extra" and then select inside the program to only use the integrated GPU.

    In the office I have a 2010 15 inch MacBook Pro that has that problem and I fixed it by using the procedure that I just described since you can log into the user, which you can't with the 17 inch models with AMD cards
     
  9. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #109
    I have the 15" with the AMD Radeon HD 6490M

    It hang on login, can't load OS.

    I did try loading HD in an enclosure then booting it up via USB on another machine and trying the gfxcardstatus fix but no luck.
     
  10. FGuarini, Apr 19, 2017
    Last edited: Apr 19, 2017

    FGuarini macrumors newbie

    Joined:
    Apr 19, 2017
    #110
    Then you could try it, It could work since both 17 inch MBPros that I fixed had different Radeon Models and the fixed worked in both. Just check that the code after gpu-power-prefs-[this code] matches yours (if it exist). If it does exist, write it down and I would recommend using that one. Still I don't know the ins and out of what it does, so I can't tell you it will work, but still you can always reformat the drive in case something goes wrong.
     
  11. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #111
    Can you explain the code thing again please?
    --- Post Merged, Apr 19, 2017 ---
    Also

    Has anyone tried realising the GPU with a heat gun?

    Failing the EFI and reflowing fix, is their anyway the machine is salvageable?

    Do the Chinese make working logic board copies?

    Can the parts be re build in another machine ?
     
  12. ectomorph macrumors newbie

    Joined:
    Apr 21, 2017
    Location:
    London
    #112
    Hi AppleMacFinder

    I'm having exactly the same problem. I'm booted from the archlinux live usb as root. I successfully unmount efivarfs and then remounted it - this about the 6th time of trying. But when I try to write the file and what I get id zsh: invalid argument: /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30fg

    And I seem to be stuck at this point. I've reset the SMC and zapped the pram but still no luck.

    Luckily my screen MBP 8,2 isn't distorted: it's just got the external monitor problem and won't go to sleep. Machine runs a little bit hot. I was hoping that this would enable me to use integrated graphics which would be better than what I have. But it looks like that's not to be.

    By the way, last night I had a same file in efivarfs as you last night but after resetting the SMC and zapping thr pram that appeared to have vanished today when I boot into archlinux,
     
  13. henchman macrumors 6502a

    Joined:
    Dec 28, 2004
    #113
    I decided to not mess around, and got the GPU replaced for $125
     
  14. ectomorph macrumors newbie

    Joined:
    Apr 21, 2017
    Location:
    London
    #114
    --- Post Merged, Apr 23, 2017 ---
    I worked out that i was making a simple erroe in the file name cause by the font Macrumour uses and my low level dislexia. Once i realised that the last character in the pintf file was a 9 and not a g AppleMacFinder's fix worked perfectly and I'm now using the MacBookPro 8,2 on ingegrated graphics with no noticeable problems. Both Photoshop and graphics intensive games work without problem. Haven't really noticed not using the AMD graphics unit at all.
    --- Post Merged, Apr 23, 2017 ---

    Hi Having posted that I was having problems on Friday - I managed to use the above fix perfectly when I realised the last character in the printf file name was a 9 not a g.

    It worked and I'm working on integrated graphics and not really noticing any performance deficit compared with the AMD Radion graphics. Both Photoshop and graphics intensive games work perfectly without problems.

    Kudos AppleMacFinder. I thought there must away to enforce this I didn't realize it would be so far down at the machine level. Thank you very much
     
  15. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #115
    Anyone tried this
    https://github.com/0xbb/gpu-switch

    "Please note that only source code is there so Xcode is requred to compile the binary. The application runs from terminal, reportedly uses the same code as gfxCardStatus but writes the setting into NVRAM(PRAM) so machine remains switched to internal GPU on next boot(s)/wake(s)"
     
  16. roberthallin macrumors member

    Joined:
    Oct 25, 2009
    Location:
    Stockholm, Sweden
    #116

    This worked perfectly for me. The initial "fix" that I did turned out to be just my dGPU coming back to life for a brief moment that by cheer chance happened to be when I was messing around with the EFI. It's real glitchy and sometimes it would work for a day or two and then give me the artefacts again. I tried just doing the EFI-fix which didn't help, and booting in single user mode wouldn't let me remove the kext-files. But this worked, and now it's up and running again and the GPU seems to be permanently disabled.

    I did however update the OS after initially applying the fix, which wrote new kext files. I simply redid the procedure and it's all working. I'm using a 15" MBP from early 2011, with the AMD 6750.
     
  17. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #117
    Hi Team,

    Hopefully someone can give me a couple of pointers.

    I made the boot USB from windows using TransMac or MacTrans, it was an .iso image.

    Booted to Linux successfully.

    Think I followed the codes correct (made a couple of mistakes along the way)

    Reboot brings me Recovery mode, which I take as a great sign as my machine wasn't previously able to access recovery.

    I select boot from HD, restart,

    Now it's hanging on Apple logo with half a progress bar.

    Whereas before it would wait till I sign in to show the progress bar and hang.

    Any ideas are most welcome!
     

    Attached Files:

  18. Bwil10, Apr 26, 2017
    Last edited: Apr 26, 2017

    Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #118
    Just did the process again because i saw the :( which operation not permitted.

    went through better, there was no confirmation after each line, just skips straight down to the next terminal without confirmation. seemed like it worked though.

    I also disabled SIP and moved amd.kexts

    For some reason I can access Recovery mode and safe mode now when i couldn't before but its still not loading regularly
     

    Attached Files:

  19. Lloyd22 macrumors newbie

    Joined:
    Apr 28, 2017
    #119
    Hi!

    Just registered to say thank you, AppleInsider, it seems like it's working well and I can still use apps like Illustrator or Lightroom. Well done for the work.
    I think this post needs to be share A LOT, on other forums where people are desperate and don't know that they can give life back to their machines. Spread the post!

    Oh, and juste a note for myself :
    Apple : NEVER again.
     
  20. AppleMacFinder, Apr 30, 2017
    Last edited: Apr 30, 2017

    AppleMacFinder thread starter macrumors 6502a

    AppleMacFinder

    Joined:
    Dec 7, 2009
    #120
    You could set a "temporary" password like qwerty - its almost the same as "no password", very easy for your friends to remember, and it will allow you to run dd and other commands which require a password for their execution

    That's strange. I have never had to reapply this fix, even after installing the OS X 10.11.6 update. Maybe you have discharged your computer and it lost the variable values, or maybe this fix is more stable on 10.11.x El Capitan than on 10.12.x Sierra, or something else - I don't know... In any case, try completely wiping the cache and history of your web browser to return it to the default state

    Sorry for my late reply! According to https://github.com/0xbb/gpu-switch/blob/master/gpu-switch , you will be able to restore the original settings: by removing this EFI variable and creating it again with \x07\x00\x00\x00\x00\x00\x00\x00 value instead of \x07\x00\x00\x00\x01\x00\x00\x00 value. Alternatively you could just remove this variable and see what happens

    Of course you need to remove the AMD kexts - if they came back with 10.12.4 update

    The last update for MBP 2011 EFI firmware was several years ago, it is difficult to downgrade it to its' previous version - and I don't see any point in doing so

    It could be that 10.12.5 update includes the new AMD kexts and they have been installed. If that is true, you need to remove them again. In short - if anything breaks, repeating a fix should fix the things :D

    2011 Macbook Pro 15" with discrete GPU = 2011 Macbook Pro 8,2 - and the thread title says this fix works for 8,2 . But in theory, it should work for any MBP with integrated+discrete GPU combination, maybe even for those which have discrete NVIDIA instead of discrete AMD

    It is interesting that just using gfxCardStatus solves a problem for MBPs with discrete NVIDIA , sadly gfxCardStatus can't solve a problem for MBPs with discrete AMD - so this EFI variable fix is required

    Heating the GPU with a heat gun could work, but I can't promise that it will be a permanent fix - because of Apple's bad solder quality eventually it will break again, but nobody could tell when: after a couple of hours/days/months/or years . Also you need to be careful - don't overheat the neighbour parts! It is recommended to cover everything with aluminium foil, except a GPU chip, before using a heat gun. Of course its better to either do BGA reballing with good solder, or GPU replacement, but these things are hardly doable at the domestic conditions, especially for the people with no repair experience

    EFI fix should work eventually, I am very sad reading that it is not working for you yet... If you are tired with EFI variable fix and have some spare money, here is the alternative solution - quoted from my 1st message of this thread:

    There are even some Chinese motherboard repair services - for example, http://www.aliexpress.com/item/Prof...her-Board-Quad-Core-i7-2-0Ghz/2024020852.html and http://www.aliexpress.com/item/Prof...Ghz-17-Mother-Board-MC024LL-A/2023462680.html , but I guess they are useful only for those people who live in the countries with a very high labour costs and it is too expensive for them to repair it locally

    I do not know if the Chinese are making the working logic board copies ( I think they don't ),
    but they have three possible items in their stocks:

    1) completely new 2011 MBP motherboards - Apple always orders to manufacture more motherboards than MBPs, so that some motherboards could be used as the replacement parts

    2) used 2011 MBP motherboards extracted from a broken MBP which had another problem - e.g. someone has damaged a screen of their MBP, and because the replacement price for a screen is too high, they decided to tear down this MBP and sell its' parts separately. These motherboards have a GPU timebomb because it has never been fixed on them

    3) used 2011 MBP motherboards extracted from a broken MBP with repaired GPU - probably its' rare

    In any case, the MBP replacement motherboard costs like $500 - so its much more efficient to replace only the failed component (GPU) rather than the whole motherboard

    Of course the parts could be re-used, but I think its more efficient to somehow fix this MBP - either by EFI variable fix or GPU reflowing/replacement - rather than sell it for parts

    My EFI variable fix instructions are partially based on a file from this repository - https://github.com/0xbb/gpu-switch/blob/master/gpu-switch . So yes, we all tried this

    Under Windows, the Rufus utility is recommended for making the Linux bootable USBs, but maybe TransMac could be used too...

    Problem with this EFI variable fix is that even a small mistake - like, typing g instead of 9 as the last character in the printf command - makes it fail to work

    Looks like you somehow booted to Recovery with AMD kexts disabled, but after rebooting they got loaded again...

    Seems like you are close to a target, but something is preventing you to achieve a full success. Are you sure that you have properly removed the AMD kexts, and that the kexts cache has been rebuilt as well? Maybe the kext cache still contains the AMD kexts, so you need to force rebuilding this cache to finalize their removal

    Please try again this part of my 1st message:

     
  21. Bwil10 macrumors newbie

    Joined:
    Mar 31, 2017
    #121
    Thanks Apple Mac finder for taking the time to respond!

    What I'm doing now is partitioning the HDD in 3, ubuntu, OS X and windows.
    Hopefully one of these should work.

    I think from memory when applying the EFI fix I wasn't able to remove GPU-power-pref even though I attempted to load rw permissions.

    I was also a little confused by the first chattr -I line where is says skip this command.

    I attempted it, and also attempted another one someone wrote on the forum where I'd started chattr -i and ended in GPU-power......

    Unsure of what went wrong :/
     
  22. Ciroxxx macrumors newbie

    Joined:
    Apr 19, 2017
    #122
    As I already said this procedure make me fix the Macbook and I am really happy for it.

    But I notice that fans run a lot more than before (I am working in a 20 °C room using just Safari).

    Does it only happen to me?
     
  23. MrAverigeUser, May 1, 2017
    Last edited: May 1, 2017

    MrAverigeUser macrumors 6502a

    MrAverigeUser

    Joined:
    May 20, 2015
    Location:
    europe
    #123
    Thanks to the TO for his excellent work. :)

    I want just to add another ADDITIONAL possible "Solution" for the problem, which is rapidly done in a few minutes under OSX AND (!) at least IMHO a good additional protection of a not already dead GPU:

    explaining my situation at the beginning:
    In our family we own some cMBP 15" 2011 and two of 2012.
    One of the 2011 had already a MB-replacement (still working correctly after that, *knocking on wood*) and just some weeks ago even one of the 2012 ones showed the typical signs of a dying dGPU - gladfully, just reversible, for a while and so being just in condition of "going soon to die, but still alive" . The problem: until now, apple is NOT accepting the 2012 MBP for a replacement.

    FIRST of the problems of dGPUs seems to be a not_too_Intelligent_design_of_dGPU-cooling for me:
    Seemingly, both fans are blowing air in a common channel that FIRST cools the CPU, followed by cooling of the dGPU - but with the same air, already heated up by the cooling of the CPU!
    a really idioxxx way to "cool":
    After burning yourself accidently, you for shure cool yourself with cool water - but Jonathan Ive seems to prefer boiling water to do so... ;) :D

    SECOND problem is not only apple´s policy of "function follows form" (too little volume of the notebook for cooling) but also "cooling follows silence" :
    The fans start far too late to cool and even then they cool not efficient enough, meaning too little upm.

    So - I installed two years ago MacFanControl.
    Set one of the fans reacting on temperature of core 2 of CPU (which is at least in my MBP the hottest core of all 4)
    Set the other fan reacting on temperature of PECI GPU (which ist always at least in my MBP the hottest part of the dGPU-Complex)

    Nevertheless this short time of dGPU_in_Danger some weeks ago showed that the OLD SETTING I did were not at all sufficiently protecting the dGPU. I did not augment the cooling mode aggressive enough higher than the standard reaction implemented by apple, especially the basic rpm.

    NOW, as limit to go higher than the basic rpm of 2000 in the original apple-standard, I did set the lower limit for both CPU and dGPU to 47° C, the maximum limit to 67°C. so - instead of resting most of the time at minimum rpm in "apple standard mode", it rests mostly at still absolut SILENT 3000 rpm = 50% more basic cooling!
    Which is pretty aggressive, permitting rapid "exploding" rpm even higher, IMMEDIATELY when heating up, but - in preventing too high temperatures - getting rapidly down again after a short time, if CPU/dGPU not too busy. And so reacting far much faster and staying at higher rpm than in the "standard apple mode" the which is well known to lead to our common problem with dead dGPUs.

    Since again changing recently my MacFanControl-settings to this even more aggressive approach - there was never a single sign of attainted or "nearly dying dGPU" - although doing some hard tests with work fully charging both CPU and dGPU with lots of work and so heating up.

    bottom line for me:

    To protect your beloved cMBP and counterweight the foolish design for cooling dGPU in MBPs there are a handful of different possibilities:

    1) The method of the TO

    but also

    2) further stabilizing and protecting methods like a aggressive setting in MacFanControl.
    Advantage: Done in a few minutes.
    Firstly, you can let it in "automatic mode", thus just being able to regard and control regually dGPU temperature to understand the problem of "undercooling" of the dGPU and its soldering problems... Then, in a second step, you might take the nevertheless existing risk of your personal settings - BUT think very well about your settings. And control well your temperatures at the beginning. For my own cMBP, this works very fine.

    AND:

    3) shurely also an effective, but risky and demanding know-how is the modification and replacement of the thermal paste used by apple.
    As already shown in classic MacPros, the assembly of the CPUs with too much and not_yet-state_of_the_art thermal_paste (and this in addition neither well done) is - if well done - shurely also a good additional protection. Some people here in the forum did this already also in the cMBP and reported success: lower temperatures of processors

    I like the cMBP of 2011 and especially 2012 a lot - easy and much less costly replacement/upgrading of RAM, SSD, battery, the very last one with option of a glossy-free screen,.... the very last one really ergonomic an more or less customer-friendly MBPs, but with a fatal mistake in design.

    I´ll do everything to protect them to use them as long as even possible.


    edit:

    Can anybody confirm definitely a common cooling-line of both fans in the cMBPs?

    https://forums.macrumors.com/threads/question-about-cooling-system-for-mbp-2011-and-2012.2043420/

    thank you in advance
     
  24. Coastalwaves macrumors newbie

    Joined:
    May 2, 2017
    #124
    Thanks AppleMacFinder. After a full day of troubleshooting and researching I finally found your post. I'm sure I'm getting close to resolving this.

    Just struck one hitch with the process. When I issue the CHATTR command is comes back with NOT FOUND. It's like the command is not available on the Linux Distro, neither does the LSATTR work.
    I pushed on with the process but when I tried to reinstall the OSX instead of going to a whitescreen like previously it freezes now with the Apple logo and a frozen spinning wheel.
    Do I need to add those commands to the Arch Linux Boot image? Thanks for your help.
     
  25. Trungtv macrumors newbie

    Trungtv

    Joined:
    May 2, 2017
    #125
    1.Hello. Pls help me. When i do command printf have issue: write effor : invalid argument
    Pls see a attach picture and help me
    2. Nomodeset with space before or no?
    Thank
    --- Post Merged, May 2, 2017 ---
    IMG_5835.JPG
     

Share This Page