Has my Macbook 2012 committed suicide?

Discussion in 'Mac Basics and Help' started by jakobaalose, Jan 17, 2017.

  1. jakobaalose macrumors newbie

    jakobaalose

    Joined:
    Jan 17, 2017
    Location:
    Denmark
    #1
    Hello people,

    The problem this time is my Macbook Pro 13" 2012 Medio with MacOS Sierra with a Kingston SSD

    It starts and runs - but then freezes for about 5-10 seconds in intervals. It started suddenly when I just sat and watched some youtube videos. I have tried to run Apple Hardware Analysis. First it was stuck at the Main Logic Board, and in the second time it finished with any issues. It makes the same freeze-thing when openingen MacOS Recovery - it runs the harddrive repair perfectly through. I have also tried resetting the PRAM.

    When I start it up, its alot slowere than before. I can see the CPU temp and it updates as normal, regardless of anything else freezes incl. the mouse. The computer is not at all warm at all, and running at lowest fan speed. It has frozen for some secounds a few times before this in the last couple of weeks, but only when I used Safari - now it's constantly, even if i dont run any programs.

    The only problems i have had with it previously, is that I have twice replaced the SATA cable from the SSD hard drive to the motherboard. It's not quite the same symptoms this time ..

    What can it be? Thank you in advance for your help..
     
  2. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
  3. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    ERondeau makes a good point above.

    OP:
    Have you changed the RAM, as well as the drive?
    If so, do you happen to have the ORIGINAL RAM around?
    If so, have you tried putting it back in?

    Also to consider:
    The internal ribbon cable might have failed again.

    Do you have the original HDD from the Macbook?
    Do you have an external USB3 enclosure you could put it into?
    Have you tried booting and running that way, to see if the hangs "disappear"?
     
  4. jakobaalose thread starter macrumors newbie

    jakobaalose

    Joined:
    Jan 17, 2017
    Location:
    Denmark
    #4
    Hi again,
    Thanks for your answers. I change the harddrive cable and it seemed to work! Its the third time that i change it now... weird!
     

Share This Page