iPhone iOS 11 Bluetooth problems with car

Discussion in 'iOS 11' started by Anders Bob, Sep 21, 2017.

  1. Extravieuxguy macrumors newbie

    Joined:
    Oct 24, 2017
    #51
    Unfortunately, it does not work for me. iPhone 7 is running same IOS and MDX is 2015?
    Thanks anyways, Ray
     
  2. LizJ58, Oct 26, 2017
    Last edited: Oct 26, 2017

    LizJ58 macrumors newbie

    LizJ58

    Joined:
    Oct 26, 2017
    #52
    I’m actually kind of relieved that others are having problems, since it confirms that its not just me and my vehicle!

    The stock Bluetooth system in my 2015 Hyundai was working fine till the iOS 11 update. Contacts downloaded into the sound system so I could use the sound system’s voice control button to place calls.

    Ever since iOS 11, the contacts will not download, so the only way I can initiate a call through the sound system is to click and hold the home button on my iPhone to activate Siri
     
  3. TH5620 macrumors member

    TH5620

    Joined:
    Jan 29, 2016
    Location:
    Mx
    #53
    Double check that all contacts photos are gone also make sure your own photo on iCloud profile is gone
     
  4. Frado macrumors member

    Joined:
    Sep 13, 2009
    #54
    For me it didn't help at all. I repaired and only allowed BT audio now. So for calls I'm forced to use the loudspeaker now. So annoying and the 11.1 beta's don't seem to fix this either.
     
  5. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #55
    I had issues in the past with a new (at the time) Galaxy S7 not working with my Pioneer unit. Pioneer issued a firmware updated that fixed it (installed via USB).

    If you don't have an aftermarket head unit, most (all?) vehicle manufacturers freely offer firmware updates for their entertainment systems on their webpage. Verifying you system is up to date could be the solution like it was for me with the S7.

    With mercedes they will update it for free in a couple minutes if you stop in (in my experience). But they also offer DIY firmware updates on their webpage as well. I know Toyota did as well.

    While BT is a standard the controls and supporting hardware are not. What used to work for iOS 10 might cause a disconnect call in iOS 11. Thankfully for us the iPhone is fairly popular phone (lol) so 3rd part accessory manufacturers are quick to fix compatibility issues and push out updates.
     
  6. Extravieuxguy macrumors newbie

    Joined:
    Oct 24, 2017
    #56
    Guess what, whoa....it’s really working now. What a difference like day and night, all phone numbers showing in my MDX corresponds with the names in the phone book and access is no longer grayed out on the various tabs.

    When I went into my iCloud account, I found there were about 15 photos I deleted using my iPhone 7, but they did not erase in my iCloud. After removing all the photos including the home page one (each time I erased it registered with a flicker on my iPhone address book) I started over, deleting the Bluetooth connection in the car and on my iPhone 7. Started over again and everything stuck so far

    How in the world did the person on uTube figuire this out? Even, the employees at the Apple Genius Bar wouldn’t be able to relate photos attached in the phone book would cause Bluetooth connectivity issues? I wish to thank you very much for offering this temporary fix to me, I can live with it permanently w/o those photo if Apple can not figure it out. Also, I made an error stating my IOS was the same as yours. When I purchased this iPhone 7 three weeks ago , I updated to IOS 11.03 and I had this issue from then. Again, thank you so much.
     
  7. lizquierdo macrumors newbie

    Joined:
    Oct 27, 2017
    #57
    I just called Apple as well and the rep said exactly the same thing. I'm surprised that this hasn't caused more of an uproar and the Apple reps are not being informed about it. I've tested this issue with multiple cars and the iOS 11 is the cause of the problem. Tested on iOS 11.0.3 and issue is still constant where the iPhone connects temporally and then removes it self from Bluetooth. iOS 10 did not have this issue.
     
  8. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #58
    Thanks for posting this!

    I just traded in my 2015 Murano for a 2016 TLX and just got done deleting all my contact photos on my phone and on iCloud so I'll see if this works. I was definitely having issues synching my contacts with my TLX so fingers crossed!

    Another unique issue I found with the TLX, but I guess this is an Acura thing from doing research, I can't have Waze or Google Maps turn by turn directions go over BT unless I'm using BT or iPod as the actual audio source, meaning that I can't be listening to music and have the direction prompts "speak" over the music and if I want to use Waze or Google Maps I have to be connected as a BT or iPod as an Audio source and that is the only thing that will be playing over my car's speakers. Weird...
     
  9. Extravieuxguy macrumors newbie

    Joined:
    Oct 24, 2017
    #59
    Yes, make sure the contact photos deleted on your iCloud too; since, when I deleted them on my iPhone 7 they did not all synch with my iCloud. Due to this, the issue synching my contacts with my MDX continued on the first try. I went through the iCloud contacts line by line and deleted the my home iCloud photo too.

    Waze or Google Maps works the same way as your phone connection using BT; so, it will cut out the whatever audio the speaker was producing; unlike, the car's GPS Navigation system which lowers the audio volume of speaker to provide directions.

    Good luck, Ray
     
  10. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #60
    That's how Waze and Google Maps worked in my 2015 Murano's infotainment system but when using either in my TLX, all it does is show like a BT call is coming through and it cuts out whatever audio is playing like it should but the spoken directions don't come over and then the BT connection disconnects and then reconnects again. I have the Advanced and technology packages on my TLX, not sure if that makes a difference.
     
  11. fedupwithapple2 macrumors newbie

    Joined:
    Oct 29, 2017
    #61
    Hi all . I upgraded to ios 11. Had a perfectly working 6+. Now Bluetooth and headset are not working. The Bluetooth is resetting itself after every call to the lowest possible volume. Every time you make or recieve a call you have to raise the bluetooth volume up.Wired headsets do not work. They stay at the lowest volume. Spent hours at the "genius" bar , they couldn't get it to work. They tried to blame it on the bluetooth headset. Showed them 3 different headsets all with the same problem. Then repaired them with my other phone, the Samsung and they all worked properly. Have spent approx 20-30 hours with apple tech phone support. They will try to have you hard reset the phone. Doesn't help.They have no idea what's going on. They finally agreed that there is an ios 11 issue and that they upgraded the problem to senior engineering people to address.
    As of my latest conversation with my senior tech advisor , they have no idea when it will be fixed.
    The only workaround for those that must have bluetooth on their phone is to get an Apple Watch with cellular. Pair your bluetooth to the phone and it works.
    I know it is an expensive fix, but it is defenitely cheaper than the ticket you will get for holding your phone to your ear when driving.
     
  12. cg006 macrumors regular

    cg006

    Joined:
    Oct 1, 2012
    #62
    2013 accord here with 11.1 beta 4?
    No bluetooth issues so far.
     
  13. parsonsmike macrumors newbie

    Joined:
    Jan 19, 2017
    #63
    Mine is doing the same thing. And I know it's the phone - not the car - because the phone drops the BT connection to my Watch at the same time. Every minute or two, the phone drops all BT connections, then picks them back up about 10 seconds later. It's annoying as all hell.

    EDIT: But I should point out, it *only* does this when the phone is connected to the car hands-free BT. If my Watch is the only BT the phone is connected to, there's no problem.
     
  14. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #64
    All seems to be working like it should, I think that deleting the contact photos also seemed to have corrected my issue with the BT staying connected as well. Fingers crossed this stays working... :)
     
  15. Barbosa84 macrumors newbie

    Barbosa84

    Joined:
    Oct 31, 2017
    #65
    I haverá 8 plus and when friend make my a phone call and i haver the iphone pair on Bluetooth on my smart car of 2017 , the of the contact dont apear! Any one with this issues ?!?
     
  16. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #66
    Never mind, all is not working like it should. I'm back to the BT disconnecting and reconnecting over and over again. On my drive home tonight it seemed like the thing disconnected and reconnected every minute, almost like clock work so the timing seems interesting. My commute is an hour and 5 minutes each way so that's a lot of disconnections, LOL.

    This is crazy, same exact problem that I was having with my Nissan before I traded it in. I tried it on my wife's 2012 Nissan Murano (different factory radio than my 2015 Murano had) and same problem with my 8 plus in her's. Her iPhone 6 on iOS 11.0.3 works fine though in her ride so I wonder if it's my phone that has a messed up BT radio in it or if certain iPhone 8/8 Plus's have the connection issue.

    After deleting all the photos in my address book on my phone that resolved my contacts synching on my Acura but I still have the issue where the damn phone won't stay connected to the car. I wanted to throw the phone out the window on my way home tonight :D
     
  17. Ted2017 macrumors newbie

    Joined:
    Nov 1, 2017
    #67
     
  18. ZeMiguel macrumors newbie

    ZeMiguel

    Joined:
    Nov 1, 2017
    #68
    I have the iPhone 8 w/ iOS 11.1.
    I also have a Mercedes CLA which has 2 BT connections: one for telephone and messaging purposes and another for a proprietary app in the iPhone (the Mercedes ME Adapter) which connects to an adapter connected directly to the car.

    I had an iPhone 5s w/ iOS 10.3.3 and it worked perfectly w/ the two connections simultaneously.

    Now, w/ the iPhone 8 the BT is always dropping. I had to disconnect the ME Adapter in order to have the phone working without dropping the BT connection.
    I’ve read in another thread here that Apple is not doing anything regarding the various BT connection matters.

    Well, I´ve done everything in my power in order to solve this issue:
    1) resetting the system;
    2) removed the adapter;
    3) restored the BT connections;
    4) removed the app;
    5) factory settings in the iPhone;
    6) restored the iPhone...
    And guess what: the problem persisted (even with the newest 11.1 which I’ve just tested).
    I’m just tired of all this.
     
  19. jhersco macrumors newbie

    Joined:
    Dec 20, 2008
    #69
    I just updated to iOS 11.1, deleted and re-added my iPhone and the problems remain. I do not have any contact photos. I reported the issue to Acura tech support and they said that it’s up to Apple to fix this. He had no info regarding any timetable. If you haven’t already done so, please report your issues to Apple -https://www.apple.com/feedback/iphone.html
     
  20. Barbosa84 macrumors newbie

    Barbosa84

    Joined:
    Oct 31, 2017
    #70

    I allready done this today.
    The customer service have a lot of complains.
    But is better call them and make pression on apple
     
  21. ZeMiguel macrumors newbie

    ZeMiguel

    Joined:
    Nov 1, 2017
    #71
    I’ve just tested my other iPhone (a 5s) with iOS 11.1 in my Mercedes and there is no problem with the 2 BT connections in the car.
    Tried with my iPhone 8 again and it drops the BT connections instantly.
    The Mercedes rep told me today that the problem must be related with the BT version (iPhone 8: 5.0; iPhone 5s: 4.0).
    I.e., I’ve just confirmed that the problem is not from iOS 11 but from the mobile itself.
     
  22. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #72
    I had a feeling the issue was with the actual BT Radio.
     
  23. sum1else macrumors newbie

    Joined:
    Nov 6, 2011
    #73
    2014 X3 3.5. IPhone X running beta 11.2. Bluetooth cuts out after 30 seconds. Cannot play anything using USB. USB connection appears to have caused my car computer to crash twice. Never had any problems with my iPhone 7 Plus up until the iPhone X came.
     
  24. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #74
    iPhone 7/7+ uses BT 4.2 and iPhone X/8/8+ uses BT 5.0 along with the Sammy GS 8's, I have a feeling that our cars aren't compatible with BT 5.0 and that's what's causing our issues. Just a hunch and I could be wrong.
     
  25. Frado macrumors member

    Joined:
    Sep 13, 2009
    #75
    So it would be up to the car brand to issue an update for their systems? Just checked with BMW but they don't have any recent updates I'm afraid.
     

Share This Page