iPhone iOS 11 Bluetooth problems with car

Discussion in 'iOS 11' started by Anders Bob, Sep 21, 2017.

  1. mloiterman macrumors newbie

    Joined:
    Aug 2, 2008
    #76
    This is the exact problem I have.


    Could you try erasing all network settings and seeing if that works for you? It didn’t for me.
     
  2. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #77
    If you're on an iPhone X/8/8+, the issue is most likely that you're car isn't compatible with BT 5.0 and either Apple will need to make the BT 5.0 radio better backwards compatible with older devices through an update or your car manufacturer will need to update your firmware in your radio/infotainment system to make it compatible with the new BT. Chances are, your car manufacturer isn't going to do anything.
     
  3. andx macrumors member

    Joined:
    Oct 3, 2017
    #78
    I think it's an excuse...
    They told the same also with speaker or headphone...
    How can you update a headphone ?
    My car for example was unable to connect iphone with ios 10.1, apple told my car manufacturer must update...but no problem with 10.2...
     
  4. mloiterman macrumors newbie

    Joined:
    Aug 2, 2008
    #79
    I get what you’re saying, but I saw the exact same behavior with my iPhone 7 only AFTER updating to iOS 11. Prior to iOS 11, my iPhone 7 worked perfectly with the same car.

    It’s possible there is some compatability issue with the Bluetooth hardware in the new iPhone when linked with my BMW. But it seems unlikely that I would have the exact same behavior and failures with iPhone 7 and iPhone X if hardware were the root cause of the problem.
     
  5. andx macrumors member

    Joined:
    Oct 3, 2017
    #80
    It’s absolutely a software issue, not hardware;
    Issue are exactly the same with SE, 6,7,8,X ecc.
    No problem with 10.3.3
    For example my car didn’t loss connection with spotify or play music, but did when i reproduce apple music....
    Same with my iphone SE and iphone 8 plus
    How this could be hardware ?!
     
  6. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #81
    I definitely think this can be fixed by Apple with some form of software/firmware update for the BT radios in iOS 11 so they can be backwards compatible with our cars. This is utterly ridiculous.
     
  7. andx macrumors member

    Joined:
    Oct 3, 2017
    #82
    In previous firmware apple still say : car fault, but fixed with update after some month...
    Still said also to ford users “car fault”, but 11.1 fixed with ford sync
     
  8. Frado macrumors member

    Joined:
    Sep 13, 2009
  9. andx macrumors member

    Joined:
    Oct 3, 2017
    #84
    Beta 1 exactly same issue of 11.1
    Beta 2 completely stop working
     
  10. Hisartwork macrumors newbie

    Hisartwork

    Joined:
    Nov 9, 2017
    #85
    i have a 2012 Mazda 3 and Bluetooth also worked fine on my 6S until ios11. Since 11 The music still plays normal, but phone calls are extremely low, even at MAX volume you can barely hear. Tried repairing the phone, nothing. Just upgraded to iPhone 8. Same exact issue.
     
  11. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #86
    I'm running 11.2 public beta 2 right now on my 8 Plus, installed it on Tue night and so far yesterday and today I haven't had my BT disconnect from my Acura. I'm not getting too excited yet but so far so good the past 2 days. I'll keep an eye on it and see how it keeps performing.
     
  12. MacLadybug macrumors 6502a

    MacLadybug

    Joined:
    Jun 6, 2008
    #87
    My husband and I both have 6S Plus phones now running iOS 11.1. Only my iPhone seems to be affected. It started as soon as I upgraded to iOS 11. Had my BMW for 3 years and 3 iPhone models... 4S, 5S, and 6S Plus. All have integrated perfectly. Typically my husband's and my phone both are paired and connected at the same time when we are both in the car. Whoever gets an incoming call, the car's bluetooth picks up. Since iOS 11 my phone seems to keep losing it's connection. When it happens the only way to reconnect is to remove the device from the car... forget the device on the iPhone and re-pair the connection. I was hoping 11.1 would fix it but I have experienced no change. Nothing is wrong with my iPhone, I know it's the iOS. How much longer until they fix this? I'm not used to Apple issues... this is wearing me out.
     
  13. jhersco macrumors newbie

    Joined:
    Dec 20, 2008
    #88
    For me, the problems with my iPhone and my Acura RDX started with iOS 11 running on an iPhone 7 Plus. That that iPhone didn't have Bluetooth 5.0.
     
  14. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #89
    This is also my experience.

    So far, I have failed with my original 7 Plus (Intel), my backup iPhone SE (Qualcomm), and a new 8 Plus (Qualcomm).

    Just in case, I have an X (Intel) on the way, and I'll give it a try. But I really and truly do not believe that I want an iPhone that does not work with my car's Bluetooth.

    In another thread, a user of 11.2 beta versions says that he is okay, but he hasn't answered the question yet whether he was having a problem before 11.2, and that 11.2 made it better.

    Meanwhile, my LG V30 is working embarrassingly perfectly, and I am facing the prospect of having to figure out how to have a V30 in my otherwise all-Apple ecosystem, and having to start using a "work phone" because I cannot use the V30 for work (at one job).

    This is all very discouraging and very un-Apple-like, and I wish they'd admit there's an issue they need to fix, and get on with it!!
    --- Post Merged, Nov 11, 2017 ---
    Thank you!

    That is very encouraging. :)

    It almost makes me want to rejoin beta testing!
     
  15. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #90
    So far through last night, no connection drops as of yet since I installed 11.2 PB2 on Tuesday.

    I’m hoping nothing gets broken whenever PB3 comes out as I’m quite pleased so far. Other than BT working as it should, PB2 has been running very solid and fluid on this beta so far. As reference, my BT was still jacked on 11.2 PB1 so I think Apple did a positive change to the BT stack in PB2. Maybe enough people submitted bug reports.

    The only issue/bug I’ve had is that when my phone detects any BT connection, the music app likes to start playing upon connection and I’ve submitted a bug report for that.
     
  16. MikeRadio macrumors newbie

    Joined:
    Jul 25, 2010
    #91
    I am having the disconnect problem with iPhone X and 11.1.1.

    Seems to disconnect often when connecting then is OK after awhile.

    I have Acura TLX

    Does anyone with Acura TLX running 11.2 beta 2 still have this issue?
     
  17. johnny hotsauce macrumors regular

    Joined:
    Nov 7, 2011
    #92
    2016 Acura TLX Tech & Advanced packages, using an iPhone 8 + on iOS 11.2 beta 2 and so far no issues and the phone stays connected to the car. All previous versions of iOS 11 wouldn't stay connected. So far 11.2 beta 2 seems to be solid since installing it last Tuesday.
     
  18. rworne macrumors 6502

    Joined:
    Jul 23, 2002
    #93
    I'm on the beta too. Phone calls work, Music app works, Spotify acts like it's working, but puts out no sound at all. No problem with disconnects.

    This is on a Toyota Sienna w/OEM Nav and a Honda with an aftermarket Kenwood that had issues after the iOS 6 update.
     
  19. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #94
    Very encouraging. Thank you.
     
  20. scott_donald macrumors member

    Joined:
    Nov 2, 2016
    #95
    11.2 Beta 2, added feedback for this -

    Phone playing music on Mercedes, either Spotify or Music over Bluetooth.
    Use Siri to call.
    Returns to either say music paused when on device the music is playing but certainly no sound out of car speakers.

    frustrating and have to re start Music or Bluetooth to get it working again.

    If I use car bluetooth, go home for lunch use Spotify from my phone on my Sonos then go back into the car again no sound but playing on device.

    Reset app and works again...

    Frustrating and no very safe to fix whilst driving...
     
  21. itsgoofy macrumors newbie

    Joined:
    Nov 14, 2017
    #96
    IPhone X - IOS 11.1.1 with BMW 5 series 2011. Bluetooth software latest version in car.
    Like other car owners the issue is exactly the same for my car. The connecting keeps on being refreshed - on and on. Extremely annoying. Will also test other functions as I learned from others in this thread that also other functions might not work properly anymore.
    Waiting for apple to resolve (again).
     
  22. wendellg85 macrumors newbie

    Joined:
    Sep 1, 2009
    #97
    Same problem here, iPhone 8+ iOS 11.1 with BMW M235 2015. iPhone Music & Audible sound does not come through car audio despite BT showing as being connected. It worked fine until yesterday and I hadn't updated the iOS at that time. Just did the 11.1.1 update but not expecting it to help based on feedback here.

    Apple please fix this, it's ridiculous.
     
  23. ukwildcatfan2017 macrumors newbie

    Joined:
    Wednesday
    #98
    I have an Iphone 6s (do not judge) and a subaru outback.
    Noticed that as I was listening to phone through bluetooth and then playback was interrupted the bluetooth would show connected on radio but no sound.
    Found turning SIRI on and of would reestablish connection.
     
  24. silvetti macrumors 6502a

    silvetti

    Joined:
    Nov 24, 2011
    Location:
    Poland
    #99
    By the way, this mostly happened to me with Apple Music, I have since switched to Tidal (free with my mobile plan) and I have no issues anymore.
     
  25. pdm32 macrumors newbie

    Joined:
    Wednesday
    #100
    --- Post Merged, Nov 15, 2017 at 6:40 AM ---
    In my case, on a X, after the 11.1.1 update, BOTH Bluetooth and USB connections drop after a few minutes in a 2015 BMW X3. The X has been terrific, until this.
     

Share This Page